Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. Is anyone else having this issue?
    [​IMG]
    I deleted my player data from the world and rejoined and im being vanished, Please note im not using vanishnopacket and essentials /vanish does not remove it, only way to remove it is drinking milk or /heal but once i relog i get it again. i tried as a regular player and opped. also i dont have any plugins that adds any sort of potion effects when you join etc.
     
  2. I believe this is what is happening to me
     
  3. Get out of my server. -_-

    Thank you, I'll rename it and give it another shot, mang. That didn't even occur to me.

    It's moving now. Udabes.
     
  4. anyone totally lost? Why couldn't the jar file downloads be directly available? Those instructions on compiling make no sense to me...
     
    • Agree Agree x 3
    • Funny Funny x 3
  5. TowelieDOH

    Supporter

    Thank you very much for all the work you have put into this!
     
    • Agree Agree x 1
  6. danjb2000

    Retired Supporter

    Woo! Good luck all
     
  7. @md_5, can you verify if this is allowed, or should I remove my links?
    EDIT: I will keep it up until further notice, I am treating your silence on the matter as allowing it.
     
  8. JamesJ

    Supporter

    Nice!
    Thanks!
     
  9. [​IMG]

    Had git 1.8.3. Deinstalled and installed 1.9.4 as per your link and tried again, made no difference.
     
  10. I seem to be encountering an error.

    Code (Text):
    Patch failed at 0004 Obfuscation Helpers
    The copy of the patch that failed is found in:
       d:/USR_DATA/Downloads/Spigot/Spigot-Server/.git/rebase-apply/patch
    When you have resolved this problem, run "git am --continue".
    If you prefer to skip this patch, run "git am --skip" instead.
    To restore the original branch and stop patching, run "git am --abort".
      Something did not apply cleanly to Spigot-Server.
      Please review above details and finish the apply then
      save the changes with rebuildPatches.sh
     
     
  11. md_5

    Administrator Developer

    Can you please run this again from a directory with JUST BuildTools in it.
     
    • Agree Agree x 1
  12. Anyone manage to get CraftBook running?
     
  13. I'm ending up with Spigot, Bukkit, Craftbukkit, work, BuildData and a Maven folder, but no jars. Used Git-1.9.4, and tried multiple times. Am I doing something wrong here?
     
  14. This fixed it for me.
     
  15. Im downloading the prerequisites to my phone at work just in case there's some issue or another DMCA (as its already being threatened). Not taking any chances on missing out on this one ;)

    Also, would there be any objection to saving a lot of us the decompiling by allowing someone who knows what they're actually doing and putting the final jars up for download? Or, at some point, put them up officially?

    I understand that's its a simple process (by the what the instructions state) but a lot seem to be having trouble with this method. And I fear I'll tank it some how...
     
    • Agree Agree x 1
  16. I have no idea how to do this lol? i have downloaded everything but what command do i put in the Git bash and where do i put the BuildTools.jar
     
    • Agree Agree x 1
  17. Does this require Java 1.8, or can I compile with 1.7 ?
     
  18. jeff142

    Benefactor

    Its all redy been made by so may in the community that even if the downloads vanish now it would still spread
     
    • Agree Agree x 1
  19. I compiled it for my mirror with Java 1.7.
     
    • Agree Agree x 2
  20. I think you look at the spawner once its placed and type /spawner mobname and it should change it
     
Thread Status:
Not open for further replies.

Share This Page