Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. I would have thought updates would have been posted as they always have, I don't see the team being secretive about it, they never have!

    From what I understand, the earlier version of buildtools itself had an error in it, hence the updates to version 8.
     
  2. GunfighterJ

    GunfighterJ Retired IRC Staff
    Retired

    We aren't being secretive, all commits are public. It's just a waste of time to write a new topic on here for every single commit.
     
  3. This is my experience, too. Updates are being fetched from the repositories even if BuildTools hasn't changed.
     
  4. Mine does not work and I would really appreciate some help.

    I am doing this on windows and have done it twenty one times now each with the same result. I've done it with Git Bash and a run.sh with the same results each time. I get no errors and always end up with a set of folders but there are no .JAR files any where. I've done entire PC searches looking for them and they just didn't happen. I mean I could try and pack the jar file my self if I'm being given the files but i don't see what all needs to be included, there's a lot of random files in here and none of it makes in since or look like what i would expect in a jar file.

    Any suggestions? My Skype is "Live4Redline" if someone wants to give me *edited* a hand.
     
    #1544 live4redline, Dec 1, 2014
    Last edited: Dec 1, 2014
  5. GunfighterJ

    GunfighterJ Retired IRC Staff
    Retired

    Don't ask for jars. Have you read the wiki page? Please provide logs of the entire build process as well on pastebin.
     
  6. i was having an issue with my red stone/hopper sorter seems like hoppers are moving stuff to fast and not sorting down to sort hoppers anybody see this or know if this issue has been fixed ?

    @md_5 have you heard anything about this ? also big thanks to you and all how have worked on this project
    i wish i knew a little more about debugging so i could look in to the hopper red stone issue i am having my self

    also for reference it's the sorting system impulsesv uses with the x79 gold farm build but i am sorting in to a row of 15+ chests worked fine before the witching to spigot

    i may have figured out what changed i need to play with hopper-checks value from what i have read hopefuly that will fix my issue (just in case someone has come across this issue and is not sure whats going on)
     
    #1546 Flakes33, Dec 1, 2014
    Last edited: Dec 1, 2014
  7. ChestShop updated. Anyone tested it yet?


    EDIT (double post is dumb):
    Every time I place a block, my console prints a message. Any tips on what is causing that?
     
    #1547 Kanegae, Dec 1, 2014
    Last edited: Dec 1, 2014
    • Informative Informative x 1
  8. Sorry but can someone helps him ^^ please? I couldn't help because Im not familiar with Bungee (never used in production stage) @Marc-Andre try contacting @sk89q on his IRC/forum/twitter/tracker for this. I guess it affects many servers running on Bungee, updating to WG 6 could make a mess x.x?
     
  9. I agree with you , sometime we can't compile it due to other issues such as running a mac,we do find ways around it though.
    However this does not stop me from running a successful server.
     
  10. I have almost the same issue... but it seems like my chunks don't get unloaded... Is it multiverse?
     
  11. Same problem here .. just created a folder (name: server) and run BuildTools in it, but it fails with error "cmd" is not recognized .. so how can I create a path without spaces??
     
  12. Create a folder in root?
     
  13. Create a folder in C:\. Like in C:\server
     
  14. Fixed my original post with an edit.

    I have read the wiki page several times and everything seems to work as expected till you get to step "6." and there is no folders with these names or any jar files. I have a Spigot folder that contains a ".git", "Bukkit-Patches" and "CraftBukkit-Patches" folders and some random files about patches and upstreamMerge. Same for the Bukkit and Craftbukkit folders.

    The result size is 83mb with 1633 files and 230 folders. Had to do some google on how to log a command prompt but heres a pastebin of my output... http://pastebin.com/TxXv9v55

    Thanks for any help.
     
    #1554 live4redline, Dec 1, 2014
    Last edited: Dec 1, 2014
  15. Is anyone having a problem with essentials signs not working? They are enabled in the config just not working and when i try to make a new sign it acts as if signs are not enabled. I'm using the essentials 2.x
     
  16. Hm, that's not written in the first post .. but thank you, I'll test it. :)
     
  17. Getting this error now .. :(
    upload_2014-12-1_18-30-30.png
     
  18. GunfighterJ

    GunfighterJ Retired IRC Staff
    Retired

    Haven't seen that one yet. Try redownloading buildtools.
     
  19. THANKS! After I do the " Git Bash " and do the " JAVA_HOME="C:\Program Files\Java\jdk1.8.0_25" java -jar BuildTools.jar " it makes all those folders. Do I just move " spigot-1.8-R0.1-snapshot.jar " into a new folder on the desktop and then open the server in that folder or do I just make the server in the folder it's already in? I am wondering, would it matter if I just move the Snapshot ONLY to a new folder and it'll still work or no?
     
    #1559 jedycus, Dec 1, 2014
    Last edited: Dec 1, 2014
  20. GunfighterJ

    GunfighterJ Retired IRC Staff
    Retired

    Move the spigot jar from the build system, otherwise it will be overwritten next time you run buildtools to update.
     
    • Informative Informative x 1
Thread Status:
Not open for further replies.