Bukkit, CraftBukkit, Spigot & BungeeCord 1.12.1

Discussion in 'News and Announcements' started by md_5, Aug 3, 2017.

Thread Status:
Not open for further replies.
  1. Handsome and talented? Wow. Great stuff, guys!
     
  2. 2008Choco

    Resource Staff

    Nope. Only those that mess with the protocol should need to be updated (i.e. ProtocolLib, ProtocolSupport, ViaVersion, etc.). There was no NMS package bump, therefore resources that use NMS should not be affected majorly (although there is a chance that it may be broken, it's likeliness is negligible).
     
    • Like Like x 2
    • Informative Informative x 1
  3. It's really amazing how fast these things come out. Amazing work as always @md_5 and contributors.
     
  4. @md_5 will everything for 1.12 work with 1.12.1?
    I just started updating one of my servers to 1.12 XD
     
  5. 2008Choco

    Resource Staff

    Read above, please
     
  6. I'm unable to update to this version (as clearly shown in me previous reply to this post). It's kinda sad no one is helping out..
     
    • Agree Agree x 1
  7. 2008Choco

    Resource Staff

    Delete all files in your BuildTools directory (excluding BuildTools.jar itself, of course) and re-run it.
     
  8. I've tried that but it doesn't work. It does download / extract all folders again but after that it represents me with the same FileNotFoundException.

    Code (Text):
    Final mapped jar: work\mapped.73f3c166.jar does not exist, creating!
    Loading mappings
    Exception in thread "main" java.io.FileNotFoundException: BuildData\mappings\buk                                                                                                                                                                                               kit-1.8-cl.csrg (Het systeem kan het opgegeven bestand niet vinden)
            at java.io.FileInputStream.open0(Native Method)
            at java.io.FileInputStream.open(FileInputStream.java:195)
            at java.io.FileInputStream.<init>(FileInputStream.java:138)
            at java.io.FileReader.<init>(FileReader.java:72)
            at net.md_5.specialsource.JarMapping.loadMappings(JarMapping.java:236)
            at net.md_5.specialsource.SpecialSource.main(SpecialSource.java:212)
    Exception in thread "main" java.lang.RuntimeException: Error running command, re                                                                                                                                                                                               turn status !=0: [java, -jar, BuildData/bin/SpecialSource.jar, -i, work\minecraf                                                                                                                                                                                               t_server.1.8.jar, -m, BuildData/mappings/bukkit-1.8-cl.csrg, -o, work\mapped.73f                                                                                                                                                                                               3c166.jar-cl]
            at org.spigotmc.builder.Builder.runProcess(Builder.java:456)
            at org.spigotmc.builder.Builder.main(Builder.java:237)
     
     
    • Funny Funny x 2
    • Agree Agree x 1
  9. electronicboy

    IRC Staff

    delete the buildtools folder itself, disable your antivirus. Beyond that, make sure that there are no spaces in the file name or any weird characters, create a folder on your C drive... if that doesn't work, there is an issue with your computer *shrugs*
     
  10. If a server updates to spigot 1.12.1, will the players still be able to connect with the 1.12 version ?
     
  11. 2008Choco

    Resource Staff

    No, a protocol bump was made, therefore you cannot join a 1.12.1 server with a 1.12.0 client and vice versa
     
  12. *reads the changelog on the wiki for Mojang's Minecraft*
    oh, so .. security fix, and ... a class update.

    Ok, now we wait for 200 plugins to update and test and confirm to work. Because I got nothing better to do tonight :)


    lol, WHY DO WE LIKE DOING THIS TO OURSELVES.

    *stuff face with pizza*


    Thanks md_5 for updating Spigot so swiftly. I appreciate it that you're as on top of it as i am on this pizza.
     
    • Agree Agree x 1
  13. You have to wait for ProtocolLib to be 1.12.1 supported, so ViaVersion can upgrade. Then you can use that to allow 1.12.1 to connect to 1.12.
    If it hasn't already, i'd say you would be by tomorrow. They're both active plugins and quite on top of it.



    Oh, friendly reminder to everybody

    - backup your working version.
    - clone your working version and upgrade/test that.

    :)
     
    • Funny Funny x 1
  14. smmmadden

    Benefactor

    ViaVersion was updated earlier today for 1.12.1 - so one down. :)
     
    • Like Like x 1
  15. That's for 1.12, to accept 1.12.1, but not viabackwards yet, to allow 1.12 to connect to 1.12.1
     
  16. The Auctions House plugin is the only one that gave me issues. All other plugins (after grabbing their nightlies) upgraded/updated just fine.
    All plugins that we use on the 1MB network (some servers use 3 plugins, others 30) all started, use, stopped just fine. Their basic expected functions tested and worked fine. That's over 60 plugins, and only one failed. I am quite happy with that. We run in -test- setup. So it's easy to rollback. But it seems to all be fine. I was afraid i'd be spending a few days on this again, but all went well

    just reporting back. If you are an owner and hesitant to upgrade, then backup, clone - new port, upgrade, test, and test again..
     
  17. Release name Version 1.12.1
    protocoll 338

    You can find the protocollnumbers here ;)
    http://wiki.vg/Protocol_version_numbers
    so u see since a longer while its normal that u need to have the servers version

    Interesting in the patchlog:
    Code (Text):

    Private issues
    *MC-119011 – Security issue with recipe book
     
    clever mojang, someone could test if this is fixing the 1.12 duplication glitch?
     
    #38 CloudeLecaw, Aug 4, 2017
    Last edited: Aug 4, 2017
  18. ProtocolSupport (dev) was updated yesterday aswell! :)
    ProtocolLib is still underway.
     
  19. I run the buildtools shell on windows - is there any way to pass that argument?
     
Thread Status:
Not open for further replies.

Share This Page