Bukkit, CraftBukkit, Spigot & BungeeCord 1.12.2

Discussion in 'News and Announcements' started by md_5, Sep 18, 2017.

  1. i want build a 1.8.8 version using the last buildtools compilation but icant build

    fatal: could not open '.git/rebase-apply/author-script' for writing: Permission denied
    Something did not apply cleanly to Spigot-Server.
    Please review above details and finish the apply then
    save the changes with rebuildPatches.sh
    Error compiling Spigot. Please check the wiki for FAQs.
    If this does not resolve your issue then please pastebin the entire BuildTools.log.txt file when seeking support.
    java.lang.RuntimeException: Error running command, return status !=0: [C:\Program Files\Git\usr\bin\bash.exe, applyPatches.sh]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:555)
    at org.spigotmc.builder.Builder.main(Builder.java:437)
    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:23)


    some buildtools to create 1.8.8 build?
     
  2. I totally didn't see that part :D
     
    • Agree Agree x 1
  3. Praya

    Benefactor

    is this still R1?
     
  4. That looks like zuiy
     
  5. Are there much changes to the core or does every Plugin that works for 1.12.1 does also work for 1.12.2?
     
  6. Cloned the live server..
    Got the latest 1.12.1 build, upgraded all the plugins, tested that.
    Backed up the live server and the working test.
    Cloned the test server and upgraded to 1.12.2, and tested that.

    Everything went fine, moved the 'last working' backup of 1.12.1 to the offsite backup server.
    Moved the 1.12.2 working test server to our live server.
    And cleaned up the test environment.

    Everything went smooth, fast, and none of the plugins had issues with 1.12.1 or 1.12.2.
    If everything stays fine, we push it to the rest of the servers on the network after backing those up first.
     
  7. It works on windows 8.1 x64 with Git Bash
     
  8. Go SpigotMC! Thank you!
     
  9. I'm having a heck of a time with 1.12.2. With all plugins removed, load terrain takes a while, then I get into the world and am instantly kicked from the server showing as time out connection forcibly closed by remote host. In the console it just says player lost connection:user was kicked.
     
  10. What AntiCheat are you using?
     
  11. Spartan, but it occurs with all plugins removed. What's really confusing is the last few lines of the debug references a skin I don't use.

    [15:17:32] [Server thread/INFO]: [Server] Welcome back, Killertunes
    [15:17:32] [Server thread/INFO]: [CONSOLE->Killertunes] Hey there, Killertunes!
    [15:17:32] [Server thread/INFO]: [CONSOLE->Killertunes] Welcome to FunWithBlocks.com
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Opening connection to https://api.mojang.com/profiles/minecraft
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Writing POST data to https://api.mojang.com/profiles/minecraft: ["mhf_sheep"]
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Reading data from https://api.mojang.com/profiles/minecraft
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Successful read, server response was 200
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Response: [{"id":"dfaad5514e7e45a1a6f7c6fc5ec823ac","name":"MHF_Sheep"}]
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Page 0 returned 1 results, parsing
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Successfully looked up profile [email protected][id=dfaad551-4e7e-45a1-a6f7-c6fc5ec823ac,name=MHF_Sheep,properties={},legacy=false]
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Opening connection to https://sessionserver.mojang.com/se...aad5514e7e45a1a6f7c6fc5ec823ac?unsigned=false
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Reading data from https://sessionserver.mojang.com/se...aad5514e7e45a1a6f7c6fc5ec823ac?unsigned=false
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Successful read, server response was 200
    [15:17:35] [Head Conversion Thread - 0/DEBUG]: Response: {"id":"dfaad5514e7e45a1a6f7c6fc5ec823ac","name":"MHF_Sheep","properties":[{"signature":"gF
    [14:28:48] [Head Conversion Thread - 0/DEBUG]: Successfully fetched profile properties for [email protected][id=dfaad551-4e7e-45a1-a6f7-c6fc5ec823ac,name=MHF_Sheep,properties={textures=[[email protected]]},legacy=false]
    [14:29:01] [Server thread/INFO]: Killertunes lost connection: user was kicked.
    [14:29:01] [Server thread/INFO]: Killertunes lost connection: Timed out
    [14:29:01] [Server thread/INFO]: Killertunes left the game

    It looks like its pulling the wrong profile from mojang.
     
    #51 killertunes, Sep 24, 2017
    Last edited: Sep 24, 2017
  12. Debug from a normal player account. It's a little different but the outcome is the same. Long Load Terrain time (longer than 1.12.1) then instant kick on console side with timed out note and the player sees disconnected, timed out, or a java error.
     

    Attached Files:

  13. electronicboy

    IRC Staff

    have you tried with a fresh world or something, there really isn't any changes between 1.12.1 -> 2 that could cause that that I'm aware of
     
  14. I renamed scoreboard.dat in the data folder for my spawn map. It was much bigger in size than all the other dat files. Turns out its placed there by mcMMO. It no longer kicks users from the server. Load Terrain is faster. That problem has been worked around.

    but

    I still have a java error in the middle of the startup with the debug on. I'm disregarding it because everything seems to be working. lol Thanks for pointing me towards the world files.
     
    #54 killertunes, Sep 24, 2017
    Last edited: Sep 24, 2017
  15. Thank you for the speedy updates! Although tiny, these updates matter a great deal especially for updating BKC. You're so fast lately it is me that is caught unaware of new minecraft versions :)
     

  16. I did this, but I still only have v 1.12.1
    Help?

    Output:
    [email protected]:~/minecraft $ ls spigot*.jar
    spigot-1.12.1.jar
    [email protected]:~/minecraft $ java -jar BuildTools.jar --rev 1.12.2
    Loading BuildTools version: git-BuildTools-59469f0-61 (#61)
    BuildTools
    [email protected]
    Attempting to build version: '1.12.2' use --rev to override
    Found version
    {
    "name": "1404",
    "description": "Jenkins build 1404",
    "refs": {
    "BuildData": "a9c4523879abc011821f06283dd468c67c3b0097",
    "Bukkit": "4f16bdbabbad82b6130b19bcc0a4621dee83e86e",
    "CraftBukkit": "94b098085269b86ae8f926fe64e06fa3fbe6a7ca",
    "Spigot": "775423189fea374bf4f1d0391c4cf242e741185f"
    },
    "toolsVersion": 47
    }

    Pulling updates for /home/pi/minecraft/BuildData/.git
    Exception in thread "main" org.eclipse.jgit.api.errors.JGitInternalException: Exception caught during execution of reset command. Unknown DIRC version 16,386
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:234)
    at org.spigotmc.builder.Builder.pull(Builder.java:523)
    at org.spigotmc.builder.Builder.main(Builder.java:250)
    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:23)
    Caused by: org.eclipse.jgit.errors.CorruptObjectException: Unknown DIRC version 16,386
    at org.eclipse.jgit.dircache.DirCache.readFrom(DirCache.java:493)
    at org.eclipse.jgit.dircache.DirCache.read(DirCache.java:433)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:253)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:327)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:293)
    at org.eclipse.jgit.lib.Repository.lockDirCache(Repository.java:1183)
    at org.eclipse.jgit.api.ResetCommand.checkoutIndex(ResetCommand.java:404)
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:207)
    ... 3 more
    [email protected]:~/minecraft $ ls spigot*.jar
    spigot-1.12.1.jar
    [email protected]:~/minecraft $
     
  17. electronicboy

    IRC Staff

    delete the buildtools folder and run it again, looks like the git repo on your device is corrupted
     
  18. Hi!
    I don't know where to write, so I wrote here.
    I have found abnormal values with some plugins which show player ping value
    They use code like:
    Code (Text):
    ((CraftPlayer)p).getHandle().ping
    Some times when player join the server, ping values are wrong. 4-seconds-intervals:
    1. 292639857 <<<=== ????????????? abnormal value
    2. 136618928 <<<===decreasing
    3. 72169964 <<<===decreasing
    4. 35569982 <<<===decreasing
    ...
    N-th. 65 <<<=== normal

    So I've looked into code:
    Code (Text):

    package net.minecraft.server.v1_12_R1;
    ...
    public class EntityPlayer extends EntityHuman implements ICrafting {
    ...
    public int ping; <<<=== this is "ping" declaration
    ...
    }
    Code (Text):

    package net.minecraft.server;
    ...
    public class PlayerConnection implements PacketListenerPlayIn, ITickable {
    ...
    public void F_() {
    ...
            if ((long) this.e - this.h > 40L) {
                this.h = (long) this.e;
                this.g = this.e(); <<<=== only here assignement
    ...
    }

    ...
        public void a(PacketPlayInKeepAlive packetplayinkeepalive) {
            if (packetplayinkeepalive.a() == this.f) {
                int i = (int) (this.e() - this.g); <<<=== here "g" is using
                this.player.ping = (this.player.ping * 3 + i) / 4; <<<=== calculate ping
            }
        }

        private long e() {
            return System.nanoTime() / 1000000L;
        }
    ...
     
    Looks like some times function "a(...)" is runned before "this.g" initialization in function "F_()"
    so,
    int i = (int) (this.e() - this.g)
    is
    int i = (System.nanoTime() / 1000000L) - 0
    and "i" becomes very large.
    Then "F_" is called and "g" gets normal value and then ping begins decreasing every recalculation step by step to its normal value

    Could you look into code and check it?

    Sorry for english
    :(

    PS. May be it's needed to assign "g" in constuctor or in declaration? like:
    private long g = System.nanoTime() / 1000000L;
    :rolleyes:
    or:
    Code (Text):
        public void a(PacketPlayInKeepAlive packetplayinkeepalive) {
            if (packetplayinkeepalive.a() == this.f) {
                int i = (int) (this.g==0 ? 0 : this.e() - this.g);
                this.player.ping = (this.player.ping * 3 + i) / 4;
            }
        }
     
    :rolleyes::rolleyes::rolleyes:
     
    #58 bottomdumber, Sep 26, 2017
    Last edited: Sep 26, 2017
  19. md_5

    Administrator Developer

    That code is not from 1.12.2, and I can't reproduce this with a Vanilla client in 1.12.2, the client shouldn't be sending InKeepAlive before server has sent OutKeepAlive. It did in 1.12.1 when loading sometimes, but you should update.
     
    • Informative Informative x 1
  20. Okey, I will test it on last version (1.12.2) :)
    ...But it is seemed that this "bug" will be repoduced again.

    May be this is because of BungeeCord, that redirects packets between client and server
    We have one BungeeCord and two Spigot servers (Lobby and Survival). Just imagine :rolleyes::
    1. First, I do connect with client to my server and BungeeCord redirects me to Lobby-Spigot
    2. Normal situation: Lobby-Spigot sends OutKeepAlive and client sends InKeepAlive. This is ok...
    3. Abnormal situation: Lobby-Spigot sends OutKeepAlive but at this moment I'm moving from Lobby to Survival and BungeeCord begins redirect packets to Survival-Spigot.

    So. OutKeepAlive has been sent by Lobby-Spigot but InKeepAlive has been get by Survival-Spigot. This is situation when Spigot gets InKeepAlive before OutKeepAlive. Is it possible?:rolleyes:
     

Share This Page