Bukkit, CraftBukkit, Spigot & BungeeCord 1.12-pre6 Released

Discussion in 'News and Announcements' started by md_5, May 14, 2017.

Thread Status:
Not open for further replies.
  1. Thanks!!! Download link ?
     
    • Funny Funny x 5
  2. This is awesome, there is literally nothing that can stand in the way of spigot!
     
  3. md_5

    Administrator Developer

    Read the post
     
    • Optimistic Optimistic x 2
    • Agree Agree x 1
  4. Thank you for beeing so fast! Great job!
     
  5. Thank you for the pre-release build. Please, keep distributing pre-releases on the next Minecraft updates, it will help everybody to get the plugins ready for the official Minecraft release.
     
  6. Holy fuck! Absolutely Amazing! Well done @md_5 and @Thinkofdeath for the hard work as usual.

    Very unexpected but I'm sure we will all chip in and work our asses off finding bugs :p
     
    • Agree Agree x 4
  7. This is so sweet! I have downloaded the files for testing so my server updates smoothly
     
  8. Oh dear.... Another update with no 1.8 PvP .-.
     
    • Optimistic Optimistic x 3
  9. 1.8 PvP is dead on MC 1.9 :D
     
    • Like Like x 3
  10. This is seriously brilliant, I already have a test server up and running! Pity it looks like the 1.12 upgrade breaks WorldEdit (some commands) and WorldGuard (completely). :/
     
  11. Yeah build 1.12 pre-2 starting do update my private API's.
     
  12. So for us developers we would be required to make the physical json files? Or could you add something API based?

    Eg,
    Bukkit.getServer().createAdvancement(Blah, Blah, Blah)

    Even if we specify the event (meaning developers can call it when they need).
     
  13. md_5

    Administrator Developer

    Why don't you please look at the API first?
     
    • Agree Agree x 1
  14. Hype :p would be helpful reference for others

    Edit: (Seems to be a thing)
    Bukkit.getAdvancement(NamespacedKey.minecraft(""));
    Bukkit.getAdvancement(NamespacedKey.minecraft("")).getCriteria();
     
    #54 Chazmondo, May 14, 2017
    Last edited: May 14, 2017
  15. minecraft7net

    Supporter

    great - upgrading my network :) ... and after 4-5 hours :) - DONE - details below if you have existing network witch use 1.7 - 1.11 it may be helpful.


    [​IMG]

    details below :

    its like time when first 1.7 started - ppl always like to be a part of development
    i think i will increase amount of 1.12 servers

    http://wiki.vg/Protocol_version_numbers

    protocol versions for version connector ;) :

    http://minecraft.gamepedia.com/1.12-pre2 - 329
    http://minecraft.gamepedia.com/1.12-pre1 - 328

    stage 1 - build new version :

    1. get buildtools
    wget https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar

    2. compile 1.12-pre2 with --dev option !
    /opt/java/jdk1.8.0_112/bin/java -jar ./BuildTools.jar --dev

    you can check versions here - sometimes its helpful
    https://hub.spigotmc.org/versions/
    https://hub.spigotmc.org/versions/latest.json


    3. get bungeecord
    curl -o BungeeCord-b1233.jar https://ci.md-5.net/job/BungeeCord/1233/artifact/bootstrap/target/BungeeCord.jar


    and it may be done but if you have existing network those link may be useful - this is for today 20170514, next days more plugins will be upgraded.


    # if you have multiple version

    #Spigot HUB with viaversion supported 1.12-pre2

    Code (Text):
    [12:03:06] [Server thread/INFO]: Default game type: SURVIVAL
    [12:03:06] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-3fb9445-6e3cec8 (MC: 1.11.2) (Implementing API version 1.11.2-R0.1-SNAPSHOT)
    [14:11:28] [Server thread/INFO]: [ViaVersion] Enabling ViaVersion v1.0.5-1_12pre2
    #BungeeCord startup message
    Code (Text):
    12:19:26 [INFO] Enabled BungeeCord version git:BungeeCord-Bootstrap:1.12-SNAPSHOT:16d2615:1233

    # 1.12-pre2 - compilation output
    Code (Text):

    /opt/java/jdk1.8.0_112/bin/java -jar ./BuildTools.jar --dev
    [INFO] ------------------------------------------------------------------------
    [INFO] Reactor Summary:
    [INFO]
    [INFO] Spigot-API ......................................... SUCCESS [ 14.059 s]
    [INFO] Spigot-Parent ...................................... SUCCESS [  0.230 s]
    [INFO] Spigot ............................................. SUCCESS [ 54.514 s]
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD SUCCESS
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 01:09 min
    [INFO] Finished at: 2017-05-14T13:26:08+02:00
    [INFO] Final Memory: 26M/649M
    [INFO] ------------------------------------------------------------------------
    Success! Everything compiled successfully. Copying final .jar files now.
    Copying craftbukkit-1.12-pre2-SNAPSHOT.jar to /home/sv112p2/build/20170514.2/.
      - Saved as craftbukkit-1.12-pre2.jar
    Copying spigot-1.12-pre2-SNAPSHOT.jar to /home/sv112p2/build/20170514.2/.
      - Saved as spigot-1.12-pre2.jar

    plugins :

    # separate hubs for different versions
    https://www.spigotmc.org/resources/version-connector.20179/update?update=131274

    plugins/VersionConnector/config.yml
    Code (Text):
      '328': hub5a # sv112a
      '329': hub5a # sv112a
    # if you build hub on 1.11.2
    https://ci.viaversion.com/job/ViaVersion-DEV/changes

    # need to be upgraded if you migrate or create new hub 1.11.2
    https://dev.bukkit.org/projects/custom-join-items/files/912032
    https://dev.bukkit.org/projects/plugman/files/2412148

    https://dev.bukkit.org/projects/chest-commands/files/912802
    # can be easy upgrade from 3.4 to 5.2 (tested works - of course backup your database)

    https://www.spigotmc.org/resources/authme-reloaded.6269/history

    # if you will have errors from mysql when using it for griefprevention, plots and logit.

    Code (Text):
    2017-05-14-9.log.gz:com.zaxxer.hikari.pool.PoolInitializationException: Exception during pool initialization: The server time zone value 'CEST' is unrecognized or represents more than one time zone. You must configure either the server or JDBC driver (via the serverTimezone configuration property) to use a more specifc time zone value if you want to utilize time zone support.
    Code (Text):
    mysql_tzinfo_to_sql /usr/share/zoneinfo/|mysql -u root mysql -p
    mysql> SELECT @@global.time_zone, @@session.time_zone;
    mysql> SET GLOBAL time_zone = 'Europe/Warsaw';

    # server 1.12-pre2 startup log with plugins from SpigotCraft (some upgraded and changed ;) )
    https://pastebin.com/tdnrvZkz
     
    #55 minecraft7net, May 14, 2017
    Last edited: May 14, 2017
    • Like Like x 1
  16. Look at UnsafeValues.class. I didn't notice it at first.
     
    • Like Like x 1
  17. @md_5 You should add a new catagory for pre 1.12 test plugins to the Resources page like you did with the web resources
     
  18. md_5

    Administrator Developer

    I added 1.12 as a version field
     
    • Like Like x 3
  19. The increased file size... ouch.
     
  20. geNAZt

    Supporter

    R.I.P zPermissions. I think the plugin is the only one who ever used ebean in a huge amount xD
     
    • Informative Informative x 1
    • Optimistic Optimistic x 1
Thread Status:
Not open for further replies.

Share This Page