Bukkit, CraftBukkit, Spigot & BungeeCord 1.12-pre6 Released

Discussion in 'News and Announcements' started by md_5, May 14, 2017.

Thread Status:
Not open for further replies.
  1. My test server has no working Nether portals. Multiverse portals not working
     
    • Informative Informative x 1
  2. Looking forward to the developers jumping on board to test out their compatibility and and take the opportunity to beta test their upgrades and support the new 1.12 features and help get our servers upgrade to 1.12 a bit faster because of it. 3+ months wait times in the past have been quite challenging to stick to a plugin or two.

    I am excited about java 8 and newer versions and taking steps forward to get a good and stable 1.12 running in the near future. Thanks md_5 for the hard work and everybody involved.
     
    • Like Like x 1
  3. Thanks for all the hard work. I thought I would give it a go on my server, unfortunately the majority of my plugins don't appear to work. It simply crashes and stops the server. I think I will wait a little longer. Once again, thanks for all the hard work! :) Cheers!!!!
     
  4. md_5

    Administrator Developer

    Nether portals work completely fine.
     
  5. MiniDigger

    Supporter

    well, its not like its hard to shade in ebean. only need to move the config options. the version was never updated in all the years bukkit exited, it was such a pain to work with (especially if you wanted to use hibernate instead of ebean and couldn't shade in jpa2.1...)
     
  6. I love it, the only issues that I've had is my fps being 7.
    Haven't had any problems with the server.
     
  7. And still there are servers running 1.8 or even 1.7. I don't understand why they are not updating.
     
    • Agree Agree x 1
  8. minecraft7net

    Supporter

    does anyone has success with via version
    https://ci.viaversion.com/job/ViaVersion-DEV/19/changes

    and 1.8.8 for hubs ?

    [14:12:02] [Server thread/INFO]: minecraft7net lost connection: Internal Exception: io.netty.handler.codec.EncoderException: java.lang.NullPointerException


    [14:11:27] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-e4d4710-e1ebe52 (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
    [14:11:28] [Server thread/INFO]: [ViaVersion] Enabling ViaVersion v1.0.5-1_12pre2


    i'm close but :) i need hub with authorization :)
     
  9. This is a thread about Spigot 1.12, so either use Spigot 1.12 or ask the ViaVersion author.
     
    • Agree Agree x 1
  10. minecraft7net

    Supporter

    yes but i have to help with my question potential upgraders.

    the answer is - you need to use for hubs 1.11.2 with viaversion - works.
    [14:21:31] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-3fb9445-2b6c9f4 (MC: 1.11.2) (Implementing API version 1.11.2-R0.1-SNAPSHOT)
    [14:21:31] [Server thread/INFO]: [ViaVersion] Loading ViaVersion v1.0.5-1_12pre2
    [14:22:15] [Server thread/INFO]: minecraft7net[/:25029] logged in with entity id 0 at ([world]-1449.5, 49.5, 304.5)
     
  11. Currently converting the new note sounds to my upcoming api project, sounds already amazing :eek:
     
  12. Is apache.commons.lang updated to 3.0 or is it still on 1.5? @md_5
     
  13. Today I let myself go a little more but now I frame this error


    Rebuilding Forked projects....
    fatal: 'E:/reconstruccion spigot/Bukkit' does not appear to be a git repository
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.
    HEAD is now at 7fd370c8 Add Chunk.isSlimeChunk to check if a chunk can spawn slimes
    Resetting Spigot-API to Bukkit...
    HEAD is now at 7fd370c8 Add Chunk.isSlimeChunk to check if a chunk can spawn slimes
    Applying patches to Spigot-API...
    Applying: POM Changes
    error: sha1 information is lacking or useless (pom.xml).
    error: could not build fake ancestor
    Patch failed at 0001 POM Changes
    The copy of the patch that failed is found in: .git/rebase-apply/patch
    When you have resolved this problem, run "git am --continue".
    If you prefer to skip this patch, run "git am --skip" instead.
    To restore the original branch and stop patching, run "git am --abort".
    Something did not apply cleanly to Spigot-API.
    Please review above details and finish the apply then
    save the changes with rebuildPatches.sh
    Error compiling Spigot. Please check the wiki for FAQs.
    If this does not resolve your issue then please pastebin the entire BuildTools.log.txt file when seeking support.
    java.lang.RuntimeException: Error running command, return status !=0: [sh, applyPatches.sh]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:561)
    at org.spigotmc.builder.Builder.main(Builder.java:443)
     
  14. electronicboy

    IRC Staff

    delete the folder and try again
     
    • Agree Agree x 1
  15. Thanks so much :)
     
    • Agree Agree x 1
  16. Great job, Spigot team! I'm lovin' the work you guys do! Keep it up! :)
     
  17. MiniDigger

    Supporter

Thread Status:
Not open for further replies.

Share This Page