Bukkit, CraftBukkit, Spigot & BungeeCord 1.12-pre6 Released

Discussion in 'News and Announcements' started by md_5, May 14, 2017.

Thread Status:
Not open for further replies.
  1. 2008Choco

    Junior Mod

    Pretty sure Mojang shades Lang3. It's in the final jar

    I hope you don't mind. I added in VeinMiner ^-^ I updated it last night shortly after release. My version numbers are getting rather confusing, though, because the most recent file is VeinMiner 1.11.2 but it supports 1.8.0 -> 1.12-Pre2+

    EDIT: D: Someone removed it from the list! I'll let you guys handle it. Haha
     
    #81 2008Choco, May 14, 2017
    Last edited: May 14, 2017
    • Friendly Friendly x 1
  2. Its not unlikely if they keep version 2. I mean they kept 1.5 even through 3.0 was available...
     
  3. 2008Choco

    Junior Mod

    It's difficult to update dependencies when one of Spigot's main focuses is to keep backwards compatibility. Often times libraries remove deprecated methods / classes that people are still using which can break between versions. Jumping to huge versions (i.e. Guava 17.0 -> 21.0) is a really really big deal for people who haven't updated since 1.7
     
    • Agree Agree x 1
  4. Yeah but if you always think this way we would be stucked forever on the same dependencies :p
     
    • Agree Agree x 1
  5. 2008Choco

    Junior Mod

    We just updated 5 of them in 1.12-Pre2 and updated at least 2 or 3 in 1.11.0 release. They'll all be updated in due time, especially with Mojang updating to Java 8 now
     
  6. Thanks for the pre release. MobHunting is now updated and Minecraft 1.12 ready :cool:. I have of cause added the two new mobs: a Parrot and the Illusioner to MobHunting!

    When I tested my plugin on the Spigot 1.12-pre2 server I noticed that many plugins broke, including Worldguard, so I guess I will wait some time before I migrate my production server to 1.12.
     
    #86 Rocologo, May 14, 2017
    Last edited: May 14, 2017
    • Like Like x 1
  7. True worldguard broke :(
     
  8. NICE! Kids are going to love this. This is going to be a nice surprise for them. Thank You Spigot Team!
     
    • Agree Agree x 2
  9. Yeah but the only downside is worldguard doesn't work so its hard since on my server we have weather disabled pvp disabled in certain areas and stuff.

    Lets hope it gets updated last commit was 3 months ago
     
  10. I'm kind of excited, then I'm kind of not because I just spent a long time working on my network and now I have to redo it... ._. why...
     
  11. 2008Choco

    Junior Mod

    There shouldn't be any reason to redo anything. Some plugins may require updating, but aside from that, nothing else has broken
     
    • Agree Agree x 1
  12. WAS

    WAS

    Ninja versioning. Lol

    Question. With the roll-out of 1.12, will be ending support for 1.7.10 on the sites resource systems?

    Does that mean you could reference craftbukkit to use it? Just wondering cause I just had to download 3.5 to use a feature I needed for a plugin.
     
  13. 2008Choco

    Junior Mod

    You're still capable of supporting any version you'd like. Be aware that you can't compile 1.7 with BuildTools, but the option to support it is still available on the resource page

    I'm not sure exactly which version of Apache Commons Lang that Mojang shades, but I know it's Lang3. If you reference the server jar as a dependency, you should be fine to use Lang3. I've used it on various occasions.
     
  14. WAS

    WAS

    Oh that's good to know about Lang3, thank you.

    But what I mean is will we now be removing the 1.7.10 reference from the Resource Section with the addition of 1.12 tag.
     
  15. 2008Choco

    Junior Mod

    I see no reason to, no. It's still available
     
    • Agree Agree x 1
  16. WAS

    WAS

    I mean. It's technically not available officially from Spigot BuildTools, and sorta endorses using third party jar hosts (which I believe is technically illegal distribution and illegally obtaining a compiled jar) to make your plugin compatible just to tick that box for a lot of people. I'll admit. I had to. Don't see why it's still there.

    I'll also admit, and note, I never tested 1.7.10 support as I was never going to execute those jars. Lol

    It's kinda like when IP.Board canned 1.3 Final for various security flaws with the internet revolution and because they offered no downloads to any free builds they removed all mods hosted on invision to not endorse thosr builds, which ultimately endorsing illegally obtaining it.
     
    #97 WAS, May 14, 2017
    Last edited: May 14, 2017
  17. Well, one thing I like about Spigot doing this is that developers can update their codes to support 1.12, so when 1.12 rolls around, it'll be a lot easier to update my plugins... :cool:
     
    • Agree Agree x 1
    • Like Like x 2
  18. Actually you can start now, most plugins will support both 1.11.2 and 1.12, f.ex. there is no reason not to update MobHunting now, then it will be very easy to upgrade to MC 1.12 when its released.
     
    • Like Like x 1
Thread Status:
Not open for further replies.

Share This Page