Bukkit, CraftBukkit, Spigot & BungeeCord 1.13.1 Development Builds

Discussion in 'News and Announcements' started by md_5, Aug 26, 2018.

  1. The bugs in 1.13.1 ate them alive.
     
    • Winner Winner x 2
    • Funny Funny x 1
  2. I'm having a hard time to build the server from a fresh droplet! It builds just fine on 1.12.2, but on 1.13.1, it fails at different places based on the Java version I'm using! What am I supposed to do? Do I have some missing dependencies or something?

    Code (Java 10):

    -------------------------------------------------------
     T E S T S
    -------------------------------------------------------
    Running org.bukkit.craftbukkit.inventory.FactoryItemMaterialTest
    Reloading ResourceManager: Default
    Sep 12, 2018 12:19:24 AM org.bukkit.Bukkit setServer
    INFO: This server is running org.bukkit.support.DummyServer version null (Implementing API version 1.13.1-R0.1-SNAPSHOT)
    Error compiling Spigot. Please check the wiki for FAQs.
    If this does not resolve your issue then please pastebin the entire BuildTools.log.txt file when seeking support.
    java.lang.RuntimeException: Error running command, return status !=0: [sh, /root/Minecraft/Spigot/apache-maven-3.5.0/bin/mvn, clean, install]
       at org.spigotmc.builder.Builder.runProcess0(Builder.java:671)
       at org.spigotmc.builder.Builder.runProcess(Builder.java:629)
       at org.spigotmc.builder.Builder.main(Builder.java:516)
       at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)
     
    Code (Java 8):

    -------------------------------------------------------
     T E S T S
    -------------------------------------------------------
    Running org.bukkit.craftbukkit.inventory.FactoryItemMaterialTest
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [sh, /root/Minecraft/Spigot/apache-maven-3.5.0/bin/mvn, clean, install]
       at org.spigotmc.builder.Builder.runProcess0(Builder.java:671)
       at org.spigotmc.builder.Builder.runProcess(Builder.java:629)
       at org.spigotmc.builder.Builder.main(Builder.java:505)
       at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)
     
    I also installed ca-certificates-java, but the errors are still the same.

    Code (Text):

    [email protected]
    ----------------------
    OS: Ubuntu 18.04.1 LTS x86_64
    Host: Droplet 20171212
    Kernel: 4.15.0-34-generic
    Uptime: 14 mins
    Packages: 639
    Shell: bash 4.4.19
    Terminal: /dev/pts/1
    CPU: Intel Xeon E5-2650 v4 (1) @ 2.199GHz
    GPU: Red Hat, Inc. QXL paravirtual graphic card
    Memory: 183MiB / 985MiB
     

    Edit : It turns out it was a memory issue. I added 1 Gb swap and it built properly!
     

    Attached Files:

    #282 NatoBoram, Sep 12, 2018
    Last edited: Sep 12, 2018
    • Informative Informative x 1
  3. Not for the faint of heart, but I use mmat jar to clean up a 1.12 world. You define a set of keeper block types and a radius, and point it at the world folder (stop the server and back up the world of course) and it will keep those chunks matching the keeper blocks in and those in the radius around it, whilst deleting the others. Our last run went from 114K chunks down to 33K. Works flawlessly and we have been using it for years to keep our build sever slim. As long as the world generator doesn't change between versions you have no problem with the newly generated chunks fitting right in. We used this to trim down our 1.12 worlds before converting to 1.13 and on .13 chunks match perfectly as the base generator appears to still be the same. New chunks under water get seaweed of course :)

    Here is our build server cleaned up : ob-build-post-mmat

    I have the mmat jar but not sure where I got it from. You can find it on github I think.
     
    • Informative Informative x 1
  4. Great job team!!!! Kudos for the hard work you all put into this!
    Now let's go get some Tacos!!!!
     
  5. Lue

    Lue

    So... uh.

    Code (Java):
    [15:57:29] [Server thread/INFO]: Quavelen issued server command: /restart
    [15:57:29] [Server thread/ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing 'restart' in org.spigotmc.RestartCommand(restart)
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:148) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:696) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.PlayerConnection.handleCommand(PlayerConnection.java:1644) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:1479) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:45) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:1) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.PlayerConnectionUtils.a(SourceFile:10) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_101]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_101]
        at net.minecraft.server.v1_13_R2.SystemUtils.a(SourceFile:199) [spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:900) [spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:411) [spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:835) [spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:733) [spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]
    Caused by: java.lang.NoClassDefFoundError: org/spigotmc/RestartCommand$1
        at org.spigotmc.RestartCommand.execute(RestartCommand.java:26) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        ... 14 more
    Caused by: java.lang.ClassNotFoundException: org.spigotmc.RestartCommand$1
        at java.net.URLClassLoader.findClass(URLClassLoader.java:381) ~[?:1.8.0_101]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_101]
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331) ~[?:1.8.0_101]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_101]
        at org.spigotmc.RestartCommand.execute(RestartCommand.java:26) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.13.1.jar:git-Spigot-500ff5d-1cead62]
        ... 14 more
    Does anyone know why this happens? It's a console log of trying, and failing to use the "/restart" command on the 1.13.1 development builds. What's so odd about it, is that it functions perfectly fine and properly reboots the server most of the time. Sometimes though, it flat out refuses and says "nope!" and throws a null like this.

    I am updated to the latest version; I just re-downloaded and ran buildtools today to be sure, because '/version' ingame has been saying it's up to date for the last few days. Also just to reiterate - the '/restart' command works normally most of the time.
     
  6. md_5

    Administrator Developer

    Are you replacing the jar whilst the server is still running?

    Seems like it to me
     
    • Agree Agree x 1
  7. Lue

    Lue

    Yes, that's exactly what it is lol. I was told by the server owner to do that, since we have a number of active players. We'd broadcast a time for a reboot, and use '/restart' when everyone was ready. Does replacing the jar whilst it's still running cause any other issues?
     
  8. md_5

    Administrator Developer

    Yes, if the server has to load a class which it has never loaded before, it will crash.

    In this case the server has never had to load the /restart class, so when it does after you've replaced the jar it crashes.
     
  9. @Lue make your server start script do

    Code (shell):
    #!/bin/bash
    if [ -f update.jar ]; then
        rm server.jar
        mv update.jar server.jar
    fi
    java <flags> -jar server.jar
    Then, upload the jar as update.jar instead of overwriting, and then when you restart, it'll move the new file into place
     
    • Agree Agree x 3
    • Useful Useful x 2
    • Creative Creative x 1
  10. When will we be in the next wave ? :D
     
  11. Ask Mojang
     
  12. MiniDigger

    Supporter

    if you are speaking about 1.13.2, that will not happen anytime soon, mojang has currently no plans of releasing a .2 version.
     
  13. Lue

    Lue

    Well, sadly I was told not to mess with that. I explained what you and @md_5 said, linked them to this thread, and screenshotted your replies, but I guess I have to continue doing what I was before. Overwriting the old jar and then using '/restart'. Apparently it has always worked for him, and it's only an issue I'm experiencing.

    Edit: Issue averted. Owner is allowing me to do manual reboots, instead of using the ingame '/restart' command. Thanks for your help people. =)
     
    #296 Lue, Sep 15, 2018 at 4:42 PM
    Last edited: Sep 15, 2018 at 5:32 PM
  14. It's hit and miss. I push a new jar in the evening and the servers auto-restart during the night. Sometimes I see the occasional exception as a result of this, but most times it works fine. The only problems is if the error causes the server to hang and your restart scripts don't handle killing off the instance as part of a restart. Then your server could be out of action until you manually clean up.

    It's also not an issue only you are experiencing. Anyone who replaces a running server with a new server jar will face this. He's just been lucky.
     
    • Like Like x 1
  15. Lue

    Lue

    Thankfully after making my previous post, the owner decided to just let me do a manual reboot for the updates. That solves the matter of the restart issue. And yeah, I know it's not just an issue I have - maybe I worded it poorly. I was trying to say that was the impression I got from the owner; he didn't outright say it though.
     
  16. Anyone is having high memory leaks?
     
  17. Anyone else having very high passive mobs spawns? Seems to happen since last night builds.

    [​IMG]
     
    • Like Like x 3

Share This Page