Bukkit, CraftBukkit, Spigot & BungeeCord 1.13.2

Discussion in 'News and Announcements' started by md_5, Oct 22, 2018.

Thread Status:
Not open for further replies.
  1. As always, awesome work!
     
  2. Thanks.
    But from where I get update??

    vidmate
     
    #362 DyraSan, Dec 27, 2018
    Last edited: Dec 28, 2018
  3. md_5

    Administrator Developer

    Same as always, its listed in the first post
     
  4. For posterity, for anyone vacillating on updating an old world: I finally bit the bullet and converted my main world to 1.13.2; used MCEdit Unified to delete or mark for repopulation as much of my world map as possible without destroying builds on or near water. Mostly worked fine.All bases, builds, items, mobs, etc. that my son and I wanted to keep got kept. In a few cases builds adjacent to repopulated blocks were affected (part of structure missing) but everything critical to me was either fine after minor repairs, or (in two extreme cases) was able to be recovered by deleting region file on server, increasing preserved area in world backup using MCEdit, and then re-importing the affected region files back to server.

    For what it's worth, "repopulate" and "delete" appear to be essentially the same thing here. Repopulated areas followed the new 1.13 terrain pattern, so in a few places I got half a new (1.13) island next to a block of preserved (1.12) ocean.

    Only major issue I have seen to date is that traveling out of nether into a preserved (1.12) block of overworld causes a really extreme lag and a timeout, dropping me from server, as the area is rendered. Unclear why. This only happens on first trip through portal, reconnecting to server shows player in the overworld (as expected), and yes I did force upgrade all existing blocks (and then restart server) before joining. On the plus side, I was able to reliably use this timeout to tell me that the area into which I was traveling HAD successfully been preserved. The only portals that didn't trigger the timeout were also the few damaged sites I had to repair.
     
  5. I have a 64bit system with 16 GB of ram only 0.1 GB of RAM is being used and it will not let me create the virtual machine in GitBash, it says I don't have enough, any suggestions ?
    This is the error it throws
    $ java -jar -Xmx1024M BuildTools.jar --rev 1.13.2
    BuildTools requires at least 512M of memory to run (1024M recommended), but has
    only detected 494M.
    This can often occur if you are running a 32-bit system, or one with low RAM.
    Please re-run BuildTools with manually specified memory, e.g: java -Xmx1024M -ja
    r BuildTools.jar --rev 1.13.2
    Picked up _JAVA_OPTIONS: -Xmx512M
     
  6. md_5

    Administrator Developer

    Your argument order is messed up, Xmx must be before jar.

    Also it looks like you defined _JAVA_OPTIONS environment variable which sets it to 512M. If you use the arg it should override it, but if not you’ll need to fix that fariable.
     
  7. md_5

    Administrator Developer

    Latest version will allow you to run with very slightly less than 512M of ram.
     
    • Like Like x 2
  8. Sikatsu

    Patron

  9. md_5

    Administrator Developer

    Bug report with what type of click is needed to trigger that please.
    I can't reproduce it by clicking in any inventory myself.
     
  10. Sikatsu

    Patron

    I don't do any clicks, but maybe the players do. However they can't access some inventories like the one from EpicSpawners, yet the plugin still throws the error.

    I contacted the developers from the plugins but they say it's an issue with spigot most likely.
    It keeps spamming the console. Rollbacked Spigot fixed the issue, however now i'm 21 versions behind.
     
  11. md_5

    Administrator Developer

    The only way I could reproduce the error was clicking in a bad spot on an enchanting table. It wouldn't affect otherwise correct clicks.
    The issue has been fixed now.
     
  12. Sikatsu

    Patron

    That's odd. None of these plugins use an enchanting table. EpicSpawners, YourAuction and HeadDatabase throw this error. Those are quite normal GUI's without any unusual clicks.
     
  13. md_5

    Administrator Developer

    Yes but any player using an enchanting table would cause the error to show in the console
     
  14. Sikatsu

    Patron

    Oh, now I get it. Yeah that's it most likely then.
     
  15. I did that and it still says "
    $ java -Xmx512M -jar BuildTools.jar --rev latest
    BuildTools requires at least 512M of memory to run (1024M recommended), but has only detected 455
    M.
    This can often occur if you are running a 32-bit system, or one with low RAM.
    Please re-run BuildTools with manually specified memory, e.g: java -Xmx1024M -jar BuildTools.jar
    --rev latest "
    Picked up _JAVA_OPTIONS: -Xmx512M "

    I donot have low ram and I have 150GB of free space, any suggestsions?
     
  16. remove -Xmx512M ... i get the same error when i try to run it with that...
    or change it to -Xmx1G ...
     
  17. md_5

    Administrator Developer

    Also the latest version sets the threshold at 448, so you’re outdated
     
  18. Hello Guys, i cannot install the Buildtools i dont know how can fix it so i ask you.
    Heres my BuildTools.log.txt i hope anybody can help me.
     

    Attached Files:

  19. md_5

    Administrator Developer

    Delete
    /root/.m2/repository/org/spigotmc/ and try again
     
  20. Bit of a problem. My server says, "Can't connect to server". It runs and everything. I upgraded my laptop if that helps. By replacing the hard drive with another one. It works on my old hard drive but not on this one. Going to run it plain and simple and see if that works. If not, it must be some other reason... maybe spigot.jar related?
     
Thread Status:
Not open for further replies.