Bukkit, CraftBukkit, Spigot & BungeeCord 1.13.2

Discussion in 'News and Announcements' started by md_5, Oct 22, 2018.

Thread Status:
Not open for further replies.
  1. md_5

    Administrator Developer

    Maybe your IP changed?
     
    • Like Like x 1
  2. Gee golly, that might be the issue. Let me go check and see. :-D
     
  3. That was it. I use no ip. Thanks for the help my good sir! B-)
     
  4. how can i get spigot 1.8.8
     
    • Like Like x 1
  5. [13:02:17 INFO]: This server is running CraftBukkit version git-Spigot-f56e2e7-ed274c5 (MC: 1.13.2) (Implementing API version 1.13.2-R0.1-SNAPSHOT)


    [13:02:24 ERROR]: Exception handling console input
    java.io.IOException: Resource temporarily unavailable
    at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_201]
    at java.io.FileInputStream.read(FileInputStream.java:255) ~[?:1.8.0_201]
    at java.io.BufferedInputStream.fill(BufferedInputStream.java:246) ~[?:1.8.0_201]
    at java.io.BufferedInputStream.read(BufferedInputStream.java:265) ~[?:1.8.0_201]
    at org.bukkit.craftbukkit.libs.jline.internal.NonBlockingInputStream.read(NonBlockingInputStream.java:169) ~[spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    at org.bukkit.craftbukkit.libs.jline.internal.NonBlockingInputStream.read(NonBlockingInputStream.java:137) ~[spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    at org.bukkit.craftbukkit.libs.jline.internal.NonBlockingInputStream.read(NonBlockingInputStream.java:246) ~[spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:261) ~[spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:198) ~[spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readCharacter(ConsoleReader.java:2145) ~[spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:2349) ~[spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    at net.minecraft.server.v1_13_R2.DedicatedServer$2.run(DedicatedServer.java:91) [spigot-1.13.2.jar:git-Spigot-f56e2e7-ed274c5]
    [13:02:24 INFO]: [PlugMan] Loading PlugMan v2.1.5

    Linux Mint 16G
    #!/bin/sh

    while true

    do

    cd /home/dadmar777/Server/Aquarius

    chmod +x start.sh

    java -server -Xmx4G -Xms512M -jar spigot-1.13.2.jar
    #java -server -Xmx2G -Xms1G -jar paperclip-487.jar

    sleep 3 #To being sure that the server is really stopped...

    done

    Result of the error - or if not this - is I cannot type into the open terminal (console) - no keyboard input is accepted.
    Maybe a java error ?? recent update to 180_201 ??

    But I found same error mentioned on Mojang
    Created:
    28/Sep/13 1:12 PM
    Updated:
    29/Nov/18 2:48 PM
    https://bugs.mojang.com/browse/MC-33041?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&showAll=true

    OR that recent Ubuntu Kernel Update I just had as mentioned by MD_5 .........below .............lol

    found this as well.....Linux ......

    "If you want to go back to a different kernel, you have to be not using the kernel you want to stop using: you can't remove it while you're booted from it. So the first step is to selecct a different kernel (an earlier one) in GRUB during startup. If you don't see GRUB, hold the Shift key during booting and it should show up.
    Once you're booted from the desired, older kernel you can use Update Manager to uninstall the unwanted kernel, which should then also stop appearing in GRUB."
     
    #386 DaDMaR777, Jan 30, 2019
    Last edited: Jan 30, 2019
  6. md_5

    Administrator Developer

    Server error, front page announcement coming momentarily.
     
    • Winner Winner x 1
  7. md_5

    Administrator Developer

    https://www.spigotmc.org/threads/ubuntu-18-04-bad-kernel-update.357871/
     
    • Informative Informative x 1
  8. md_5

    Administrator Developer

    Unless you have a dedi or vps you cant, try one of the other options.
     
  9. i using dedi , how method fix that
     
  10. upload_2019-1-31_22-16-19.png
    not have kernel old
     
  11. md_5

    Administrator Developer

    4.15.0-20 is old (very old even).

    You can install a more recent old version using the apt commands I listed
     
  12. I'm having the same issue on 4.15.0-43.
    upload_2019-2-2_8-51-1.png
    I've tried -Djline.terminal=jline.UnsupportedTerminal on my BungeeCord, but it's still a problem.
     
  13. md_5

    Administrator Developer

    Did you make sure to add it as a Java arg, not a Bungee arg?
     
    • Like Like x 1
  14. Yes. But I just noticed my system wants a restart, so there's probably some fix on the way.
     
  15. Stupid Ubuntu infiltrators, now I have to look at my console without ANSI.....
     
    • Agree Agree x 1
  16. 4.15.0-45-generic is out, gonna check if they fix it
     
    • Like Like x 1
  17. no, its not working on that update...
     
    • Informative Informative x 1
  18. Thank you for your work!
     
Thread Status:
Not open for further replies.