Bukkit, CraftBukkit, Spigot & BungeeCord 1.13.2

Discussion in 'News and Announcements' started by md_5, Oct 22, 2018.

Thread Status:
Not open for further replies.
  1. Linux Mint 19.1 MATE 64-bit..................kernel v4.18.0-14 not working yet ....which is my latest update.

    no new updates
    but tried a non Mate-terminal----- found by typing "term" in the Menu /Search box --- found these....

    Mate-Terminal................not working one
    Terminal..........................gnome-terminal not tried yet
    UXTerm...........................so not as versatile no menu across top -- but the colours and cursor are back
    XTerm..............................so not as versatile no menu across top -- but the colours and cursor are back

    EDIT:
    I highly recommend you get "Guake terminal" - named because it is similar to a Quake dropdown terminal.......oh so good.

    sudo apt-get install guake -y

    EDIT:
    Linux Mint 19.1 MATE 64-bit.................. kernel v4.18.0-15 ........

    http://changelogs.ubuntu.com/changelogs/pool/main/l/linux/linux_4.18.0-15.16/changelog

    14:58:57] [Server console handler/ERROR]: Exception handling console input
    java.io.IOException: Input/output error
    at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_201]
    at java.io.FileInputStream.read(FileInputStream.java:255) ~[?:1.8.0_201]
    at java.io.BufferedInputStream.fill(BufferedInputStream.java:246) ~[?:1.8.0_201]
    at java.io.BufferedInputStream.read(BufferedInputStream.java:265) ~[?:1.8.0_201]
    at org.bukkit.craftbukkit.libs.jline.internal.NonBlockingInputStream.read(NonBlockingInputStream.java:248) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:261) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:198) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readCharacter(ConsoleReader.java:2145) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLineSimple(ConsoleReader.java:3183) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:2333) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:2269) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:2257) ~[spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
    at net.minecraft.server.v1_13_R2.DedicatedServer$2.run(DedicatedServer.java:93) [spigot-1.13.2.jar:git-Spigot-b0f4c22-2ced023]
     
    #402 DaDMaR777, Feb 8, 2019
    Last edited: Feb 13, 2019
    • Like Like x 1
  2. I did option 4 for the bad kernal update and it did fix the issue.
    But a few days went by and now I can't type in console again. Tried that install / remove process again but no luck.
     
  3. md_5

    Administrator Developer

    There was a subsequent kernel update also wihout the fix. You’ll have to remove that too.
     
  4. I'm not the best when it comes to Linux. Will it remove anything if I downgrade my system?
     
  5. md_5

    Administrator Developer

    Nothing of consequence (hopefully), you could review the changelogs to make sure.
    It would just be as if you didn't do the update you did.
     
    • Like Like x 1
  6. We're having the same console issue on Ubuntu 16.04.5
    Code (Text):
     4.4.0-142-generic #168-Ubuntu SMP Wed Jan 16 21:00:45 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
     
  7. md_5

    Administrator Developer

    It's fixed in 4.4.0-143 for that OS version.
    You can get it by enabling the 'proposed' updates - Google. Or just wait for the update to be released properly.
     
  8. md_5 Im curious if Spigot/Craftubkkit is going to attempt to fix this issue with this "Book Dupe" that has been floating around recently?

    It seems that this dupe has been in Minecraft for YEARS and until recently, very few heard of it. Now it seems to be spreading like wild fire, lots and lots more people are finding out about it, and its starting to affect a lot of servers in a very negative manner.

    I know that Paper has done some small fixes for it (Im not 100% sure on the 1st fix, but something to do with blocking books from having illegal characters in them), obviously this can't solve the issue for the books that are already written, and then yesterday they pushed a release that helps deal with these oversized chunks.

    Ive heard a lot of people talking recently about how their servers are being affected. A lot of people are stumbling to find solutions, but the solutions only seem to slap a small bandaid on a very large situation.
     
  9. I've seen various fixes including the paper one, but i haven't seen one that elegantly covers the whole problem. I guess quick fix is to prevent certain moving items from moving, and allowing editing of books. There's a 1.12.x plugin that mentioned 1.13, but i dunno if that works on 1.13 and from what i read in the code it doesn't actually deal with the issue properly at all. we're on the spigot site here, and immah stick to spigot, hopefully dupe issues, vanilla or not, could get addressed. i understand that if it's a vanilla issue it's up to mojang to fix it, but if you check the logs from buildtools to see the stuff that's getting patched, it wouldn't be the first time.

    as for the first time.. i've seen some custom fixes ages ago, like nearly 4 months ago.

    looking forawrd to updating loads of servers to new 1.13.2 build to deal with this once and for all.
     
  10. md_5

    Administrator Developer

    @ShaneBee you complain that an issue is spreading with the result that more servers are affected, and then proceed to spread it even further yourself. Private bugtrackers exist for a reason. Even if the issue is out there to some degree you should leave that for us to manage. I am aware of developing situations without you broadcasting them in this thread.

    Most of the “fixes” you mention can be done BETTER from a plugin than Spigot. This is why it has not until recently been a pressing concern.

    All I can say is now it will be fixed properly for 1.12.2 and 1.13.2 soon.
     
    • Like Like x 2
  11. OOF someones cranky.
    I didnt even state what the dupe is... its not like this is new information at this point. I mean paper said more details about it in their announcements.

    SO SORRY to question if Spigot was planning on resolving an issue that a lot of people are concerned about.

    Also ... "@ShaneBee you complain" I wasn't complaining, I don't even have an active server at the moment. It was simply a question because I have yet to see anyone address it on this site, nor have I seen anything regarding it on the Jira.
    No need to get bent out of shape.
     
    • Agree Agree x 3
    • Funny Funny x 1
  12. https://hub.spigotmc.org/stash/proj...mits/e5e5c7c6d438c89ced4041c0d3361ae9e6bcc177

    \o/
     
    • Like Like x 1
  13. MiniDigger

    Supporter

    Sadly that fix still leads to giant region files which will make your server lag out horrible when loading.
    The only real fix here is for mojang to adjust the region format. Other approaches like putting the stuff that is too large into its own custom file have been implemented by other projects, but that's not really a good solution either since it might lead to 3rd party programms overriding content.
     
  14. md_5

    Administrator Developer

    Sounds like an exaggeration, but ok.
    That doesn't solve what you mention at all. Region files are not read in their entirety for a single chunk.

    Sidenote: If you don't want players to write infinite numbers of 50 page books, then don't let them write infinite numbers of 50 page books.
     
  15. md_5

    Administrator Developer

    Won’t affect the bug if thats what you’re suggesting :)
    Never used it myself but have heard of it a lot.
     
    • Informative Informative x 1
  16. What do I do to fix/remove that?
     
  17. I see there's an updated build for 1.12.2 (I run CraftBukkit, not Spigot). This fixes the dup bug? Are there any downsides of using this? In particular, do you know if the standalone program Minecraft Overviewer will still be able to read the region files?

    EDIT: Does this large chunks fix even apply to CraftBukkit? Because the /version string didn't change; it's still "CraftBukkit version git-Bukkit-acbc348 (MC: 1.12.2)", which is the commit from Nov 10, 2018.
     
    #419 Bobcat00, Feb 22, 2019
    Last edited: Feb 22, 2019
  18. md_5

    Administrator Developer

    1) I can’t speak for any particular program, ask them
    2) No
     
Thread Status:
Not open for further replies.