Bukkit, CraftBukkit, Spigot & BungeeCord 1.13.2

Discussion in 'News and Announcements' started by md_5, Oct 22, 2018.

Thread Status:
Not open for further replies.
  1. I know, I switched to spigot (I also tried papermc) because of it's performance beneifts, before I ran vanila server for ages, so my current small playerbase don't have the demand for plugins.
    That live map plugin looks interesting tho'.
    And this, https://github.com/mapcrafter/mapcrafter-playermarkers however I don't think it will work (haven't been updated in 4 years). :unsure:
     
  2. MiniDigger

    Supporter

    take a look at dynmap https://www.spigotmc.org/resources/dynmap.274/
    example project: https://utopia.emc.gs/#
     
  3. Because dealing with a bigger single world first gives us enough data to then make smart decisions to speed things up.
    The CPU isn't being utilized much at all, there's more than plenty of RAM available. The system isn't the bottleneck.
    Since that post the same system has run multiple vm instances to do various maps of 10gb and up simultaneously, and hasn't impacted performance much at at all.

    Just because I post my experience, opinion or findings, doesn't mean I am posting as if I have a problem with it.
     
  4. I am not going to trust a third party with the server data, to be honest. I have no interest in playing quality control and double checking what they've done. (just sayin)
    The only reason we use something like Spigot over vanilla is merely for having the comfortable ability of expanding the server to our liking through plugins. That on top of that things perform a little better is a nice perk.
     
    • Agree Agree x 1
  5. NICE!! thanks man (y)
     
  6. Lue

    Lue

    Um, I asked about this back on page 2, but never got an answer:

    [​IMG]


    The owner of the server I manage thinks there is an issue with the 1.13.2 builds of Spigot, where it's not communicating or whatever with MultiCraft correctly. It runs fine and everything, it just shows the "restarting" icon, and states the status is offline when it's actually online:


    [​IMG]

    It worked perfectly in the 1.13.1 Spigot builds, as well as through all the 1.13 vanilla snapshots when we were 'surfing' through them as Mojang released them. If this is not an issue on Spigot's end, I'd like to be able to tell the owner this so we can contact our host, and open a ticket with them.
     
  7. md_5

    Administrator Developer

    Spigot doesn't do any communication with multicraft and I have no idea how multicraft works.
    You're best off asking them.
     
    • Like Like x 1
  8. Lue

    Lue

    Thank you, I've let the owner know. It's weird how it's only with 1.13.2, and not other versions.
     
  9. This is because it is being ran as a 'custom jar' - meaning it's not an option on the drop down list (set to Default in your screenshots) that has been added to the system with a .conf set up so MultiCraft can parse the console output correctly, it has just been uploaded to your server files and the jar name added to the text field - so it won't show as Online on the panel even when the server is online. The host should have their own option for Spigot 1.13.2 on the drop down list to use, or should have some option to link the jar to.

    For example if they do have Spigot 1.13.2 but you want to use your own jar anyway select their Spigot 1.13.2 option on the jar list, copy what it gives you in the text field for that selection (and save changes so it stays on that option) rename your server jar to match and then restart the server.

    Either way it's an issue on the control panel/hosts end, so you should contact them if you have issues with this. Note that this should not effect connecting to the server however, it's only an issue on the control panel - the server itself will be running the same regardless.
     
    • Informative Informative x 1
  10. Multicraft and Spigot 1.13.2 works perfectly on my server... Check your server.log for errors
     
  11. Hello, Im just having this problem when I try to update my server to 1.13.2
    Error: Could not find or load main class org.apache.maven.surefire.booter.ForkedBooter

    Results :

    Tests run: 0, Failures: 0, Errors: 0, Skipped: 0

    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD FAILURE
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 10.658 s
    [INFO] Finished at: 2018-10-27T10:54:32Z
    [INFO] Final Memory: 10M/67M
    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.12.4:test (default-test) on project bukkit: Execution default-test of goal org.apache.maven.plugins:maven-surefire-plugin:2.12.4:test failed: The forked VM terminated without saying properly goodbye. VM crash or System.exit called ? -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [sh, /home/spartan_drogado616/BuildTools/apache-maven-3.5.0/bin/mvn, clean, install]
    at org.spigotmc.builder.Builder.runProcess0(Builder.java:673)
    at org.spigotmc.builder.Builder.runProcess(Builder.java:630)
    at org.spigotmc.builder.Builder.main(Builder.java:495)
    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)

    Rev 1.13.1 works.
     
  12. I'm getting this error :/ trying to update 1.13.1 to 1.13.2

    with cmd lines of

    java -jar BuildTools.jar --rev 1.13.2
    Pause

    -------------------------------------------

    *** Using downloaded git PortableGit-2.15.0-64-bit\PortableGit ***
    *** Please note that this is a beta feature, so if it does not work please also try a manual install of git from https://git-for-windows.github.io/ ***
    git version 2.15.0.windows.1
    BuildTools
    [email protected]
    Attempting to build version: '1.13.2' use --rev <version> to override
    Found version
    {
    "name": "1928",
    "description": "Jenkins build 1928",
    "refs": {
    "BuildData": "f527a8ff0d2f2efafc292ac7648ae3a184245a74",
    "Bukkit": "99934bd88a6b2976695d03cffddd4d4bba75ef66",
    "CraftBukkit": "5184216f2788fb1bd722dfe1ac53ee2f4c2f4177",
    "Spigot": "e4d0c66f9eefadb5f9f39a102f457daaeb05374c"
    },
    "toolsVersion": 75,
    "javaVersions": [52, 55]
    }

    Pulling updates for D:\mc spiggot server\BuildData\.git
    Successfully fetched updates!
    Checked out: f527a8ff0d2f2efafc292ac7648ae3a184245a74
    Pulling updates for D:\mc spiggot server\Bukkit\.git
    Exception in thread "main" org.eclipse.jgit.api.errors.JGitInternalException: Exception caught during execution of reset command. Cannot lock D:\mc spiggot server\Bukkit\.git\index
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:234)
    at org.spigotmc.builder.Builder.pull(Builder.java:603)
    at org.spigotmc.builder.Builder.main(Builder.java:320)
    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)
    Caused by: org.eclipse.jgit.errors.LockFailedException: Cannot lock D:\mc spiggot server\Bukkit\.git\index
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:250)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:327)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:293)
    at org.eclipse.jgit.lib.Repository.lockDirCache(Repository.java:1183)
    at org.eclipse.jgit.api.ResetCommand.checkoutIndex(ResetCommand.java:404)
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:207)
    ... 3 more
     
  13. "Spaces or exclamation points in the directory path may break BuildTools! It is recommended to remove these."
    https://www.spigotmc.org/wiki/buildtools/
     
  14. Is it safe to convert 1.12 worlds over to this version yet?
     
  15. how are worlds converted? Simply start the odl world with the new server?
     
  16. Choco

    Moderator

    They will be converted automatically as chunks are loaded by players, yes. If your worlds are large, it's recommended you pre-convert the entire world. There is a startup argument for this but I can't recall what it is off the top of my head.
     
    • Informative Informative x 1
  17. If I were to pre-generate the chunks in my world before updating as I use a custom generator, what would happen to my world? Would the loaded chunks contain new blocks like kelp and whatnot or does that require chunks to be loaded in 1.13 for that to appear?
     
  18. Choco

    Moderator

    Any newly generated chunks in 1.13.x will contain the new blocks. Any existing chunks, when converted, will not contain new blocks. This has been the case ever since Minecraft has been adding blocks to the game :p
     
  19. Thx. If i pre-convert - only my existing chunks will pre converted. If i donĀ“t do that, they will be converted if a player goes into a chunk?
     
  20. I just try the whole day to update from rev 1.13.1 to rev 1.13.2, I think is the version because 1.13.1 updates from 1.13 to 1.13.1 (Just test that to make sure that it wasnt my vm)
     
Thread Status:
Not open for further replies.