Bukkit, CraftBukkit, Spigot & BungeeCord 1.13 Development Builds

Discussion in 'News and Announcements' started by md_5, Jul 15, 2018.

Thread Status:
Not open for further replies.
  1. send the links anyways, gives me something to do :) that's what you can give me in return, something to do :p
    You get updated plugins and i get something to do xD
     
  2. Hm yeah, good point. I'd test 'em all but this is too early to call "lots of plugin does not work" waiting for devs to update them (popular ones, like EssX/mcMMO etc)
     
  3. Pretty much, the only reason i updated the plugin @BrettPlayMC wanted updated was due to when the last update was (Updated: Feb 19, 2012)
     
  4. That's the reason I picked it lol.
    I mean it was as a joke but I hope it was at least a good challenge...?
     
  5. It was literally just changing org.bukkit.craftbukkit to work with the 1.13 pre-release and then changing other smaller things, took maybe 2 or 3 minutes maybe less
     
    • Like Like x 1
  6. Wooo! can't wait to break my server! and the plugins... I'm going to do everything MD_5 said not to do! (backing up server first thoe)
     
    • Like Like x 2
  7. @Optic_Fusion1 I'd try this one https://github.com/slipcor/TreeAssist

    The actual dev requires a lib which I don't support that having extra useless plugins as a lib. I can provide you the stacktraces of it in 1.13-pre7 (startup error) and while chopping out trees. Last version which DOES not require the useless lib is 5.11.50. On his github the version is .52, so no lib requirement.

    Anyways my server would not pass to 1.13 (never!), too many plugins expected to not to work and fixing them would require me to pay them
     
  8. I see that my fork got noticed, yes I'm updating it to 1.13. I have a local branch built against 1.13, I've just been short on time lately.
     
  9. Honestly, there's probably up to date versions of this type of plugin
     
  10. In that case, i won't bother updating it my self xD
     
    • Like Like x 1
  11. It does, but it requires a lib which I don't support/tolerate. So no update with that 5.11.52 on slipcor's Github? Then ill stuck on 1.12.2 (I've said it numerous time hah sorry xD)
     
  12. "softdepend: [mcMMO, Prism, CoreProtect, LogBlock]"
    softdepend A list of plugins that are required for your plugin to have full functionality.
    https://bukkit.gamepedia.com/Plugin_YAML
    It would still function, just not completely
     
  13. Those aren't libs, the actual dev requires another which is a lib^^ I alreayd have mcMMO and Prism (keeping an eye on @ezeiger92 's fork and wispoffates xD) and Logblock/CoreProtect are not needed since they do the same job (antigriefing, block logging, rollbacks) etc.

    What I mean, a lib plugin which serves no purposes (like MultiInv needed a lib) and the current one I use is "PWI" by Gnat does not require a lib^^ I don't know the correct term to define "lib" xD
     
  14. Just donated some $$$ as thanks for all the hard work you've all put in. I'm testing it out now, and I'm surprised at the 1.12 versions of plugins that still work (even ones which have old item ids in config files etc). Keep up the great work! :giggle:
     
    • Winner Winner x 1
  15. Will 1.13 release Spigot build contain in-built anti-xray feature?
     
  16. probably not
     
  17. md_5

    Administrator Developer

    Don't see why they would, unless you're gonna write it for me
     
    • Funny Funny x 3
    • Like Like x 1
  18. wouldn't most anti x-ray features kill performance? plus there are plugins that do this type of thing anyways, no point adding it your self
     
  19. If I add that string to my plugin.yml, will my plugins work with earlier versions? (assuming it works on all properly)
     
  20. i keep getting this problem... i believe it's a problem lol

    Code (YAML):
    [INFO] ------------------------------------------------------------------------
    Applying CraftBukkit Patches
    Backing up NMS dir
    Patching with Advancement.patch
    Exception in thread "main" java.io.FileNotFoundException
    : work\decompile-be335ab                                                                                                                                  2\net\minecraft\server\Advancement.java (The system cannot find the file specifi                                                                                                                                  ed)
            at java.base/java.io.FileInputStream.open0(Native Method)
            at java.base/java.io.FileInputStream.open(Unknown Source)
            at java.base/java.io.FileInputStream.<init>(Unknown Source)
            at com.google.common.io.Files$FileByteSource.openStream(Files.java:120)
            at com.google.common.io.Files$FileByteSource.openStream(Files.java:110)
            at com.google.common.io.ByteSource$AsCharSource.openStream(ByteSource.ja                                                                                                                                  va:456)
            at com.google.common.io.CharSource.readLines(CharSource.java:311)
            at com.google.common.io.Files.readLines(Files.java:553)
            at com.google.common.io.Files.readLines(Files.java:520)
            at org.spigotmc.builder.Builder.main(Builder.java:425)
            at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)
    for bash... .-. or am i doing it wrong?
     
Thread Status:
Not open for further replies.

Share This Page