Bukkit, CraftBukkit, Spigot & BungeeCord 1.13 Development Builds

Discussion in 'News and Announcements' started by md_5, Jul 15, 2018.

Thread Status:
Not open for further replies.
  1. Hey how can i make the "world conversion" in my server ? (he is running perfectly in 1.13 without action of "world conversion").
     
    #1421 benoitfouc, Aug 27, 2018
    Last edited: Aug 28, 2018
    • Agree Agree x 2
  2. If I write a dll as an extenstion and inject it into a program that is bugged, is my dll bugged too? The code that was added to vanilla mc by spigot is perfectly stable. All major know issues are caused by the native minecraft code. I just wanted to point that out, because some people keep blaming spigot for the issues or think that spigot is supposed to fix them.
     
  3. As a datapoint, our 1.12.2 -> 1.13 converted world upgraded to 1.13.1 with no issues.

    I still have my backup copy of our 1.12.2 world with all the ocean chunks removed sitting on my laptop so I'll try to re-test conversion straight to 1.13.1 tonight. The only glitch I know we can check for is the order of items in chests changing (cosmetic/annoying, supposedly fixed in 1.13.1) - we didn't have any of the other common vanilla conversion issues.
     
  4. World (chunk) conversion happens automatically when you load a world generated with an old version of Minecraft/Spigot on a 1.13 server.
    This normally happens as each chunk is loaded, but you can (& IMHO should) specify --forceUpgrade when starting your server to do the whole world at once.

    Standard caveats apply. Make a backup of your world before proceeding.
     
    • Like Like x 1
  5. 1.13.1 is out for bukkit btw
     
  6. > Is on SpigotMC
    ...
    ...
    ...
    > Talks about Bukkit
    :unsure::unsure::unsure:
     
  7. Following up on my earlier post, I've done the 1.12.2 -> 1.13.1 conversion test (with forceUpgrade) on git-Spigot-2440e18-4228a56

    No discernible glitches, the chest-items-out-of-order bug in conversions appears to have been addressed.
    Overall 1.13.1 performance seems to be noticeably better though I think that's more client-side than server-side.
     
  8. MiniDigger

    Supporter

  9. md_5

    Administrator Developer

    Almost certainly a vanilla issue. See if you can reproduce it there. You might not be able to for other reasons, in which case open a bug report with the affected map and it can be looked at conclusively.
     
  10. im trying to make a server and the code to make it is not working so i was wondering whats happening
     
  11. That code is for plugins, not servers.
     
  12. I keep getting this error. Does anyone know why?

    $ java -jar BuildTools.jar
    Loading BuildTools version: git-BuildTools-4bf25ea-55 (#55)
    BuildTools
    [email protected]
    Attempting to build version: 'latest' use --rev <version> to override
    Found version
    {
    "name": "1573-c",
    "description": "Jenkins build 1573-c",
    "refs": {
    "BuildData": "be360cc298a06b5355ecd057f5b1feb894a73f0f",
    "Bukkit": "558fdf5f54b0f527cd48903daf9368ac4b862876",
    "CraftBukkit": "2b93d839ddb1541cad937e3dd7a4da5d1525af3d",
    "Spigot": "2cf50f055260acaa2344390334bbca546d46726d"
    },
    "toolsVersion": 47
    }

    Pulling updates for C:\Program Files\Git\BuildData\.git
    Exception in thread "main" org.eclipse.jgit.api.errors.JGitInternalException: Exception caught during execution of reset command. Cannot lock C:\Program Files\Git\BuildData\.git\index
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:228)
    at org.spigotmc.builder.Builder.pull(Builder.java:520)
    at org.spigotmc.builder.Builder.main(Builder.java:260)
    Caused by: org.eclipse.jgit.errors.LockFailedException: Cannot lock C:\Program Files\Git\BuildData\.git\index
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:250)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:327)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:293)
    at org.eclipse.jgit.lib.Repository.lockDirCache(Repository.java:1182)
    at org.eclipse.jgit.api.ResetCommand.checkoutIndex(ResetCommand.java:378)
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:201)
    ... 2 more
     
  13. md_5

    Administrator Developer

    Try running it in your user directory not C:\Program Files

    Also could be antivirus... Seems to be a common error recently
     
    • Like Like x 1
  14. Because Bukkit is the software that SpigotMC develops?
     
  15. Tried both. Same error. Any other suggestions? I'm running it with java -jar BuildTools.jar command with git? That is all. Thanks for the help anyhow. :)
     
    #1437 Astral-Revenant, Aug 29, 2018
    Last edited by a moderator: Aug 29, 2018
  16. maol3

    Supporter

    Try creating a new empty folder and put the latest version of BuildTools in there, and try it again.
     
    • Like Like x 1
    • Agree Agree x 1
  17. md_5

    Administrator Developer

    Reminder that legacy support is exactly that, for LEGACY plugins.
    If you’re relying on it to not update your plugin then you’re doing it wrong.

    Spigot is going to get gradually more annoying about running such plugins
     
    • Like Like x 3
    • Agree Agree x 1
    • Informative Informative x 1
    • Friendly Friendly x 1
  18. Thank you kind sir, it works. :cool:
     
Thread Status:
Not open for further replies.

Share This Page