Bukkit, CraftBukkit, Spigot & BungeeCord 1.14.3 Development Builds

Discussion in 'News and Announcements' started by md_5, Apr 23, 2019.

  1. I aways use the last BuildTools. To get an clean build i deleted the .m2 folder and the folder i build spigot into. Then recreated the folder and downloaded buildtools again from jenkins. It crashes with the same error.
     
  2. Shaggy67

    Supporter

    Just built "Jenkins build 2399"... same error.

    HEAD is now at fa67447 CraftBukkit $ Wed Jul 10 13:55:12 EDT 2019
    Applying patches to Spigot-Server...
    Applying: POM Changes
    Applying: Skeleton API Implementations
    Applying: mc-dev imports
    Applying: Spigot Configuration
    Applying: Crop Growth Rates
    Applying: Merge tweaks and configuration
    Applying: Async Operation Catching
    fatal: sha1 information is lacking or useless (src/main/java/net/minecraft/server/PlayerChunkMap.java).
    Repository lacks necessary blobs to fall back on 3-way merge.
    Cannot fall back to three-way merge.
    Patch failed at 0007 Async Operation Catching
    The copy of the patch that failed is found in:
    /home/minecraft/MCSpigot/Spigot/Spigot-Server/.git/rebase-apply/patch
    When you have resolved this problem, run "git am --resolved".
    If you prefer to skip this patch, run "git am --skip" instead.
    To restore the original branch and stop patching, run "git am --abort".
    Something did not apply cleanly to Spigot-Server.
    Please review above details and finish the apply then
    save the changes with rebuildPatches.sh
    Error compiling Spigot. Please check the wiki for FAQs.
    If this does not resolve your issue then please pastebin the entire BuildTools.log.txt file when seeking support.
    java.lang.RuntimeException: Error running command, return status !=0: [sh, applyPatches.sh]
    at org.spigotmc.builder.Builder.runProcess0(Builder.java:764)
    at org.spigotmc.builder.Builder.runProcess(Builder.java:699)
    at org.spigotmc.builder.Builder.main(Builder.java:564)
    at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:40)
     
  3. SlimeDog

    Patron

    I get the same error, on (always) clean build of Jenkins 2399 with (always) latest BuildTools. Jenkins 2397 and 2398 build without error.

    CentOS Linux release 7.6.1810 (Core)
    java version "11.0.3" 2019-04-16 LTS
    Java(TM) SE Runtime Environment 18.9 (build 11.0.3+12-LTS)
    Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.3+12-LTS, mixed mode)

    Posted resultant patch file to ticket.
     
    #1523 SlimeDog, Jul 10, 2019 at 7:28 PM
    Last edited: Jul 10, 2019 at 7:34 PM
    • Like Like x 1
  4. md_5

    Administrator Developer

    The issue has been resolved (*looks at multiple duplicated bug reports*).

    Jenkins builds each version from scratch to make sure that patch rebuilding is not needed, but it seems due to differences in the git version used by some users and the version used by Jenkins it was not detected as requiring a rebuild.
     
    • Like Like x 1
    • Friendly Friendly x 1
  5. SlimeDog

    Patron

    Since the duplicates are 469, 471, and 472, it is reasonably likely that posters looked for duplicates, didn't find any, and (nearly) simultaneously posted new tickets.
     
    • Agree Agree x 1
  6. md_5

    Administrator Developer

    They were posted several hours apart
     
    • Funny Funny x 2
    • Informative Informative x 1
  7. SlimeDog

    Patron

    Confirmed fixed in Jenkins 2400. Thanks.
     
    • Winner Winner x 1
  8. Hi

    When will the stable version come out? An idea ?
    Regards
     
  9. When Mojang released a stable version.
     
    • Like Like x 1
    • Optimistic Optimistic x 1
    • Optimistic Optimistic x 1
    • Useful Useful x 1
  10. Yeah, 1.14.4 is looking promising. Pre-release 6 tackled both the above mentioned bug as well as an unreported memory leak issue.
     
  11. Still & all, "stable is as stable does," and @md_5 needs better than the turd that was 1.14.0 to start with for a real good polish on Spigot. We're getting there, and I look forward to seeing how Vanilla 1.14.4 pans out. I'd *really* like to enjoy Optifine, Fabric mods, ViveCraft, and such, if I can figure out how to get them all to play together... plugins being "ok" with the Spigot I'm running, that sort of thing. The 1.14 series has been a seriously rough ride. :(
     
  12. Well... Server crashed.. With 4 players online - due to out of memory.. With 1000 chunks only.