Bukkit, CraftBukkit, Spigot & BungeeCord 1.14.4 Development Builds

Discussion in 'News and Announcements' started by md_5, Apr 23, 2019.

Thread Status:
Not open for further replies.
  1. I tried this, same error.
  2. Thanks for updating ! I have tried this version on my server, it looks like the server timeout a lot of times, without any error or any specific case that I am able to detect (I don't known if it is related, but this is a world converted from 1.13 to 1.13 btw)
  3. Is anyone else running this on Linux? Having some issues with Open Broadcaster Software. Issue is 100% specific to Minecraft 1.14. Edge case, but most productive to ask here than in a forum full of Fortnite players.

    Still... not surprised if this is a me-problem. Anyone?

    [Edit] SOLVED. It only ever works with Optifine - true of both Windows and Linux, but worse for Linux without game capture alternative. If you searched and found this post, install Optifine for your current version and breathe easy.
    #103 smellyonionman, Apr 23, 2019
    Last edited: Apr 23, 2019
  4. Thanks for releasing 1.14-pre5 so quickly, I'll give it a try later and look forward to first release build of 1.14
  5. Same for me, have you managed to get inventory titles working again?
  6. Maximvdw


    Seems my plugins were spared from the changes apart from two things:
    1) Forgot that I used "callEvent" in an async thread. Now throws an error in 1.14
    2) Some weird error with CraftEvil that I need to investigate further (fails on "getType()" method of a block)
    ^its called in an async thread, so could be something to do with this + compatibility layer
  7. Anyone else having a tough time will essentials on the pre release?
  8. Choco


    You can depend on the 1.14 API if you want and have it run on 1.13, so long as no 1.14 features are used. In your plugin.yml, you would have to specify api-version: 1.13. This field serves as a way to stop your plugin from loading on versions that you cannot support. i.e. if you absolutely require the use of 1.14 methods, that is the api version you would specify

    Literally every single change is on the Stash (as per usual). I’m sure you can figure this out yourself

    Come on... he’s sleeping... lol
    • Like Like x 1
    • Funny Funny x 1
  9. Perhaps I read it wrong but for clarification, if I build my plugin against 1.14’s jar and specify api version 1.14 will the plugin refuse to run on a 1.13 server even if I do not use any 1.14 api specific methods???

    Previously it was on us plugin authors to make sure we didn’t invoke a method that did not exist if the plugin supported multiple versions. Which was totally fine and I’m sure people would be okay with that rather than having two compile and maintain multiple versions of a plugin because of the api version setting.

    Sent from my iPhone using Tapatalk
  10. Maximvdw


  11. *excited sysadmin noises*
    • Funny Funny x 1
  12. *dread developer noises*
    • Funny Funny x 2
  13. https://pastebin.com/qAeaJgKV
    I don't have these issues with CMI though, loads a lot better. EssentialsX is currently unusable. They just need some time to adjust and update.
    • Agree Agree x 1
  14. release plugins used on the 1.14 community server?
  15. So to clear things up for me, this Spigot version will ONLY work with 1.14 Pre Release 5 and NOT with Full Release 1.14?
    Thanks in advance :)

    Nonetheless LOVING the work you are doing! :)
    • Optimistic Optimistic x 1
  16. Yes.

    Mojang only released 1.14 like an hour or so ago.
    Screenshot 2019-04-23 at 19.22.10.png
  17. Most likely. Could always test ;) But I believe they wont work
  18. Oh my bad, I was not looking at the time haha. Thanks anyway! :)
Thread Status:
Not open for further replies.