Bukkit, CraftBukkit, Spigot & BungeeCord 1.15.1

Discussion in 'News and Announcements' started by md_5, Dec 10, 2019.

  1. Both plugins should have loaded correctly, you would only see some errors on startup but that should not have effected regular plugin work.
     
    • Like Like x 1
  2. Nice work! Keep it up!
     
    • Friendly Friendly x 1
  3. So speaking as someone who only poked around in plugins to fix an abandoned one that broke with 1.13 - how do I make sure the plugin is actually coded correctly against the system now?

    Currently the plugin references whatever is being held by the player via ItemStack item = player.getInventory().getItemInMainHand(); - it's intended to only affect items with damage counters, do I need to wrap that inside another conditional to test whether the thing being held is actually an itemstack instead of a material?
     
  4. I ran:
    java -jar BuildTools.jar --compile craftbukkit
    which seems to complete successfully, but when I try to run craftbukkit.sh I still get an error that says *** Error, this build is outdated ***
     
  5. Personally I couldn't replicate your issue, my command to build build tools: (on a Mac btw)
    Code (Text):
    cd ~/Desktop/Server/Archived/BuildTools
    export JAVA_HOME=`/usr/libexec/java_home -v '1.8*'`
    java -Xmx2G -jar BuildTools.jar --compile craftbukkit
    Server started up promptly with this as the output from /ver:
    Code (Text):
    >ver
    [14:13:17] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-752cf95 (MC: 1.15.1) (Implementing API version 1.15.1-R0.1-SNAPSHOT)
    [14:13:17] [Server thread/INFO]: Checking version, please wait...
    [14:13:17] [Thread-12/INFO]: You are running the latest version
     
  6. Code (Text):

    $ ./craftbukkit.sh
    *** Error, this build is outdated ***
    *** Please download a new build as per instructions from https://www.spigotmc.org/go/outdated-spigot ***
    *** Server will start in 20 seconds ***
    Loading libraries, please wait...
    [17:25:19] [Server thread/INFO]: Starting minecraft server version 1.15.1
    [17:25:19] [Server thread/INFO]: Loading properties
    [17:25:19] [Server thread/INFO]: Default game type: SURVIVAL
    [17:25:19] [Server thread/INFO]: Generating keypair
    [17:25:20] [Server thread/INFO]: Starting Minecraft server on *:19132
    [17:25:20] [Server thread/INFO]: Using default channel type
    [17:25:20] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-2d9db47 (MC: 1.15.1) (Implementing API version 1.15.1-R0.1-SNAPSHOT)
    [17:25:20] [Server thread/INFO]: Preparing level "world"
    [17:25:21] [Server thread/INFO]: Reloading ResourceManager: Default, bukkit
    [17:25:30] [Server thread/INFO]: Loaded 6 recipes
    [17:25:31] [Server thread/INFO]: Preparing start region for dimension 'world'/minecraft:overworld
    [17:25:31] [Server thread/INFO]: Preparing spawn area: 0%
    [17:25:36] [Server-Worker-1/INFO]: Preparing spawn area: 83%
    [17:25:37] [Server-Worker-2/INFO]: Preparing spawn area: 83%
    [17:25:38] [Server-Worker-3/INFO]: Preparing spawn area: 85%
    [17:25:39] [Server thread/INFO]: Time elapsed: 8725 ms
    [17:25:39] [Server thread/INFO]: Preparing start region for dimension 'world_nether'/minecraft:the_nether
    [17:25:42] [Server thread/INFO]: Preparing spawn area: 0%
    [17:25:43] [Server-Worker-3/INFO]: Preparing spawn area: 91%
    [17:25:44] [Server-Worker-2/INFO]: Preparing spawn area: 91%
    [17:25:44] [Server thread/INFO]: Time elapsed: 4839 ms
    [17:25:44] [Server thread/INFO]: Preparing start region for dimension 'world_the_end'/minecraft:the_end
    [17:25:44] [Server thread/INFO]: Preparing spawn area: 0%
    [17:25:45] [Server-Worker-2/INFO]: Preparing spawn area: 0%
    [17:25:45] [Server thread/INFO]: Time elapsed: 924 ms
    [17:25:45] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [17:25:45] [Server thread/INFO]: Done (24.721s)! For help, type "help"
    and ver...
    Code (Text):
    >ver
    [17:25:48] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-2d9db47 (MC: 1.15.1) (Implementing API version 1.15.1-R0.1-SNAPSHOT)
    [17:25:48] [Server thread/INFO]: Checking version, please wait...
    [17:25:54] [Thread-11/INFO]: You are 27 version(s) behind
     
  7. Whatever you're running, it isn't the .jar file you just built. Check the file timestamps.
     
    • Agree Agree x 1
  8. I agree with Bobcat here.
    I would also recommend (since you are having this issue) deleting your entire BuildTools directory (with the exception of BuildTools.jar and your script) and run it all from scratch.
     
  9. Yes, keep in mind that the CraftBukkit jar file is no longer in the root BuildTools directory; You have to go hunting for it. I don't know if BuildTools deletes the old jar file in the now-unused folder. So maybe that's what you're grabbing.
     
  10. md_5

    Administrator Developer

    It is if you use --compile craftbukkit, which you have to use now in 1.15.1+
     
    • Friendly Friendly x 1
  11. As md stated ^

    To clear up any confusion, for 1.14.x it was removed from the root directory, but when md_5 did the --compile craftbukkit, it is now back in the root directory... magic :)

    PS @md_5 incase no one said anything, thank you for reverting that ItemStack change :)
     
    • Friendly Friendly x 1
  12. I'm getting this error occasionally. Any idea what's causing it?

    2020-01-19 08:14:47 [WARN] An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception.
    java.nio.channels.ClosedChannelException: null
    at io.netty.channel.AbstractChannel$AbstractUnsafe.write(...)(Unknown Source) ~[custom.jar:git-Spigot-037559e-752cf95]
     
    • Agree Agree x 1
  13. md_5

    Administrator Developer

    Did you enable debug in server.properties? That causes extra warnings like this to appear
     
    • Optimistic Optimistic x 1
  14. Thank you so much
     
    • Funny Funny x 1
    • Friendly Friendly x 1
  15. Nope. debug=false
     
    • Winner Winner x 1
    • Friendly Friendly x 1
  16. Yay 1.15.2, i guess..
     
    • Like Like x 1
    • Agree Agree x 1
  17. Did they just have released it? ... Yep it does. Hope it won't f*k out plugins which depend on the protocol/mcversion/nms things :X
     
    • Informative Informative x 1
  18. thanks this is very helpful
     
    • Agree Agree x 1
    • Funny Funny x 1
  19. Any plugin breakage in 1.15.2? Don't get off work for another 5 hours so someone give me a sneak peak before I update my test server thanks :^)
     
    • Optimistic Optimistic x 1