Bukkit, CraftBukkit, Spigot & BungeeCord 1.15.1

Discussion in 'News and Announcements' started by md_5, Dec 10, 2019.

  1. seem to work with most of my plugin. only seem broken is ticket support, npc, and tab plugin due to unsupport plugin!
     
  2. Probably because they use NMS directly and they haven't updated their plugins yet.
     
  3. The update process has cost me three hours less sleep.
    Who cares about sleep after a Spigot major release?
     
  4. We're developers, sleep is unnecessary luxery anyway.
     
    • Funny Funny x 3
  5. Is Dyescape updated to 1.15 already? :eek::LOL:
     
  6. If not we riot

    on topic:
    I love how my two plugins need 0 changes for 1.15 xD
     
    • Like Like x 2
    • Agree Agree x 1
  7. Do you think that 1.15 will be better than 1.14 in terms of stability and cpu usage etc?
     
  8. I love how quickly Bukkit gets updated.
     
    • Like Like x 1
  9. Great work! Thank you so much for this!
     
  10. No. I don't really want to update from 1.13.2 to 1.14 or higher due to the absolute garbage performance. It's a first release, we don't know about performance. It would be beyond risky to update to 1.14 or 1.15 now. We'll see if 1.15.1 (or paper) has any sane performance, otherwise I won't update until we have performance evaluated our own stuff.
     
    • Like Like x 1
  11. About 10 from 27 plugins doesn't work on 1.15 :(
     
  12. Awesome job Spigot team!
     
  13. Looks like it is caused by outdated Worldedit. I get same error and it goes away when plugin is not loaded. Need to wait for an update..
     
  14. Legoman99573

    Supporter

    You mean how longer its delayed for :ROFLMAO::ROFLMAO::ROFLMAO::ROFLMAO::ROFLMAO:
    https://howoldisminecraft.today/1.8.8
     
    #74 Legoman99573, Dec 11, 2019
    Last edited: Dec 11, 2019
    • Like Like x 2
    • Useful Useful x 2
  15. Hi all, is there a way to get a beta version of Bungee 1.15 or does someone know how to allow others to connect via bungee in 1.15?
     
  16. https://ci.md-5.net/job/BungeeCord/1426/ - this is the build supporting 1.15
     
    • Friendly Friendly x 1
  17. Thanks so much for the quick update, how is it performing compared to 1.14?
     
  18. Better, but not all plugins compatible. For example - protocolLib doesn't allow players to join the server.
    CrazyCrates doesn't work. Similar
     
  19. since today 1.12.2 is 2 years, 2 months and 22 days old, did mojang plan to release 1.15 on such a special date as a replacement for 1.12.2's performance?
     
    • Like Like x 2
  20. [​IMG]
     
    • Funny Funny x 1