Bungee - Proxy Bungee Chat 2.2.3

A new way to send private, global or help messages and to do much more with chatting network wide!

  1. Says I don't have permission to use /g What server does the permission folder need to be on?
     
  2. You have to use the BungeePermissions. Never the less I need an answer of the developer =/
     
  3. Thanks, I'll give it a go ;p
     
  4. How do I get prefix's to work? I'm using %sprefix: but it displays the default bungeechat prefix instead of the one set in bungeeperms.
     
  5. It depends on your configuration in BungeeChat.
    Code (Text):
    # Bungee Chat Configuration by shawn_ian (v4)
    # Placeholders can be found here: http://tiny.cc/bungeechatplaceholders
    # In the config file you can change the chat formats and disable and enable feautures.
    # If you found any bugs please report them (See plugin site for more information)

    Formats:
      alert: "&9ALERT > &c&l%sender: &r%message"
      socialspy: "&9SPY > &e%sender &8-> &e%target&8: &r%message"
      global: "&9GLOBAL > &e%sender: &r%message"
      message-sender: "&6You &8-> &6%target&8: &r%message"
      message-target: "&6%sender &8-> &6You&8: &r%message"
      staffchat: "&9STAFF > &e%sender: &r%message"
      muted: "&cSorry but you can not talk because you are muted!"
      local-chat: "%sprefix&7%sender: %message"
      joinmessage: "&e%sender has joined the network!"
      leavemessage: "&e%sender has left the network!"
      helpop: "&2HELPOP > &e%sender: &r%message"

    Messages:
      incorrect-usage: "&cIncorrect usage! Use this command like this: %command"
      not-player: "&cYou need to be a player to use this command!"
      muted: "&cSorry but you can not talk because you are muted!"
      unmute: "&eThe player &c%target &cehas been unmuted!"
      mute: "&eThe player &c%target &cehas been muted!"
      unmute-not-muted: "&cThis player is not muted!"
      mute-is-muted: "This player is already muted!"
      enable-global: "&eYou are now talking in &bglobal chat&e!"
      disable-global: "&eYou are no longer talking in &bglobal chat&e!"
      no-reply: "&cYou have nobody to reply."
      reply-offline: "&cThe player you were chatting with is no longer online."
      message-yourself: "&cYou can not send a message to yourself..."
      player-not-found: "&cCould not find that player..."
      remove-prefix: "&eRemoved the prefix of &6%target&e!"
      set-prefix: "&eSet the prefix of &6%target &eto %prefix&e!"
      enable-socialspy: "&eSocialspy has been &aenbaled&e!"
      disable-socialspy: "&eSocialspy has been &cdisabled&e!"
      enable-staffchat: "&eYou are now talking in &astaffchat&e!"
      disable-staffchat: "&eYou are no longer talking in &astaffchat&e!"
      enable-messager: "&eYou have &aenbaled&e messaging!"
      disable-messager: "&eYou have &cdisabled&e messaging"
      has-messager-disabled: "&c%target has messaging disabled!"
      enable-vanish: "&eYou have &aenbaled&e hide mode!"
      disable-vanish: "&eYou have &cdisabled&e hide mode!"
      enable-muteall: "&eYou have muted all chats!"
      disable-muteall: "&eYou have unmuted all chats!"
      chat-is-disabled: "&cYou may not talk now, chatting has been disabled!"
      global-is-default: "&eGlobal chat is already the default chatmode!"
      not-server: "&c%tserver is not a valid server."

    Enabled:
      alert: true
      socialspy: false
      global: true
      message: true
      staffchat: true
      muting: true
      chatmanager: true
      joinmessage: true
      leavemessage: true
      helpop: true
      vanish: true
      muteall: true

    Options:
       Global-is-default-chat: false

    Mute-Blocked-Commands:
      - message
      - msg
      - whisper
      - m
      - tell
      - t
      - w
      - global
      - g
      - reply
      - r
     
  6. Depends on? Where do I change it? I don't see it
     
  7. chatmanager: true
     
  8. It is set to true but it still does not seem to be working :/
     
  9. please add uuid support, please !

    i want so much uuid's support .;p

    in the chat prefixes config, please add uuuuuuuiiiiiddddddddd
     
    #89 Vinicius0075, Feb 16, 2016
    Last edited by a moderator: Feb 17, 2016
  10. Is it possible for you to make an english tutorial for setting up the plugin?
     
  11. +1
     
  12. Hi,
    Is/Can there be a Placeholder for a Group Manager prefix as I really need it for Donation Prefixes as /setprefix cannot be done by console
     
  13. Like I said in my review,
    "
    Some suggestions,
    - Add support for prefixes staff chat
    - When Global chat is Default, add a /chat local or just /local
    - add bungeechat.admin wich gives u all admin perms
    "

    But I forgot to add, that you should add a server Blacklist

    :D
     
  14. Seems to have problems with 1.9.

    If you use `/staffchat` as a toggle and get into the staff chat mode and then speak you will disconnected with the message.

    Internal Exception: io.netty.handler.codec.DecoderException:com.google.gson.JsonSyntaxException:com.google.gsons.stream.MalformedJsonException: Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 2

    ----
    Nevermind, updating BungeeCord seemed to fix this.
     
    #94 zoredache, Mar 4, 2016
    Last edited: Mar 4, 2016
  15. Hi, I would love you if you added /tempmute <player> <time> <reason>
    That is all C:
     
  16. Is there a feature built in to prevent people advertising other servers?
     
  17. Are there any /mail commands? If not will you add some? Like the essentials mail system except for the whole network.
     
  18. With chatmanager set to true, other players don't seem to see the local chat
     
  19. Hmmmm, the perms are meant to be added to the Bungee groups or the Server permission manager like Pex? I added them to the Bungee but it keeps telling me permission denied. And does the plugin have to be on all servers too, or just the Bungee Proxy is fine?
     
  20. im having a issue with the permissions. I have added the global permission and some other ones in the bungee config and also in the groupmanager one. But people including OPs do not have permissions to use /g or what ever.
    What am i doing wrong??