Bungee Passing Proper Player Ip

Discussion in 'BungeeCord Discussion' started by notyetrated, Apr 12, 2013.

  1. So I know a relatively recent commit to Bungee allowed it to pass the proper player IP address to spigot enabled servers, and it worked great for me while Bungee and all servers were on the same box.

    I have just move a couple of servers and Bungee to another box, so I have Bungee connecting 2 physical servers at different IP addresses together. Bungee does not appear to be passing through the IP anymore. Is this normal? Or have I somehow configured something incorrect?
     
  2. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    Would help to see a copy of your config explaining which servers belong to which box. Are your servers located in different spots? Any errors in bungee start up? All your servers are reachable from an outside source? Need more information.
     
  3. Information below. Did not originally provide, as I wanted to first see if that is a known issue, not passing IP when on different boxes.

    All servers are reachable. No issues there. Only issue is /whois shows "Server2" IP, instead of players IP. Did not have this issue 10 minutes ago when Bungee was all on my Server1.

    Bungee Version: 328
    Spigot: 750 on all servers

    Server1 Server: Hosting multiple servers. IP=192.200.200.200
    Server2: Hosting Bungee+ "Hub" server. IP=192.300.300.300
    Hub:
    Code (Text):
    listeners:
    - max_players: 777
      host: 0.0.0.0:25565
      force_default_server: true
      motd: The LegendsMC Hub
      default_server: legendshub
      forced_hosts:
        pvp.md-5.net: hub
      tab_size: 65
      texture_size: 32
    servers:
      legendsmc:
        address: 192.200.200.200:25566
        restricted: false
      build:
        address: 192.200.200.200:25569
        restricted: false
      modded:
        address: 192.200.200.200:25567
        restricted: false
      test:
        address: 192.200.200.200:25568
        restricted: false
      skyblock:
        address: 192.200.200.200:25570
        restricted: false
      factions:
        address: 192.200.200.200:25571
        restricted: false
      legendshub:
        address: localhost:25555
        restricted: false
     
  4. You need to setup the bungee-ip option in SPIGOT'S config.yml
     
  5. Spigots config.yml = bukkit.yml?

    I have no option for "Bungee-IP", though I do have a "Bungee-proxies" set as

    Code (Text):
      bungee-proxies:
      - 127.0.0.1
    on all servers....
     
  6. Yes, this. Sorry. You need to change 127.0.0.1 to whatever the bungeecord IP is.
     
  7. If I run Bungee on my Windows box(as I always have, with it passing IP's correctly), and goto a server hosted on my Linux box, even on that Linux hosted server it shows my correct IP.

    If I swap the Bungee to the Linux box, all servers still show the Linux Box's IP. This is without ever changing the bungee-proxy setting from default on any of the servers.

    I have also changed the bungee-proxy to reflect the linux Ip address, to no avail. It quite honestly appears to be a Ubuntu/Linux issue somehow... Unless I am still somehow missing something, which is quite possible.
     
  8. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    If its connecting to local host only the box with bungeecord will receive the ip's, the other one won't.
     
  9. Even in that case, it is not working. I just set up a test environment with clean files for everything still no luck. Odd.
     
  10. Please provide your bungeecord config.yml and your minecraft server's server.properties. We can't help you without those.If you want to obfuscate the IP, at least make it so we can differentiate different IPs.
     
  11. MCServer1, On Linux Box:
    Bukkit.yml: http://pastebin.com/fCVBvGkG
    Server.properties: http://pastebin.com/kTMQQ06U

    Bungee, On Linux Box:
    config.yml: http://pastebin.com/nRzktwx3

    Bungee Version: 328
    Spigot: 750

    These, as noted, are both hosted currently on the Linux box. Logging into bugee, sends me to MCServer1(legendshub), IP shows as the IP of my linux box itself to plugins, not of my actual IP. verified with hawkeye and essentials command /WHOIS. using Bungee command /IP shows my correct IP.

    This EXACT same set up hosted on my Windows box works as intended.
     
  12. I'm like 80% sure it won't work, but the only thing I can think of trying is changing
    Code (Text):
    servers:
      legendshub:
        address: localhost:25555
        restricted: false
     
    to
    Code (Text):
    servers:
      legendshub:
        address: 127.0.0.1:25555
        restricted: false
     
     
  13. Ya, no worky. Thanks for trying though!
     
  14. I updated my spigot version and bungeecord and for some reason it works now !
     
  15. To which versions?
     
  16. Sorry for late react. Spigot 794 and bungee 330