Bungee - Proxy BungeeBridge 0.2

A powerfull, complete cross proxy bridge

  1. zyuiop submitted a new resource:

    BukkitBridge - A powerfull, complete cross proxy bridge

    Read more about this resource...
     
    • Like Like x 1
  2. You really need a youtube tutorial.
     
  3. Error when I loading plugins:
    Code (Text):

    >[email protected]:/home/bungeecord# java -jar BungeeCord.jar
    19:05:04 [INFOS] Using OpenSSL based native cipher.
    19:05:04 [INFOS] Using native code compressor
    19:05:04 [INFOS] Enabled BungeeCord version git:BungeeCord-Bootstrap:1.8-SNAPSHOT:"cc3a8c0":1071
    19:05:04 [INFOS] Discovered module: ModuleSpec(name=cmd_alert, file=modules/cmd_alert.jar, provider=JenkinsModuleSource())
    19:05:04 [INFOS] Discovered module: ModuleSpec(name=cmd_find, file=modules/cmd_find.jar, provider=JenkinsModuleSource())
    19:05:04 [INFOS] Discovered module: ModuleSpec(name=cmd_list, file=modules/cmd_list.jar, provider=JenkinsModuleSource())
    19:05:04 [INFOS] Discovered module: ModuleSpec(name=cmd_send, file=modules/cmd_send.jar, provider=JenkinsModuleSource())
    19:05:04 [INFOS] Discovered module: ModuleSpec(name=cmd_server, file=modules/cmd_server.jar, provider=JenkinsModuleSource())
    19:05:04 [INFOS] Discovered module: ModuleSpec(name=reconnect_yaml, file=modules/reconnect_yaml.jar, provider=JenkinsModuleSource())
    19:05:04 [AVERTISSEMENT] Could not load plugin from file plugins/BungeeStaffChat-V2.jar
    java.lang.NullPointerException: Plugin must have a plugin.yml or bungee.yml
        at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:226)
        at net.md_5.bungee.api.plugin.PluginManager.detectPlugins(PluginManager.java:338)
        at net.md_5.bungee.BungeeCord.start(BungeeCord.java:245)
        at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:54)
        at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)
    19:05:04 [INFOS] Loaded plugin cmd_alert version git:cmd_alert:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Loaded plugin BungeeServerManager version 1.0.15-SNAPSHOT by Teg
    19:05:04 [INFOS] Loaded plugin Yamler version 2.3.0-SNAPSHOTb-5 by geNAZt
    19:05:04 [INFOS] Loaded plugin OverflowLobby version 1.3 by Batschkoto
    19:05:04 [INFOS] Loaded plugin authmehook-bungee version 1 by Moo_im_a_cow
    19:05:04 [INFOS] Loaded plugin cmd_find version git:cmd_find:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Loaded plugin BPlugins version 1.0.0 by dommi2212
    19:05:04 [AVERTISSEMENT] Error enabling plugin BungeeBridge
    java.lang.UnsupportedClassVersionError: net/bridgesapis/bungeebridge/BungeeBridge : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
        at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
        at net.md_5.bungee.api.plugin.PluginClassloader.loadClass0(PluginClassloader.java:34)
        at net.md_5.bungee.api.plugin.PluginClassloader.loadClass(PluginClassloader.java:27)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
        at net.md_5.bungee.api.plugin.PluginManager.enablePlugin(PluginManager.java:297)
        at net.md_5.bungee.api.plugin.PluginManager.loadPlugins(PluginManager.java:205)
        at net.md_5.bungee.BungeeCord.start(BungeeCord.java:247)
        at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:54)
        at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)
    19:05:04 [INFOS] Loaded plugin reconnect_yaml version git:reconnect_yaml:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Loaded plugin BungeeWeb version 0.1 by Dead-i
    19:05:04 [INFOS] Loaded plugin cmd_server version git:cmd_server:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Loaded plugin cmd_send version git:cmd_send:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Loaded plugin cmd_list version git:cmd_list:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [AVERTISSEMENT] Forced host server pvp is not defined
    19:05:04 [INFOS] Enabled plugin cmd_alert version git:cmd_alert:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Enabled plugin BungeeServerManager version 1.0.15-SNAPSHOT by Teg
    19:05:04 [INFOS] Enabled plugin Yamler version 2.3.0-SNAPSHOTb-5 by geNAZt
    19:05:04 [INFOS] Enabled plugin OverflowLobby version 1.3 by Batschkoto
    19:05:04 [INFOS] Enabled plugin authmehook-bungee version 1 by Moo_im_a_cow
    19:05:04 [INFOS] Enabled plugin cmd_find version git:cmd_find:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Enabled plugin BPlugins version 1.0.0 by dommi2212
    19:05:04 [INFOS] Enabled plugin reconnect_yaml version git:reconnect_yaml:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [GRAVE] [BungeeWeb] Unable to connect to MySQL database. BungeeWeb may not function properly.
    19:05:04 [GRAVE] [BungeeWeb] BungeeWeb is disabling. Please check your database settings in your config.yml
    19:05:04 [INFOS] Enabled plugin BungeeWeb version 0.1 by Dead-i
    19:05:04 [INFOS] Enabled plugin cmd_server version git:cmd_server:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Enabled plugin cmd_send version git:cmd_send:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Enabled plugin cmd_list version git:cmd_list:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    19:05:04 [INFOS] Listening on /0.0.0.0:25577
     
    Thanks you !,
     
  4. You shall use Java 8 if you want to use BUngeeBridge
     
  5. Hey !
    I'm currently working on full i18n
    It's not really easy, as this plugin was not planned at all to be internationalized, but I'm working on it.
    Expect a release soon =)