BungeeCord: Cannot Bind To Host on Shared Hosting

Discussion in 'BungeeCord Discussion' started by TheEnvy, Jun 18, 2013.

  1. Hi,
    I need a little help with my Bungee Cord setup.
    I have 5 servers on Shared Hosting, my objective being to create a lobby server using Bungee.
    I have had some problems though. Here's what happened:

    I bought all 5 servers. 1 dedicated to hosting Bungee, 1 for the lobby and 3 for the game types. I set up the hosting server running BungeeCord, everything was fine. I had ordered a dedicated IP with the hosting, which took about 5 hours to kick in. So about 5 hours later, it did so, and I updated the config the the new Host IP. When I went into the console, I got a big long Java error saying "Cannot Bind to Host" and "Cannot assign requested address". I knew something was wrong, so I submitted a ticket asking if anything else was running on that port. A long chain of tickets then went on about If it was possible to switch back to the old IP, as I knew it had worked then. When it did happen, I again updated the host address back to as it was, and then I got this same "Cannot Bind To Host" error again. This time I tried to remove everything off the FTP root directory, and replace the BungeeCord.jar in and run the server again. It was again fine, but then gave me the error once I updated the IP and Port. It is now able to listen on a localhost IP address or 0.0.0.0, but it is unable to listen on my IP.

    Here are pastes of the log:
    http://pastebin.com/ujP9sUAE
    & config.yml:
    http://pastebin.com/P1hhB4x3

    Thank you very much for help I get. I will very much appreciate it.
     
  2. LiLChris

    LiLChris Retired Moderator
    Retired

    • Agree Agree x 2
  3. Yes, I had to because I don't have enough money to buy a dedicated server.

    And, thanks for that, but I used that post for the first setup.