Bungeecord connection problems.......

Discussion in 'Spigot Plugin Help' started by dadofthree, Jan 18, 2020.

  1. Hello all.
    I currently have a bungeecord network setup and on-line by a hosting company, the current problem I have is I can't get one of the servers to connect or even be visible to the bungeecord server?

    This is what I have:
    BungeeCord 1.15.1 server
    Lobby (Spigot)1.12.2 Server
    Factions (Paper)1.12.2 server
    Skyblocks (Spigot)1.12.2 server
    Villagedefence (Spigot)1.12.2 server
    Prison (Spigot) 1.12.2 server
    All these work fine and run as they should, with no connection issues.

    I tried adding another server, Paper 1.12.2 for Survival, and it won't connect, or even get noticed by ViaVersions. I've set this up no different to the others, but just can't work out what I'm doing wrong?

    I've added from pastebin my bungeecord config, and the problem servers bukkit, spigot, paper yml and the server properties file.

    If anyone can help, that would be great, as been trying to sort this myself for about a month now........
     

    Attached Files:

  2. Each server needs a unique port, and you have to put that same port in the bungeecord config but what you did is you put the same port for all servers, so eventually it won't work.
     
  3. Doesnt every server in the bungeecord config need a port defined instead of 00000?
     
  4. Ah yes im a bit late with my reply
     
    • Funny Funny x 1
  5. Hi.
    I removed all port and ip addresses for posting, but each servers ip and port is placed in configs, I just removed them for posting purposes.

    Sorry, should have stated that.
     
  6. did set bungeecord: true in each spigot.yml ?
     
  7. Maybe you ran out of ports the host gives you? Probably not but just a thought
     
  8. Yes, all spigot.yml is set to bungeecord: true.
     
  9. I've tried getting my host company to look into this, but they always seem to busy, so one last try before I cancel that server......
     
  10. what's exactly the problem ? does the servers show in /server ? if yes, is there an error when you try to join them ? and are your others server on ?
     
  11. When I do /server, it shows up along with all the others, I can click each one and it connects, except this one, it makes me wait around 10 seconds, then states "Could not connect to a default or fallback server, please try again later: io.netty.channel.ConnectTimeOutException"

    I've had all these servers for 2 months now and all built ready to use, and running all the time, just not advertised, but this one is the only one I have had problems with. I've even copied and pasted the yml files from the other servers to see if I've missed something, but still not working.
    I do, however, make sure I'm always using the right ip and port when doing this.......

    And no errors in bungeecord or this servers consoles?

    I have noticed though, when i check the viaversions config, it finds all servers, except this one?
     
  12. Ive replicated your setup with a few servers, viaversion and the same configs on a local machine, ive had no issues whats however. Where is your ViaVersion installed btw?
     
  13. ViaVersions is on my bungeecord server with protocolSupport, Viabackwards.

    Thank you for your reply.
     
  14. Have you checked your VPS/dedicated server's firewall? Do you have any enabled? If it shows when using /server it means the local machine can see it, but if it times out then maybe you're unable to connect remotely because of that.
     
  15. I've not installed one, and it works ok on the other servers, and they all setup the same.
    Unless it's something my server host has, but trying to get them to help is like trying to get blood from a stone!

    I've just sent them a steaming message, as it seems this is not going to be a easy or quick fix........
     
  16. hm... i imagine you already tried running it on a different port then? you could be so unlucky that the port you chose may already be reserved or used by some other protocol/service.

    if i understand correctly, all your other servers are official Spigot ones, while the new one is PaperSpigot. could it be the issue? have you tried using the official one? is it the latest build?
    what about running it without plugins (other than ViaVersion)?
     
  17. Some other ideas I came up with, that may help you localize the problem - have you tried:
    1. running this particular server as another one? (eg using prison's config)
    2. only swapping the port between this server and another one?
    3. swapping this server and another one in bungee.config?

    These three things may look similar or pointless but could actually help in identifying the problem, because:
    1. if this works, then the problem is in the server's config, not related to networking.
    2. if this works, then the problem is purely related to the port and may be caused by another service.
    3. if this works, then the problem is caused by some error (maybe wrong yaml spacing/formatting) in the bungee's config.
     
  18. Hi.
    I listed my servers in the post, a mixture of Spigot, BungeeCord and Paper. Those ones all work faultlessly, just this one is the one that doesn't seem to want to work no matter what.
    But, I did try other MC versions (1.12.2 - 1.15.1) and makes (paper, spigot) but the results are always the same, no change, will not connect?
    Someone suggested it might be my version of Bungeecord, so updated that, but still not working.
    It just amazes me, i got 6 servers working faultlessly, but the seventh is being a right stick in the mud!

    I do appreciate everyone's help and support, and will still try and sort it, but I fear I may have to chalk this one down to experience and cancel this server instead.
     
  19. Whoops sorry, I didn't see Paper listed in your servers - and of course I thought having Bungee was implied. The fastest and best method to solve your problem imho is to just make another server from scratch, make sure it's working and you can connect to it, and then copy everything you need from the previous non-working one, step by step, always checking that everything still works.
     
  20. 1) I done this and it changed nothing, still the same as before.
    2) I noticed I had two port, rcon and port, used both, no change.
    3) tried this with skyblocks, no change, still does the same.

    I was hoping one would make a difference, but nope...lol.