Bungeecord intense lag when under bot attack

Discussion in 'BungeeCord Help' started by GuysImTristan, Jun 1, 2018.

  1. Code (Text):
    01.06 12:56:11 [Server] WARN Event PreLoginEvent(cancelled=true, cancelReasonComponents=[TextComponent{text=AntiBotDeluxe » 01.06 12:56:11 [Server] INFO You've got kicked from our System 01.06 12:56:11 [Server] INFO Your IP Address is detected as an proxy. 01.06 12:56:11 [Server] INFO If you think that is an issue contact us! 01.06 12:56:11 [Server] INFO , BaseComponent(color=, bold=null, italic=null, underlined=null, strikethrough=null, obfuscated=null, insertion=null, extra=null, clickEvent=null, hoverEvent=null)}], connection=[110.49.11.50/110.49.11.50:45538|MCSpam_PQF1MZl44] <-> InitialHandler) took 414,876,631ns to process!

    So when those f*** kids "bot attack" our server or forcibly join thousands of proxies aka bots at once, server lags immensely we cannot even join it. I do have an antibot plugin and it does block those proxies to ever entering the server but the prelogin events is lagging the server so much. (Click on the spoiler for the error) Help is needed! What can I do to stop/lessen the lag?
     
  2. Sure... You have to insert the ip with iptables when the proxy will connect the server, so when a proxy has connected at once, so he can't build a connection to the server...
     
  3. With „proxies“ he means Proxy-Servers or VPNs.
     
  4. Yeah of course I know?
     
    • Like Like x 1
  5. I did contact the author of the plugin but he considered it resolved when he asked me to enable late-bind and I did. But it didn't really fix my issue.
     
  6. Thanks for the suggestion!