BungeeCord Permissions

Discussion in 'BungeeCord Discussion' started by RiotShielder, Jun 11, 2013.

Thread Status:
Not open for further replies.
  1. I use /perms in-game, tells me I am part of the group default

    Probably something obvious that I should of noticed, so here is my config.

    Code (Text):
    groups:
      riotshielder:
      - admin
    permissions:
      default:
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
      - bungeecord.command.send
     
    • Friendly Friendly x 2
    • Agree Agree x 1
  2. This is a guess, but perhaps groups is case-sensitive? I'm assuming your IGN is RiotShielder instead of riotshielder.
     
    • Informative Informative x 2
    • Friendly Friendly x 1
  3. It is. I'll try it
     
  4. Yup, fixed it. Thanks!
     
    • Agree Agree x 1
  5. Is there any way to allow /server to specific servers and deny /server to specific servers?
     
    • Optimistic Optimistic x 1
  6. I don't think replying to a thread from 5 months ago is the best way to get an answer. Especially when the question isn't really related.

    If you're still looking for an answer:

    Set the server(s) to restricted
    Code (Text):
    pvp:
    address: 127.0.0.1:25564
    restricted: true
    Then only give this permission to people allowed to access the server:
    Code (Text):
    permissions:
      myspecialgroup:
         - bungeecord.server.pvp
     
    • Like Like x 4
  7. hmmm, what about replying to a post 2 years later with something that isn't relevant?
     
    • Funny Funny x 9
    • Like Like x 4
    • Optimistic Optimistic x 1
  8. Heh
     
  9. Can someone tell me why this doesn't work


    Code (Text):
    Mod:
      - litebans.*
      - -litebans.ipban
      - -litebans.warn
      - -litebans.unwarn
      - -litebans.warnings
      - -litebans.iphistory
      - -litebans.banlist
      - -litebans.staffrollback
      - -litebans.lastuuid
      - -litebans.geoip
      - -litebans.dupeip
      - -litebans.ipreport
      - -litebans.lockdown
      - -litebans.admin
      - -litebans.notify.ipban
      - -litebans.notify.banned_join
      - -litebans.notify.mute
      - -litebans.notify.dupeip_join
      - -litebans.exempt
      - -litebans.exempt.ban
      - -litebans.exempt.mute
      - -litebans.exempt.warn
      - -litebans.exempt.bypass
      - -litebans.exempt.kick
      - staffchat.toggle
      - staffchat.send
      - staffchat.receive
      - slashserver.hub
      - slashserver.prison
      - slashserver.factions
      - slashserver.hcf
      - slashserver.kitpvp
      - bungeecord.command.server
      - bungeecord.command.list
     
  10. This is a guess, but perhaps groups is case-sensitive? I'm assuming your IGN is RiotShielder instead of riotshielder.
     
    • Funny Funny x 1
  11. JBT

    JBT

    Im still stuck on this
     
    • Friendly Friendly x 1
  12. Everything is cool and dandy but it wont let me use /server any ideas?

    Here is my config... Please help?

    ip_forward: true
    network_compression_threshold: 256
    stats: 10bec3bd-a0fd-4261-a117-5ea697fa9d63
    groups:
    ItzTony_:
    - admin
    assassin_crazy5:
    - admin
    servers:
    KitPvP:
    motd: '&1Just another BungeeCord - Forced Host'
    address: localhost:25563
    restricted: false
    Factions:
    motd: '&1Just another BungeeCord - Forced Host'
    address: localhost:25564
    restricted: false
    timeout: 30000
    player_limit: -1
    listeners:
    - query_port: 25565
    motd: '&cChromaKitPvP &6[&cNow BungeeCord&6]'
    priorities:
    - KitPvP
    bind_local_address: true
    tab_list: GLOBAL_PING
    query_enabled: false
    host: 0.0.0.0:25565
    forced_hosts:
    ChromaKitPvP.zapto.org: KitPvP
    max_players: 350
    tab_size: 60
    ping_passthrough: false
    force_default_server: true
    permissions:
    default:
    - bungeecord.command.server
    - bungeecord.command.list
    admin:
    - bungeecord.command.alert
    - bungeecord.command.end
    - bungeecord.command.ip
    - bungeecord.command.reload
    online_mode: true
    log_commands: false
    disabled_commands:
    - disabledcommandhere
    connection_throttle: 4000
     
  13. This thread was created 3 years ago...
     
  14. Litebans needs to be in the Bukkit perms
     
  15. Vagdedes

    Supporter

    I don't really know whats wrong with your config, but I do recommend you to set the connection_throttle to 0. Its very annoying
     
  16. I might be able to help you with your bungeecord config, that is if it is still having issues...


    I will re-write the entire config to hopefully get it working, but before I do that, I need to know, do your other servers in the properties file, have online-mode disabled? If not, then that is the issue, right there, all your servers, other than the bungeecord server NEED to be set to offline mode, but don't worry about non-paying players, because they will need to go through the bungeecord server (which is in online mode) in order to join any server in this list, also, if you havn't already, go into the spigot.yml file in the base of your servers, other than the bungeecord server, and set bungeecord: true
    And make sure it is like that on all your servers!!!
    Now for the bungeecord Config:

    ip_forward: true
    network_compression_threshold: 256
    stats: 10bec3bd-a0fd-4261-a117-5ea697fa9d63
    groups:
    ItzTony_:
    - admin
    assassin_crazy5:
    - admin
    servers:
    KitPvP:
    motd: '&1Just another BungeeCord - Forced Host'
    address: localhost:25563
    restricted: false
    Factions:
    motd: '&1Just another BungeeCord - Forced Host'
    address: localhost:25564
    restricted: false
    timeout: 30000
    player_limit: -1
    listeners:
    - query_port: 25565
    motd: '&cChromaKitPvP &6[&cNow BungeeCord&6]'
    priorities:
    - KitPvP
    bind_local_address: true
    tab_list: GLOBAL_PING
    query_enabled: false
    host: 0.0.0.0:25565
    forced_hosts:
    pvp.md-5.net: pvp
    max_players: -1
    #This is for the bungeecord server, not the other servers
    tab_size: 60
    ping_passthrough: false
    force_default_server: true
    permissions:
    default:
    - bungeecord.command.server
    - bungeecord.command.list
    admin:
    - bungeecord.command.alert
    - bungeecord.command.end
    - bungeecord.command.ip
    - bungeecord.command.reload
    online_mode: true
    log_commands: false
    disabled_commands:
    - disabledcommandhere
    connection_throttle: 0

    Try that, and let me know how it works!
     
    #17 MCPro1122334, Aug 22, 2016
    Last edited: Aug 22, 2016
    • Like Like x 1
Thread Status:
Not open for further replies.