Bungeecord problem [Screen Terminating]

Discussion in 'BungeeCord Help' started by iSweekZ, Feb 25, 2020.

  1. Ok so i just installed bungeecord on a vps i can launch it, but when i connect to the server it didnt connect me and in the console i can see [Exception Connecting:NativeIoException : readAddress(..) failed: Connection reset by peer] then around 1 minute after it close and write [screen is terminating]

    Error in the console:
    [​IMG]

    [​IMG]

    Config.yml
    Code (Text):
    server_connect_timeout: 5000
    listeners:
    - query_port: 25577
      motd: '&1Another Bungee server'
      priorities:
      - one
      bind_local_address: true
      tab_list: GLOBAL_PING
      query_enabled: false
      host: 0.0.0.0:25565
      forced_hosts:
        pvp.md-5.net: pvp
      max_players: 1
      tab_size: 60
      ping_passthrough: false
      force_default_server: false
      proxy_protocol: false
    remote_ping_cache: -1
    permissions:
      default:
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
    network_compression_threshold: 256
    timeout: 30000
    log_pings: true
    connection_throttle_limit: 3
    prevent_proxy_connections: false
    inject_commands: false
    player_limit: -1
    ip_forward: true
    groups:
      syuu_u:
      - admin
    remote_ping_timeout: 5000
    connection_throttle: -1
    log_commands: false
    stats: f2876aa6-74d2-468c-90ee-1377111f1c9f
    online_mode: false
    forge_support: false
    disabled_commands:
    - disabledcommandhere
    servers:
      one:
        motd: '&1Just another BungeeCord - Forced Host'
        address: localhost:25566
        restricted: false
      two:
        motd: '&1Just another BungeeCord - Forced Host'
        address: localhost:25567
        restricted: false
    S1. Server Properties
    Code (Text):
    #Minecraft server properties
    #Mon Feb 24 21:14:51 EST 2020
    view-distance=10
    max-build-height=256
    server-ip=
    level-seed=
    allow-nether=true
    enable-command-block=false
    server-port=25566
    gamemode=0
    enable-rcon=false
    op-permission-level=4
    enable-query=false
    generator-settings=
    resource-pack=
    player-idle-timeout=0
    level-name=world
    motd=one
    announce-player-achievements=true
    force-gamemode=false
    debug=false
    hardcore=false
    white-list=false
    pvp=true
    spawn-npcs=true
    generate-structures=true
    spawn-animals=true
    snooper-enabled=true
    difficulty=1
    network-compression-threshold=256
    level-type=DEFAULT
    spawn-monsters=true
    use-native-transport=true
    max-players=20
    online-mode=false
    allow-flight=false
    resource-pack-hash=
    max-world-size=29999984
     
    S2. Server Properties
    Code (Text):
    #Minecraft server properties
    #Mon Feb 24 20:23:58 EST 2020
    view-distance=10
    max-build-height=256
    server-ip=
    level-seed=
    allow-nether=true
    enable-command-block=false
    server-port=25567
    gamemode=0
    enable-rcon=false
    op-permission-level=4
    enable-query=false
    generator-settings=
    resource-pack=
    player-idle-timeout=0
    level-name=world
    motd=two
    announce-player-achievements=true
    force-gamemode=false
    hardcore=false
    white-list=false
    pvp=true
    spawn-npcs=true
    generate-structures=true
    spawn-animals=true
    snooper-enabled=true
    difficulty=1
    network-compression-threshold=256
    level-type=DEFAULT
    spawn-monsters=true
    use-native-transport=true
    max-players=20
    online-mode=false
    allow-flight=false
    resource-pack-hash=
    max-world-size=29999984
     
    Thank you, i don't know if i provide enough information.
     
    #1 iSweekZ, Feb 25, 2020
    Last edited: Feb 25, 2020
  2. Update : I mage some research and i think its the java version the problem. Pretty much all forum post talking about this message Exception Connecting:NativeIoException : readAddress(..) failed: Connection reset by peer is about java version but i tried .. but i don't know wich one is the good one and how to change it right now i have this ..

    Code (Text):
    openjdk version "11.0.6" 2020-01-14
    OpenJDK Runtime Environment (build 11.0.6+10-post-Ubuntu-1ubuntu119.10.1)
    OpenJDK 64-Bit Server VM (build 11.0.6+10-post-Ubuntu-1ubuntu119.10.1, mixed mode, sharing)
     
    If someone know how to solve my problem i will love to ear them
     
  3. Try Java 8

    Also not sure if you intended this, but your Bungee is in offline mode.
     
  4. First, thank you for the respond

    Im not very sure if ur talking about online_mode: false if yes, ib the video that i followed to setup the bungee they said to do this i don't know what they do im ganna try tommorow to put it on.

    And for java im pretty sure the version i have rn is the 8 because i installed it but i install a bunch of java i maybe mess up somewhere i was not sure wich one to chose so i was just lile putting some random commands that some sime gave me to install java 8

    Sorry for my english
     
  5. The BungeeCord config is meant to have online-mode set to true if you don't want cracked accounts to join. All of your Spigot servers should have online-mode set to false in their server.properties files.

    Regarding your Java version, in the log you posted it says OpenJDK 11, meaning Java 11. If you have mutliple Java versions installed then I believe you need to change some environment variable to point to the right Java installation path.
     
  6. Yeah, so i set the online-mode to the good mode cuz i don't want crack to join my server

    And for the java i have a question.. if my java version on the server is 11 and my version on my pc is 8 it is suppose to work anyway or i need 8 on the pc and 8 on the server. And if ur suppose to have both so 8 on the server and 8 on the pc how does other server can accept multiple java version cuz i suppose we don't have all same java version?
     
  7. What Minecraft version is your server running?
     
  8. I installed spigot 1.8.8
     
  9. Oh, i just solve my problem, it was the java version ... i was on 1.11 i downgrade to 1.8.0 and now its working properly :)