BungeeCord

Discussion in 'Wiki Discussion' started by jtaylor69, Jun 15, 2013.

  1. It's showing up on the bungee server console:

    03.04 20:50:52 [Server] INFO disconnected with: Kicked whilst connecting to lobby: You are not whitelisted on this server!
     
  2. Check the bungeechord files then.
     
  3. Not sure what i would be checking, everything seems fine.

    Here's the bungee config however http://pastebin.com/nCT60eX2
     
  4. Few options you can do:

    1) Go into the server directory and find the spigot.yml. Then change the "whitelist" to whatever you want.

    2) On the "server" console type the following "whitelist add <your playername>" (MAKE SURE THAT YOU ARE NOT TYPING IN THE SERVER PROXY!)

    3) Go into the server.properties file in the server directory and change the "whitelist" to false.
     
  5. There's a bungeecord exploit that allows players to OP themselves on bungeecord servers. I have the latest BungeeCord. Unfortunately, I'm not sure how to recreate the exploit. I know this isn't much help..
    I run a pretty large bungeecord server (around 100+ players). A small hosting company is now attempting to extort me, for not using their hosting, by using this exploit. My server is currently offline. Someone just logged in and started placing TNT everywhere at the hub after I refused to use his hosting. I don't think this exploit is public, otherwise it would've already been patched. I'm currently backing up my files. (I run PokeNexus, it's the third largest Pixelmon server. You can contact me through this forums or on my website.)
    I'm really sorry I can't give you more information, but if you contact me I'm willing to provide you with logs, files, and any other information you need to fix this.
    Has anyone else had to deal with this? If so, please point me in the right direction. I'm going to be researching this quite a bit.
    Edit:
    I posted an alert on PokeNexus's homepage. I'll keep you posted. I'm looking for a patch. The person who's exploiting me once ran a bungeecord server, he had it patched. I have no idea how, he didn't tell me. Apparently he planned on using the exploit against me.
    Edit 2:
    I failed to set up my firewall properly when I installed bungeecord. I believe setting up my firewall properly will fix the exploit. If not I'll update my reply.
    Edit 3:
    I've blocked people from connecting to any port aside from the bungee proxy port. This isn't stopping my hub from being trashed. I'm not sure why, but they didn't grief any other servers, aside from the hub. Any ideas?
     
    #25 PixelsAreFood, Jul 6, 2015
    Last edited: Jul 7, 2015
  6. Are your backend servers (Spigot servers) protected by firewalls/iptables/setup so players are only able to connect through the proxy? If not, then this is your issue. It's pretty common that owners forget about this, and I think that you're experiencing the same.
     
    • Like Like x 2
  7. Not sure, I've just recently started using BungeeCord and spigot because of an influx of players. For months I've only ran 1 large server. I had to split it up due to lag. Thank you. I'll see if this is the problem.
     
  8. 1#:
    Man in the middle attack server: https://github.com/acecheese/HaxorCord
    Client sided: http://ghosted.me/ZfM6Cs (yes, for that I used eclipse, deal with it)
    Edit:
    :/
    Edit 2:
    Yes, that will fix things, like everyone doesn't say that nor does it say that on the wiki.
     
  9. New update.
     
  10. I've switched to Linux, I set up IPTables to block all ports aside from BungeeCord (25565). Now players are unable to connect to the server. I'm guessing the proxy isn't passing them along, rather it's trying to directly connect them? I don't understand why it would do this, I've further explained this in my help thread here:
    https://www.spigotmc.org/threads/iptables-preventing-players-from-joining.76625/
     
  11. There are quite a few exploits if you don't set up BungeeCord properly. Make sure you follow all the guides in-depth when you set things up. I did not do this, and it caused a lot of trouble and a lot of downtime. I'm still having trouble with BungeeCord, so in the meantime I'm just separating my servers with different dedicated IPs, and listing them all on my modpack. It's a temporary fix until I've finished setting BungeeCord up properly.
    Thanks for pointing me in the right direction GGhost and Darth.
    Much appreciated. :)
     
  12. People keep getting kicked to the hub from the prison server. Does anyone know why this is happening or how to fix it?
     
  13. Im using BungeeCord for my server and when I open BungeeCord not on localhost is gives this error:

    16:57:34 [INFO] Using OpenSSL based native cipher.
    16:57:34 [INFO] Using native code compressor
    16:57:34 [INFO] Enabled BungeeCord version git:BungeeCord-Bootstrap:1.8-SNAPSHOT:"6343416":1076
    16:57:34 [INFO] Discovered module: ModuleSpec(name=cmd_alert, file=modules/cmd_alert.jar, provider=JenkinsModuleSource())
    16:57:34 [INFO] Discovered module: ModuleSpec(name=cmd_find, file=modules/cmd_find.jar, provider=JenkinsModuleSource())
    16:57:34 [INFO] Discovered module: ModuleSpec(name=cmd_list, file=modules/cmd_list.jar, provider=JenkinsModuleSource())
    16:57:34 [INFO] Discovered module: ModuleSpec(name=cmd_send, file=modules/cmd_send.jar, provider=JenkinsModuleSource())
    16:57:34 [INFO] Discovered module: ModuleSpec(name=cmd_server, file=modules/cmd_server.jar, provider=JenkinsModuleSource())
    16:57:34 [INFO] Discovered module: ModuleSpec(name=reconnect_yaml, file=modules/reconnect_yaml.jar, provider=JenkinsModuleSource())
    16:57:34 [INFO] Loaded plugin cmd_alert version git:cmd_alert:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:34 [INFO] Loaded plugin cmd_find version git:cmd_find:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:34 [INFO] Loaded plugin reconnect_yaml version git:reconnect_yaml:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:34 [INFO] Loaded plugin cmd_server version git:cmd_server:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:34 [INFO] Loaded plugin cmd_send version git:cmd_send:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:34 [INFO] Loaded plugin cmd_list version git:cmd_list:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:35 [WARNING] Forced host server pvp is not defined
    16:57:35 [INFO] Enabled plugin cmd_alert version git:cmd_alert:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:35 [INFO] Enabled plugin cmd_find version git:cmd_find:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:35 [INFO] Enabled plugin reconnect_yaml version git:reconnect_yaml:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:35 [INFO] Enabled plugin cmd_server version git:cmd_server:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:35 [INFO] Enabled plugin cmd_send version git:cmd_send:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:35 [INFO] Enabled plugin cmd_list version git:cmd_list:1.8-SNAPSHOT:"6343416":1076 by SpigotMC
    16:57:35 [WARNING] Could not bind to host mc.cainpvp.info/**.***.**.**:25565 <-- I * out my ip for privacy
    java.net.BindException: Cannot assign requested address

    at sun.nio.ch.Net.bind0(Native Method)
    at sun.nio.ch.Net.bind(Net.java:444)
    at sun.nio.ch.Net.bind(Net.java:436)
    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
    at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:125)
    at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:478)
    at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1021)
    at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:455)
    at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:440)
    at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:844)
    at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:197)
    at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:350)
    at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:380)
    at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:357)
    at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:116)
    at java.lang.Thread.run(Thread.java:745)

    I've port forwarded the port for the BungeeCord and the two servers it connects. Why does it give me this ERROR?
     
  14. Wait just a small question: For Bungeecord, is it like (Hub, Factions, Prison, Bungeecord) or just Hub, Factions and Prison? It's just an example.
     
  15. You can add as many servers as you want to BungeeCord..
     
  16. Hub, factions, prison, BungeeCord