Bungeefier not working!! Please help!!

Discussion in 'Server & Community Management' started by djhey1234321, Jul 17, 2013.

  1. Hi this is an error I get from running bungeefier:
    Code (Text):
    07:40:15 [SEVERE] Jul 17, 2013 7:40:15 AM com.vexsoftware.votifier.net.VoteRecei
    ver initialize
    SEVERE: [Votifier] IP address and port are not already in use. This is a common
    problem
     
    07:40:15 [SEVERE] Jul 17, 2013 7:40:15 AM com.vexsoftware.votifier.net.VoteRecei
    ver initialize
    SEVERE: [Votifier] with hosting services and, if so, you should check with your
    hosting provider.
    java.net.BindException: Cannot assign requested address: JVM_Bind
        at java.net.DualStackPlainSocketImpl.bind0(Native Method)
        at java.net.DualStackPlainSocketImpl.socketBind(Unknown Source)
        at java.net.AbstractPlainSocketImpl.bind(Unknown Source)
        at java.net.PlainSocketImpl.bind(Unknown Source)
        at java.net.ServerSocket.bind(Unknown Source)
        at java.net.ServerSocket.bind(Unknown Source)
        at com.vexsoftware.votifier.net.VoteReceiver.initialize(VoteReceiver.java:62
    )
        at com.vexsoftware.votifier.net.VoteReceiver.<init>(VoteReceiver.java:42)
        at com.vexsoftware.votifier.Votifier.onEnable(Votifier.java:136)
        at net.md_5.bungee.api.plugin.PluginManager.loadAndEnablePlugins(PluginManag
    er.java:158)
        at net.md_5.bungee.BungeeCord.start(BungeeCord.java:226)
        at net.md_5.bungee.BungeeCord.main(BungeeCord.java:188)
     
     
    07:40:15 [SEVERE] Jul 17, 2013 7:40:15 AM com.vexsoftware.votifier.Votifier grac
    efulExit
    SEVERE: [Votifier] Votifier did not initialize properly!
     
    07:40:15 [INFO] Enabled plugin Bungeefier version 1.0 by hcherndon,VexSoftware
    Please help! my port is defualt!
     
  2. joehot200

    Supporter

    SEVERE: [Votifier] IP address and port are not already in use.
     
  3. How do I fix this? Please help, but thank you for replying!
     
  4. joehot200

    Supporter

    The port is already in use, try changing the port ;)
     
  5. But it sais their not in usewhy does it say the oppisite? (srry for my curiosity)
     
  6. joehot200

    Supporter

    The port is already in use, im guessing its one of your servers. As long as the voting websites allow you to change the port, it should not really matter.
    You could also clear the port 25577 (thats the default, i believe), For ubuntu the command is netstat -ntlp | awk '$4~/:*25567$/{gsub(/\/.*/,"",$NF);cmd="kill -9 "$NF;system(cmd)}'
     
  7. Wait do i need to port forward?
     
  8. joehot200

    Supporter

    Idk. What system are you on?
     
  9. Windows 7 , all bukkit, bungee cord
     
  10. joehot200

    Supporter

    Guessing its your home PC (Not recommended) then yes you would have to port-foward, yes.
     
  11. Ok THANK YOU SO MUCH!