Spigot Buycraft Confirm ➜ Protect yourself from chargebacks ✦ Confirm GUI ✦ Open Source ✦ 1.8 - 1.16.4 1.0.6 - Updated

Confirm GUI for buycraft purchases, Great for chargeback proof

  1. Splodgebox submitted a new resource:

    Buycraft Confirm ➜ Protect yourself from chargebacks ✦ Confirm GUI ✦ 1.8 - 1.16.1 - Confirm GUI for buycraft purchases, Great for chargeback proof

    Read more about this resource...
     
  2. doesnt work for me on 1.16.1
     
  3. Any error?
     
  4. 26.06 21:35:44 [Server] Server thread/ERROR Could not load 'plugins/BuycraftConfirm-1.0.1.jar' in folder 'plugins'
    26.06 21:35:44 [Server] INFO org.bukkit.plugin.InvalidPluginException: Unsupported API version 1.15.2
    26.06 21:35:44 [Server] INFO at org.bukkit.craftbukkit.v1_16_R1.util.CraftMagicNumbers.checkSupported(CraftMagicNumbers.java:275) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
    26.06 21:35:44 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e] 26.06 21:35:44 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:394) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
    26.06 21:35:44 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:301) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
    26.06 21:35:44 [Server] INFO at org.bukkit.craftbukkit.v1_16_R1.CraftServer.loadPlugins(CraftServer.java:380) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
    26.06 21:35:44 [Server] INFO at net.minecraft.server.v1_16_R1.DedicatedServer.init(DedicatedServer.java:186) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
    26.06 21:35:44 [Server] INFO at net.minecraft.server.v1_16_R1.MinecraftServer.v(MinecraftServer.java:810) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
    26.06 21:35:44 [Server] INFO at net.minecraft.server.v1_16_R1.MinecraftServer.lambda$0(MinecraftServer.java:164) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]

    the first line is about buycraftconfirm, not sure if the other lines are about it or not
     
  5. you probably just have to update the api-version of it, im on 1.16.1 btw
     
  6. Yh I just need to update the API version, I'll do that in a sec
     
  7. hey ur discord link doesn't work, and i have 3 suggestions, be able to put on bungeecord only ;), have a mysql support and /bconfirm info <player> to see important infos about the player and the package associated etc. ;)
     
  8. 1) I probably won't do the first suggestion
    2) I will add SQL support soon
    3) I will add info command soon aswell.
     
  9. ok, one last thing, can u update the discord link please ? ;)
     
  10. I notice that this plugin works on 1.16, but, atleast according to this link: https://www.spigotmc.org/resources/buycraft.336/, Buycraft itself is not available for 1.16 yet. So, if buycraft does work for 1.16, could someone maybe send me a link to the updated version? I'd appreciate it. :)
     
  11. Splodgebox updated Buycraft Confirm ➜ Protect yourself from chargebacks ✦ Confirm GUI ✦ Open Source ✦ 1.8 - 1.16.1 with a new update entry:

    1.0.3

    Read the rest of this update entry...
     
  12. Is bungeecord suppot possible?

    I heard u can like have GUIs even on bungee
     
  13. Hey I am super confused. I have gotten the plugin setup and have it working. However, when I confirm a package and have the commands section of the plugin folder run any sort of command they dont work. The placeholders {name} {player} {PLAYER} %player% and %name% did not work.
     
  14. Hey! What happens if they decline the purchase after doing /confirm?
    Because my understanding is that Buycraft is already processing the payment when they clicked on Purchase on the webstore
    So if after they purchase on the webstore decided to decline the agreement that this plugin shows what happens next?
    Do they have to contact us for a refund?