Solved Can anyone help? Prefixes and Sufexes dont work.

Discussion in 'Spigot Help' started by EpicBuild360, May 11, 2016.

  1. Here is the problem, My name is default for some reason, prefixes and suffixes wont work, Im useing pex, and I have asked tons of people, and other players.

    I think I got a problem no one can solve

    So, I'll give you all the info.
    Here is my plugins: http://pastebin.com/ZTz8M9qr
    In color: http://prnt.sc/b2y65v
    Run log: http://pastebin.com/mbTadrqM
    And if it concerns anyone, my folder for my files. http://prnt.sc/b2yd0e

    Info
    : I updated permissionsEX, still no luck. Im using permissionsEX for the prifixes, and suffixes.
    My permissions.yml file: http://pastebin.com/EUGmpJH4
    Picture: http://prnt.sc/b2y9j2

    Plugins file picture: http://prnt.sc/b2yaxf
    Plugins jar picture: http://prnt.sc/b2yay1

    And my desktop: http://prnt.sc/b2ydzd
    Just kidding on the last one, but seriously, Il give you any info that you need.
     
  2. My suggestion is do not use Pex prefixes and suffixes. You can set up prefixes and suffixes for ranks using essentials. Pex never worked for me
     
    • Agree Agree x 1
  3. Oh, ok, let me give that a shot!
     
  4. PermissionsEx prefix works fine for me. Using EssentialsChat to take care of the chat formatting atm.

    /pex group <group> prefix [newprefix]
     
  5. Oh, and there's several errors in your console. Your WorldEdit isnt compatible with the version of Spigot you are running i believe. Also there's an error in WorldGuard. Probably because its dependant on WorldEdit to work.

    Have you enabled this in Essentials config.yml?

    # Disable this if you have any other plugin, that modifies the displayname of a user.
    change-displayname: true

    And what does the EssentialsChat part of your Essentials config.yml look like?

    Mine looks like this (But don't copy paste it, i don't know how to paste code on here, there needs to be two spaces after chat: on format: )

    # This section requires the EssentialsChat.jar to work.

    chat:

    # If EssentialsChat is installed, this will define how far a player's voice travels, in blocks. Set to 0 to make all chat global.
    # Note that users with the "essentials.chat.spy" permission will hear everything, regardless of this setting.
    # Users with essentials.chat.shout can override this by prefixing text with an exclamation mark (!)
    # Users with essentials.chat.question can override this by prefixing text with a question mark (?)
    # You can add command costs for shout/question by adding chat-shout and chat-question to the command costs section."
    radius: 0

    # Chat formatting can be done in two ways, you can either define a standard format for all chat.
    # Or you can give a group specific chat format, to give some extra variation.
    # For more information of chat formatting, check out the wiki: http://wiki.ess3.net/wiki/Chat_Formatting

    format: '{DISPLAYNAME}> {MESSAGE}'
    #format: '&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}'

    group-formats:
    # Default: '{WORLDNAME} {DISPLAYNAME}&7:&r {MESSAGE}'
    # Admins: '{WORLDNAME} &c[{GROUP}]&r {DISPLAYNAME}&7:&c {MESSAGE}'

    # If you are using group formats make sure to remove the '#' to allow the setting to be read.
     
    #5 prefix, May 12, 2016
    Last edited: May 12, 2016
  6. Omg you did it!! I had it set to false, which is what I though it was supposed to be, you have no idea how much that helped me, I thought all hope was lost ;\
     
  7. How would I go around fixing the two errors? Do I need to update the spigot part of my sever? It says im 261 versions behind when I do "/version". I havnt been able to update it and still have the command consul have color.

    I have an old version, all files and everything backed up, and it all works fine.
     
    #7 EpicBuild360, May 13, 2016
    Last edited: May 13, 2016