Solved Can not connect to any of my servers when i have bungeecord installed

Discussion in 'BungeeCord Help' started by hakan9878, Jun 17, 2016.

  1. I am getting a lot of problems with bungeecord, but the only one i couldn't resolve is java.net.connectexception problem on all my server, i can't connect to any of them

    Bungee config
    Code (Text):
    groups:
      md_5:
      - admin
    ip_forward: false
    network_compression_threshold: 256
    stats: c1be4ec6-3b79-418e-a6be-4bfc68ad457f
    permissions:
      default:
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
    online_mode: false
    servers:
      Casa Caselli:
        motd: '&1Just another BungeeCord - CasaCaselli'
        address: localhost:25564
        restricted: false
      ChickenOP Survival:
        motd: '&1Just another BungeeCord - ChickenOP'
        address: localhost:25565
        restricted: false
    timeout: 30000
    listeners:
    - query_port: 25577
      motd: '&1Another Bungee server'
      priorities:
      - Casa Caselli
      bind_local_address: true
      tab_list: GLOBAL_PING
      query_enabled: false
      host: 127.0.0.1:25577
      forced_hosts:
       104.155.28.110:25564: Casa Caselli
      max_players: 100
      tab_size: 60
      ping_passthrough: false
      force_default_server: false
    player_limit: -1
    disabled_commands:
    - disabledcommandhere
    log_commands: false
    connection_throttle: 4000
    "Casa Caselli" server config

    Code (Text):
    #Minecraft server properties
    #Thu Jun 16 10:32:31 UTC 2016
    spawn-protection=0
    max-tick-time=60000
    query.port=25564
    server-name=Casa Caselli
    generator-settings=
    force-gamemode=true
    allow-nether=true
    gamemode=1
    broadcast-console-to-ops=true
    enable-query=true
    player-idle-timeout=0
    difficulty=0
    spawn-monsters=true
    op-permission-level=4
    announce-player-achievements=true
    pvp=true
    snooper-enabled=true
    level-type=DEFAULT
    hardcore=false
    enable-command-block=true
    max-players=100
    network-compression-threshold=256
    resource-pack-sha1=
    max-world-size=29999984
    server-port=25564
    debug=false
    server-ip=127.0.0.1
    spawn-npcs=true
    allow-flight=false
    level-name=world
    view-distance=10
    resource-pack=
    spawn-animals=true
    white-list=false
    generate-structures=true
    max-build-height=256
    online-mode=false
    level-seed=
    use-native-transport=true
    enable-rcon=false
    motd=\u00A7e\u00A7k1010 \u00A7cCasa Caselli Official \u00A7e\u00A7k1010
     
    ChickenOP server config
    Code (Text):
    #Minecraft server properties
    #Thu Jun 16 11:58:28 UTC 2016
    spawn-protection=0
    max-tick-time=60000
    query.port=25565
    server-name=ChickenOP Survival
    generator-settings=
    force-gamemode=true
    allow-nether=true
    gamemode=0
    broadcast-console-to-ops=true
    enable-query=true
    player-idle-timeout=0
    difficulty=0
    spawn-monsters=true
    op-permission-level=4
    announce-player-achievements=true
    pvp=true
    snooper-enabled=true
    level-type=DEFAULT
    hardcore=false
    enable-command-block=true
    max-players=100
    network-compression-threshold=256
    resource-pack-sha1=
    max-world-size=29999984
    server-port=25565
    debug=false
    server-ip=127.0.0.1
    spawn-npcs=true
    allow-flight=false
    level-name=world
    view-distance=10
    resource-pack=
    spawn-animals=true
    white-list=false
    generate-structures=true
    online-mode=false
    max-build-height=256
    level-seed=
    use-native-transport=true
    motd=\u00A7e\u00A7k1010 \u00A7cCasa Caselli Official \u00A7e\u00A7k1010
    enable-rcon=false
     
    Bungee console output
    Code (Text):
    01:15:12 [INFO] Using native code compressor
    01:15:12 [INFO] Enabled BungeeCord version git:BungeeCord-Bootstrap:1.10-SNAPSHOT:97eef62:1159
    01:15:12 [INFO] Not on Windows, attempting to use enhanced EpollEventLoop
    01:15:12 [INFO] Epoll is working, utilising it!
    01:15:12 [INFO] Discovered module: ModuleSpec(name=cmd_alert, file=modules/cmd_alert.jar, provider=JenkinsModuleSource())
    01:15:12 [INFO] Discovered module: ModuleSpec(name=cmd_find, file=modules/cmd_find.jar, provider=JenkinsModuleSource())
    01:15:12 [INFO] Discovered module: ModuleSpec(name=cmd_list, file=modules/cmd_list.jar, provider=JenkinsModuleSource())
    01:15:12 [INFO] Discovered module: ModuleSpec(name=cmd_send, file=modules/cmd_send.jar, provider=JenkinsModuleSource())
    01:15:12 [INFO] Discovered module: ModuleSpec(name=cmd_server, file=modules/cmd_server.jar, provider=JenkinsModuleSource())
    01:15:12 [INFO] Discovered module: ModuleSpec(name=reconnect_yaml, file=modules/reconnect_yaml.jar, provider=JenkinsModuleSource())
    01:15:12 [INFO] Loaded plugin reconnect_yaml version git:reconnect_yaml:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Loaded plugin cmd_find version git:cmd_find:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Loaded plugin cmd_server version git:cmd_server:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Loaded plugin cmd_alert version git:cmd_alert:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Loaded plugin cmd_send version git:cmd_send:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Loaded plugin cmd_list version git:cmd_list:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Enabled plugin reconnect_yaml version git:reconnect_yaml:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Enabled plugin cmd_find version git:cmd_find:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Enabled plugin cmd_server version git:cmd_server:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Enabled plugin cmd_alert version git:cmd_alert:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Enabled plugin cmd_send version git:cmd_send:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Enabled plugin cmd_list version git:cmd_list:1.10-SNAPSHOT:97eef62:1159 by SpigotMC
    01:15:12 [INFO] Listening on /127.0.0.1:25577
     
    //edit, alredy set throttle on -1 and bungeecord on true in spigot.yml

    //edit x2, my ports are unlocked, everything worked fine untill i installed bungeecord
     
    #1 hakan9878, Jun 17, 2016
    Last edited: Jun 17, 2016
  2. Are you connecting to bungeecord using 127.0.0.1:25577?
     
    • Like Like x 1
  3. absolutely no! 104.155.28.110:25577

    Forgot to mention. i am running everything on a dedicated server.
     
  4. Is the port forwarded through the firewall? Or is the firewall off?
     
    • Like Like x 1
  5. Opened the ports i needed (25564,25565 and 25577)
    [​IMG]
     
  6. The image did not show up. Try turning off the firewall completely and see if that fixes the issue.
     
    • Like Like x 1
  7. Can not do that, i am working on google dedicated server and they don't have options to turn their firewalls off,
     
  8. Change " host: 127.0.0.1:25577" to " host: 0.0.0.0:25577"
     
    • Like Like x 1
  9. Worked! Thanks! I got an error saying that i needed to enable port forwarding, enabled port forwarding and now i get this. Every config is set on offline mode.[​IMG]
     
  10. Restart your sub-servers
     
    • Like Like x 1
  11. Did it, still have the same problem :\
     
  12. Re check your config values. Check online-mode and make sure all the ports are correct.
     
    • Like Like x 1
  13. modified all 127.0.0.1 to 0.0.0.0 and now it works! Thank you for your help!
     
  14. Sweet. Glad it works. You're welcome. You can mark the thread Resolved now.
     
    • Like Like x 1
  15. reopening the thread :/ sadly it worked for 20 minutes, i installed bungeeportals they worked pretty well for 10 minutes and then... [​IMG]
     
  16. That just means the server you are trying to connect to is offline. Check to make sure the server is online and all the ips/ports are correct.
     
    • Like Like x 1