Can only join 1 server in-game

Discussion in 'BungeeCord Help' started by 71Zombie, Feb 25, 2018.

  1. I have recently set up a BungeeCord server, It seems that I can only join one of the servers, when I try to join other servers I get this message "Could not connect to a default or fallback server, please try again later: io.netty.channel.AbstractChannel$AnnotatedConnectionExeption"

    Note: I do have IpWhitelist installed but I removed it from one of the servers to try to fix this issue put it didn't work.


    All servers are set in online mode false and bungeecord is set to true and bungee is set to true


    Edit: My one server keeps kicking me when I join, It is 512 MB with plenty of RAM left.

    27.02 18:49:26 [Server] INFO CONSOLE issued server command: /list 27.02 18:48:49 [Server] INFO CONSOLE issued server command: /list 27.02 18:48:12 [Server] INFO CONSOLE issued server command: /list 27.02 18:47:35 [Server] INFO CONSOLE issued server command: /list 27.02 18:46:57 [Server] INFO CONSOLE issued server command: /list 27.02 18:46:20 [Server] INFO CONSOLE issued server command: /list 27.02 18:45:43 [Server] INFO CONSOLE issued server command: /list 27.02 18:45:06 [Server] INFO CONSOLE issued server command: /list 27.02 18:44:29 [Server] INFO CONSOLE issued server command: /list 27.02 18:43:52 [Server] INFO CONSOLE issued server command: /list 27.02 18:43:15 [Server] INFO CONSOLE issued server command: /list 27.02 18:43:11 [Server] INFO Saved the world 27.02 18:43:11 [Server] INFO Saving... 27.02 18:43:11 [Server] INFO Saving is already turned on 27.02 18:43:11 [Multicraft] Auto-saving world... 27.02 18:42:38 [Server] INFO CONSOLE issued server command: /list 27.02 18:42:01 [Server] INFO CONSOLE issued server command: /list 27.02 18:41:24 [Server] INFO CONSOLE issued server command: /list 27.02 18:40:47 [Server] INFO CONSOLE issued server command: /list 27.02 18:40:09 [Server] INFO CONSOLE issued server command: /list 27.02 18:39:32 [Server] INFO CONSOLE issued server command: /list 27.02 18:38:55 [Server] INFO CONSOLE issued server command: /list 27.02 18:38:18 [Server] INFO CONSOLE issued server command: /list 27.02 18:37:41 [Server] INFO CONSOLE issued server command: /list 27.02 18:37:04 [Server] INFO CONSOLE issued server command: /list 27.02 18:36:27 [Server] INFO CONSOLE issued server command: /list 27.02 18:35:50 [Server] INFO CONSOLE issued server command: /list 27.02 18:35:13 [Server] INFO CONSOLE issued server command: /list 27.02 18:34:59 [Server] INFO [BuycraftX] Updating coupon list... 27.02 18:34:36 [Server] INFO CONSOLE issued server command: /list
     
    #1 71Zombie, Feb 25, 2018
    Last edited: Feb 27, 2018
  2. All the game servers need to be in offline mode with bungeecord: true set and make sure the server you are trying to connect to is running.

    The only server that needs to be in online mode is bungeecord
     
  3. Thats just what I said...
     
  4. Config just remove ips If you’d like
     
  5. Attach the config.yml for bungee please? Are you sure the server was actually running and registered in your config and that you were doing it directly by the hub and not trying to access a specific server via a port?

    Edit: From what your error says, it seems that you only have the Bungee server running and not an actual Spigot server, as Bungee is a proxy and not an actual server you connect to. Try starting your hub/lobby’s server (and register it in the Bungee config.yml, and in server.properties of the hub server set online-mode to false and Bungee online mode to true) along with BungeeCord server and let me know if you encounter the same issue?

    Edit 2: Ok apparently I can’t read, try opening your second server also and registering it in the Bungee config.yml. If you think it has enough ram then there must be some sort of 2nd server start up error such as a plugin (or you didn’t open it at all) that’s assuming you registered it in config.yml of the Bungee server. Make sure it fully loads up and try typing /server [servername], if that doesn’t work and it shows the same error then try typing /glist and see if the server shows up there. And make sure you’re doing this in-game as a player and not on the console.

    And go to server.properties in each Spigot server and make sure server IP stays the same and in Bungee make sure the ‘address’ part of the server registering is ‘localhost(or whatever it is, probably localhost):[port]’

    Thanks & hope I helped,
    Toby
     
    #5 TobyJDev, Mar 2, 2018
    Last edited: Mar 2, 2018