Can someone help my with this error??

Discussion in 'BungeeCord Discussion' started by Rodrix47, Jun 13, 2021.

  1. [WARNING] Could not bind to host /0.0.0.0:25577
    java.net.BindException: Address already in use: bind
    at java.base/sun.nio.ch.Net.bind0(Native Method)
    at java.base/sun.nio.ch.Net.bind(Net.java:552)
    at java.base/sun.nio.ch.ServerSocketChannelImpl.netBind(ServerSocketChannelImpl.java:336)
    at java.base/sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:294)
    at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:134)
    at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:562)
    at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1334)
    at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:506)
    at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:491)
    at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:973)
    at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:260)
    at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:356)
    at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:164)
    at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:472)
    at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:500)
    at io.netty.util.concurrent.SingleThreadEventExecutor$4.run(SingleThreadEventExecutor.java:989)
    at io.netty.util.internal.ThreadExecutorMap$2.run(ThreadExecutorMap.java:74)
    at java.base/java.lang.Thread.run(Thread.java:831)
    >
     
  2. This is my config.yml right now
     

    Attached Files:

  3. Phoenix616

    Resource Staff

    This means that there is already a program listening on the port 25577. Make sure to stop any other server before trying to start a new one or specify a different port.
     
  4. I just changed the port to 25565 and it is not still working, and I have not created any server on the port 25565 apart from the bungeecord one.

    Everything was working perfectly a couple of hours ago, I was playing in a server and when I tried to open de bungeecord again the error showed up, there is also no server running when I try to start the bungeecord.

    Edit: oohhh you said program not servers, well, how can I know which is the program which is causing this?
     
    #4 Rodrix47, Jun 13, 2021
    Last edited: Jun 13, 2021
  5. It's not the easiest thing to do on Windows as far as I'm aware, I'd just recommend using another port in your case, maybe 25566 or 25568 since it doesn't seem like you've tried those.
     
  6. If all else fails, try restarting your computer or signing off and back on again ;)
     
    • Like Like x 1
  7. I just found out that my FileZilla server was the one using that port. Thank you guys for helping :D