Cannot build NMS with BuildTools

Discussion in 'Spigot Help' started by SCPKeter, Jul 30, 2018.

  1. Sup!

    I was trying to get NMS using buildtools, but when I try to get NMS for 1.13 it fails.

    Log:
    Code (Text):
    git version 2.17.0.windows.1
    Starting clone of https://hub.spigotmc.org/stash/scm/spigot/craftbukkit.git to CraftBukkit
    Cloned git repository https://hub.spigotmc.org/stash/scm/spigot/craftbukkit.git to C:\Users\KeterDev\Desktop\git\Spigot\buildtools\CraftBukkit. Current HEAD: 3f9d7f7770c2c700ef1cc2e9568cfb253996eff8
    Starting clone of https://hub.spigotmc.org/stash/scm/spigot/spigot.git to Spigot
    Cloned git repository https://hub.spigotmc.org/stash/scm/spigot/spigot.git to C:\Users\KeterDev\Desktop\git\Spigot\buildtools\Spigot. Current HEAD: 69774b3e4419d3213023b46dc791214bd39f48d6
    Starting clone of https://hub.spigotmc.org/stash/scm/spigot/builddata.git to BuildData
    Cloned git repository https://hub.spigotmc.org/stash/scm/spigot/builddata.git to C:\Users\KeterDev\Desktop\git\Spigot\buildtools\BuildData. Current HEAD: 351106b6336fc52f6acf94aabd34ac54fc772432
    Maven does not exist, downloading. Please wait.
    Starting download of https://static.spigotmc.org/maven/apache-maven-3.5.0-bin.zip
    Downloaded file: mvn.zip with md5: c062cb57ca81615cc16500af332b93bd
    Extracted: .\apache-maven-3.5.0\README.txt
    Extracted: .\apache-maven-3.5.0\lib\maven-compat.license
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-connector-basic.license
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-provider.license
    Extracted: .\apache-maven-3.5.0\lib\plexus-cipher.license
    Extracted: .\apache-maven-3.5.0\lib\wagon-provider-api.license
    Extracted: .\apache-maven-3.5.0\bin\mvn.cmd
    Extracted: .\apache-maven-3.5.0\lib\ext\README.txt
    Extracted: .\apache-maven-3.5.0\lib\commons-lang3-3.5.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-spi-1.0.3.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-impl-1.0.3.jar
    Extracted: .\apache-maven-3.5.0\lib\wagon-http-2.12-shaded.jar
    Extracted: .\apache-maven-3.5.0\LICENSE
    Extracted: .\apache-maven-3.5.0\lib\maven-embedder.license
    Extracted: .\apache-maven-3.5.0\lib\plexus-sec-dispatcher.license
    Extracted: .\apache-maven-3.5.0\lib\jansi-native\osx\libjansi.jnilib
    Extracted: .\apache-maven-3.5.0\bin\mvnyjp
    Extracted: .\apache-maven-3.5.0\lib\maven-settings-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\plexus-interpolation-1.24.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-repository-metadata-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\javax.inject-1.jar
    Extracted: .\apache-maven-3.5.0\lib\org.eclipse.sisu.inject-0.3.3.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-compat-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\NOTICE
    Extracted: .\apache-maven-3.5.0\lib\maven-artifact.license
    Extracted: .\apache-maven-3.5.0\lib\maven-plugin-api.license
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-transport-wagon.license
    Extracted: .\apache-maven-3.5.0\lib\wagon-file.license
    Extracted: .\apache-maven-3.5.0\bin\m2.conf
    Extracted: .\apache-maven-3.5.0\conf\toolchains.xml
    Extracted: .\apache-maven-3.5.0\lib\maven-core-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\guice-4.0-no_aop.jar
    Extracted: .\apache-maven-3.5.0\lib\cdi-api.license
    Extracted: .\apache-maven-3.5.0\lib\maven-model-builder.license
    Extracted: .\apache-maven-3.5.0\lib\org.eclipse.sisu.inject.license
    Extracted: .\apache-maven-3.5.0\lib\org.eclipse.sisu.plexus.license
    Extracted: .\apache-maven-3.5.0\lib\wagon-http.license
    Extracted: .\apache-maven-3.5.0\bin\mvnDebug.cmd
    Extracted: .\apache-maven-3.5.0\lib\jansi-native\README.txt
    Extracted: .\apache-maven-3.5.0\lib\maven-settings-builder-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\plexus-sec-dispatcher-1.4.jar
    Extracted: .\apache-maven-3.5.0\lib\jsr250-api-1.0.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-provider-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-shared-utils-3.1.0.jar
    Extracted: .\apache-maven-3.5.0\lib\aopalliance-1.0.jar
    Extracted: .\apache-maven-3.5.0\lib\slf4j-api-1.7.22.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-connector-basic-1.0.3.jar
    Extracted: .\apache-maven-3.5.0\lib\commons-cli.license
    Extracted: .\apache-maven-3.5.0\lib\maven-core.license
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-impl.license
    Extracted: .\apache-maven-3.5.0\lib\maven-slf4j-provider.license
    Extracted: .\apache-maven-3.5.0\lib\slf4j-api.license
    Extracted: .\apache-maven-3.5.0\lib\jansi-native\windows64\jansi.dll
    Extracted: .\apache-maven-3.5.0\bin\mvnDebug
    Extracted: .\apache-maven-3.5.0\boot\plexus-classworlds-2.5.2.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-builder-support-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\cdi-api-1.0.jar
    Extracted: .\apache-maven-3.5.0\lib\guava-20.0.jar
    Extracted: .\apache-maven-3.5.0\lib\commons-io.license
    Extracted: .\apache-maven-3.5.0\lib\maven-builder-support.license
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-api.license
    Extracted: .\apache-maven-3.5.0\lib\maven-settings-builder.license
    Extracted: .\apache-maven-3.5.0\lib\maven-shared-utils.license
    Extracted: .\apache-maven-3.5.0\lib\plexus-utils.license
    Extracted: .\apache-maven-3.5.0\lib\jansi-native\windows32\jansi.dll
    Extracted: .\apache-maven-3.5.0\bin\mvn
    Extracted: .\apache-maven-3.5.0\lib\maven-embedder-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\plexus-component-annotations-1.7.1.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-artifact-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-api-1.0.3.jar
    Extracted: .\apache-maven-3.5.0\lib\commons-cli-1.4.jar
    Extracted: .\apache-maven-3.5.0\lib\jansi-1.13.jar
    Extracted: .\apache-maven-3.5.0\lib\commons-lang3.license
    Extracted: .\apache-maven-3.5.0\lib\maven-model.license
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-spi.license
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-util.license
    Extracted: .\apache-maven-3.5.0\lib\plexus-component-annotations.license
    Extracted: .\apache-maven-3.5.0\lib\jansi-native\linux32\libjansi.so
    Extracted: .\apache-maven-3.5.0\conf\logging\simplelogger.properties
    Extracted: .\apache-maven-3.5.0\lib\plexus-utils-3.0.24.jar
    Extracted: .\apache-maven-3.5.0\lib\org.eclipse.sisu.plexus-0.3.3.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-util-1.0.3.jar
    Extracted: .\apache-maven-3.5.0\lib\wagon-provider-api-2.12.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-slf4j-provider-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\jcl-over-slf4j.license
    Extracted: .\apache-maven-3.5.0\lib\jsr250-api.license
    Extracted: .\apache-maven-3.5.0\lib\maven-repository-metadata.license
    Extracted: .\apache-maven-3.5.0\lib\maven-settings.license
    Extracted: .\apache-maven-3.5.0\lib\plexus-interpolation.license
    Extracted: .\apache-maven-3.5.0\lib\jansi-native\linux64\libjansi.so
    Extracted: .\apache-maven-3.5.0\conf\settings.xml
    Extracted: .\apache-maven-3.5.0\lib\maven-model-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\plexus-cipher-1.7.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-plugin-api-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-model-builder-3.5.0.jar
    Extracted: .\apache-maven-3.5.0\lib\commons-io-2.5.jar
    Extracted: .\apache-maven-3.5.0\lib\jcl-over-slf4j-1.7.22.jar
    Extracted: .\apache-maven-3.5.0\lib\wagon-file-2.12.jar
    Extracted: .\apache-maven-3.5.0\lib\maven-resolver-transport-wagon-1.0.3.jar
    Attempting to build version: '1.13' use --rev <version> to override
    Found version
    {
        "name": "1723",
        "description": "Jenkins build 1723",
        "refs": {
            "BuildData": "351106b6336fc52f6acf94aabd34ac54fc772432",
            "Bukkit": "cf6548b4fd81f5be6a243eaf00da815c76611495",
            "CraftBukkit": "3f9d7f7770c2c700ef1cc2e9568cfb253996eff8",
            "Spigot": "69774b3e4419d3213023b46dc791214bd39f48d6"
        },
        "toolsVersion": 75
    }

    Pulling updates for C:\Users\KeterDev\Desktop\git\Spigot\buildtools\BuildData\.git
    Successfully fetched updates!
    Checked out: 351106b6336fc52f6acf94aabd34ac54fc772432
    Pulling updates for C:\Users\KeterDev\Desktop\git\Spigot\buildtools\Bukkit\.git
    Exception in thread "main" org.eclipse.jgit.api.errors.JGitInternalException: Invalid ref name: origin/master
        at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:163)
        at org.spigotmc.builder.Builder.pull(Builder.java:570)
        at org.spigotmc.builder.Builder.main(Builder.java:287)
        at org.spigotmc.builder.Bootstrap.main(Bootstrap.java:29)
     
     
  2. md_5

    Administrator Developer

    Delete Bukkit and run again
     
  3. I tried that like 3 times already, I wiped the whole dir and ran BT.jar again.
     
  4. Are you using the latest BuildTools.jar or a version released since 1.13-pre7 came about?
     
  5. Latest.