Solved Cannot Connect To Database

Discussion in 'Spigot Plugin Development' started by Dragon0617_, Dec 23, 2018.

  1. FrostedSnowman

    Resource Staff

    depends on the kind of data you're working with. mongo != sql
     
    • Informative Informative x 1
  2. The static IP is the IP of the machine the server is running on. So if you downloaded mysql and are running it from your own PC, then the static IP would be your IP

    To me, the issue is you're using either wrong host or password. It's the login details that are the issue
     
  3. Update now: mysql won’t let me use the password I use to login. So can’t use Mysql Workbench.
     
  4. I have this issue too, you need to reset the password. It happens whenever I restart my computer or leave it alone for some time I'm not sure why, but whenever I need to use it I just reset the password and I'm good to go. I created a batch file for it so it's easier to do, suggest you do the same. Either way, follow the instructions listed here...

    https://dev.mysql.com/doc/mysql-windows-excerpt/5.7/en/resetting-permissions-windows.html

    Sent from my CPH1719 using Tapatalk
     
    • Like Like x 1
  5. I just might not use it and go to MongoDB since I've been uninstalling and reinstalling multiple times.
     
  6. XAMPP? It offers a MySQL server and it’s really easy to setup. Maybe that might be better than the MySQL Workbench because back when I had Windows Server it didn’t work either.
     
  7. Hmm xampp. That'll work probably better than MongoDB. I'll try it out when I get home from dinner. Thanks.
     
  8. Just reset the password mate, mysql works lol, mongodb does as well, I'm not sure what issue you're having with maven, just include the dependency and I'm unsure if it has a repo but if it does include that too. What's the issue..?

    Sent from my CPH1719 using Tapatalk
     
  9. MySQL Workbench is too damn confusing and not working no matter what I try to do.
    I don't know that much about Maven so.
     
  10. Google to learn about maven, these are spigot forums not maven forums, also MySQL workbench isn't that hard... It's just a way to view the database

    Sent from my CPH1719 using Tapatalk
     
    • Creative Creative x 1
  11. When I try using phpmyadmin this happens:
    Screenshot (35).png
    I honestly give up
     
  12. You are just using a different viewer of the database, the database is the same. Do as I said, reset the password.

    Sent from my CPH1719 using Tapatalk
     
  13. IDK How to reset the password ;-;
     
  14. I linked it to you in the first post I said on this thread >.>

    Sent from my CPH1719 using Tapatalk
     
  15. I tried that it didn't work
     
  16. Besides this is what it looks trying to set this up.
    Screenshot (36).png
     
  17. What did you try.

    Sent from my CPH1719 using Tapatalk
     
  18. Don't use the installer, use the cmd lines to reset the password

    Sent from my CPH1719 using Tapatalk
     
  19. Read it mate come on...

    Sent from my CPH1719 using Tapatalk