Cannot enable Ip Forwarding

Discussion in 'BungeeCord Help' started by 71Zombie, Aug 10, 2019.

  1. Hello, I have sever Spigot servers on the same device connected to a Bungeecord server. In all the Spigot servers I have bungeecord set to true and offline mode set to false and in the Bungeecord config I have IP Forwarding set to true. Whenever I try to join my Hub Spigot server it says "You must enable IP_Forwarding in your Bungeecord config". I have done this yet it still gives me the error message...
     
  2. Can you send your bungeecord config.yml and spigot.yml? on pastebin or some paste tool
     
  3. I find some problems. You probably are triying to connect to the server using only the ip and minecraft automatically uses the port 25565, thats the port of your Hub and not your bungeecord so i recommend you to use the port 25565 on your bungeecord. for that put on bungee config.yml:
    Code (Text):
    host: 0.0.0.0:25565
    also change the port of the Hub from 25565 to another one.
    The other problem is that you have SkyWars and Skyblock on the same port:
    Code (Text):
      SkyBlock:
        motd: '&1Just another BungeeCord - SkyBlock'
        address: 192.168.0.26:25570
        restricted: false
      SkyWars:
        motd: '&1Just another BungeeCord - SkyWars'
        address: 192.168.0.26:25570
        restricted: false
    fix it changing it to a unused one

    PD: remember to set up the ports on server.properties as well
     
  4. D'oh

    Well I actually did just switch the ports from the bungee to the Hub because the MOTD wouldnt show up, it would just be a default motd....

    The Hub originally used to be on 25563 and the Bungee on 25565 but the MOTD would not show even if I had the plugin on Hub or the Bungee
     
  5. bungee config.yml has an option for the motd
     
  6. Sure, but there are also plugins that I would prefer to use...
     
  7. look for plugins that works for bungeecord