can't add overleveled enchantments on my kits in essentials

Discussion in 'Spigot Plugin Help' started by WitherKiller132, Jan 10, 2020.

  1. Hello everyone.
    I have a problem with my essentials kit plugin. I'm using 2.17.1.0 essentials on 1.14.4 server. I can't add overleveled enchantment on my kits. For example, i can't add sharpness 10 (X) on my sword. It gives me level 5 (V). I also turned 'unsafe_enchantment' to true in essentials but it doesn't work. when i try to check kits.yml i see it's name changed to kits.yml.broken.(a long number). Can anyone help me how to fix this?
    Thanks for your time
    Best regards
    WitherKiller132
     
  2. are there any errors in the console?
    if yes, then please show the console.

    Also, have you reloaded/restarted the server after you changed the kits.yml?
     
  3. Like @Bredo said, we need logs and the edited kits.yml you tried to load.

    Be sure to insert the Kits.yml text in a code area:

    Making a code area:
    Press this: upload_2020-1-10_21-12-38.png and select "Code", there, insert the config and select the dropdown on the bottom right that says "General Code", select YAML for .yml files.
     
    • Agree Agree x 1
  4. or use [ code ] [ /code ] and remove the space between code and the [ ]
     
  5. Ehh that could work too, but just make sure to add
    Code (Text):
     [code=yaml] [/ code]
    pls
     
    • Agree Agree x 1
  6. that's true
     
  7. Strahan

    Benefactor

    You can avoid that headache with spacing out the BB code if you use the [PLAIN] tag you know ;)
     
    • Funny Funny x 1
    • Informative Informative x 1
  8. nvm i found the problem. just forgot to put a number for a level of tool enchantment. thanks for your time :)
     
  9. you can close this thread
     
  10. No you can close this thread.

    CLOSING A THREAD:

    Close a thread by tapping More Options... and unchecking "Open". and post a random reply and it will close, you may also edit the title to add "Solved" prefix.