Can't download file/plugins from spigot :'(

Discussion in 'Spigot Help' started by BlueObsidian, Feb 14, 2018.

  1. I dont know what just happened. When i try to download a plugin, my browser cant download it. It says "Failed to download **.jar". I tried to use InternetDownloadManager, but still failed "HTTP/1.1 503 Service Unavailable".
    Help me please <3 :)

    ~my english is bad, im from non-speaking english country
     
    • Like Like x 1
  2. It's possible CloudFlare could be blocking your connection for some reason.
     
    • Like Like x 1
  3. what should i do?
     
    • Like Like x 1
  4. Only bump every 24 hours.
    Try using chrome (if you’re not already)
     
    • Like Like x 1
    • Funny Funny x 1
  5. Try to download the plugin from google chrome or firefox.
     
    • Like Like x 1
  6. That’s what I just said. No need to say basically the same thing I did.
     
  7. Sorry, i didn't saw your message.
     
    • Like Like x 1
  8. Now, the problem is my chrome is not working.
    Its not loading any page (included it self homepage)
    same as Mozilla Firefox, im currently using UCBrowser.

    Ill try every browser, included InternetExplorer.

    But the question is... Why spigotmc/cloudflare block me with 503 Http error?
     
  9. 503 Service Unavailable

    This basically means the web server (it's client side error msg) reports back the http status code 503, that the service you've tried to reach is currently (temporarily) not available. If it's not temporary, because it happens to your connection to it each time, it might be blocked. Then 503 isn't the more desirable 'blocked' return code, but it happens.

    Yeah, maybe your IP or ip range has been part of a (recent) flood/hack attack against spigot, cloudflaire, some host.. and the result is that you're blocked.

    Quite strange that the download itself doesn't work, but browsing the site doesn't give an issue.

    Get a VPN and a custom DNS service, and try again. Go with a lesser known one, so they're not blocked by default either. ProXPN or TorGuard might work. The service then thinks you're from a different country, or at least a different IP range, and you bypass that protection. The DNS change also helps 'kinda hide' the country origin.

    Plugin downloads seem to work for us, so it's specific to you (or your iprange).


    [edit]
    How does the page look like, is it pure Apache 503 error? Or a custom DNS result 503 error, maybe a cloudflare designed page reporting that?
     
    • Like Like x 1
  10. If that did not work, you can maybe try to turn off your firewall, I know that that worked for me.
     
  11. When i click download, it shows me "Checking your browser blah blah blah" then it start to download, but it failed. The only thing that work is external download (because its not from spigot)
    upload_2018-2-15_11-32-10.png
    It doesnt shows 503 error, but i know the error from the internetdownloadmanager.
    upload_2018-2-15_11-31-4.png
    It same as when i download the file in my browser, but without the error message, just "Failed to download" message.
     
  12. Its already turned off, still same.
     
  13. Have you tried another browser? A VPN? Restarting your modem? Did you have this error before?
     
  14. 1.) Yes i have tried another browser
    2.) I dont know how to use VPN, im using WIFI
    3.) I didnt use Modem, but i did restart my WIFI.
    4.) No
     
  15. sounds like you have malware, suggest you run something like malwarebytes or something similar. Would even recommend running a virus scan afterwards as well. If nothing turns up for either of those, then my only other guess would be something hijacked your browsers so ensure you don't have some weird plugin enabled.
     
  16. Remove InternetDownloadManager and any shady browsers you might have and reboot then try again. If that doesn't work, download MalwareBytes and run a full system scan, following its suggestions.
     
    • Winner Winner x 1

Share This Page