Solved can't find main class after adding new classes?

Discussion in 'Spigot Plugin Development' started by Aspens, Apr 26, 2017.

Thread Status:
Not open for further replies.
  1. hey, so i added 2 new classes that I don't call/initialize until the player enters a command.
    But, now spigot can't find my main class?
    upload_2017-4-25_19-18-3.png
    and, i changed it to cf.aspens.Main and it still doesn't work
     
  2. In your plugin.yml, why do you set :

    Code (Text):
    main: cf.aspens.Main.java
    why *.java? you just have to set the path to your file. ;)
     
    • Like Like x 1
  3. this is kind of a XY problem, it was cf.aspens.Main but i set it to .java to see if that would fix anything :p sorry for confusion
     
  4. Does the jar actually contain that class; are you exporting it properly? Open the jar and check.

    Also, .java is sourcecode. bytecode is a .class file. Look in the jar.
     
  5. And now, what's the error?
     
    • Like Like x 1
  6. ah, i have fixed it.. its because i changed some names before i exported
     
Thread Status:
Not open for further replies.