1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Can't get H2 and eclipse to work!!!!!

Discussion in 'Bugs & Feature Requests' started by EvilPeanut, May 22, 2013.

  1. Hello,

    I can't get H2 to work with eclipse and its really getting annoying.
    Heres the error i get:
    Code (text):
    2013-05-22 15:49:39 [SEVERE] java.lang.ClassNotFoundException: org.h2.Driver
    2013-05-22 15:49:39 [SEVERE] at java.net.URLClassLoader$1.run(Unknown Source)
    2013-05-22 15:49:39 [SEVERE] at java.net.URLClassLoader$1.run(Unknown Source)
    2013-05-22 15:49:39 [SEVERE] at java.security.AccessController.doPrivileged(Native Method)
    2013-05-22 15:49:39 [SEVERE] at java.net.URLClassLoader.findClass(Unknown Source)
    2013-05-22 15:49:39 [SEVERE] at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader.java:87)
    2013-05-22 15:49:39 [SEVERE] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:53)
    2013-05-22 15:49:39 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2013-05-22 15:49:39 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    2013-05-22 15:49:39 [SEVERE] at java.lang.Class.forName0(Native Method)
    2013-05-22 15:49:39 [SEVERE] at java.lang.Class.forName(Unknown Source)
    2013-05-22 15:49:39 [SEVERE] at me.evilpeanut.H2Controller.<init>(H2Controller.java:11)
    2013-05-22 15:49:39 [SEVERE] at me.evilpeanut.EvilBook.onEnable(EvilBook.java:134)
    2013-05-22 15:49:39 [SEVERE] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
    2013-05-22 15:49:39 [SEVERE] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:457)
    2013-05-22 15:49:39 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:383)
    2013-05-22 15:49:39 [SEVERE] at org.bukkit.craftbukkit.v1_5_R3.CraftServer.loadPlugin(CraftServer.java:305)
    2013-05-22 15:49:39 [SEVERE] at org.bukkit.craftbukkit.v1_5_R3.CraftServer.enablePlugins(CraftServer.java:287)
    2013-05-22 15:49:39 [SEVERE] at net.minecraft.server.v1_5_R3.MinecraftServer.j(MinecraftServer.java:310)
    2013-05-22 15:49:39 [SEVERE] at net.minecraft.server.v1_5_R3.MinecraftServer.e(MinecraftServer.java:289)
    2013-05-22 15:49:39 [SEVERE] at net.minecraft.server.v1_5_R3.MinecraftServer.a(MinecraftServer.java:249)
    2013-05-22 15:49:39 [SEVERE] at net.minecraft.server.v1_5_R3.DedicatedServer.init(DedicatedServer.java:152)
    2013-05-22 15:49:39 [SEVERE] at net.minecraft.server.v1_5_R3.MinecraftServer.run(MinecraftServer.java:388)
    2013-05-22 15:49:39 [SEVERE] at net.minecraft.server.v1_5_R3.ThreadServerApplication.run(SourceFile:573)
    I have the H2.jar as a referenced assembly and i see no reason why it cant see the class..
     
  2. No. Im trying to solve a bug.