cant get MCMMO working for spigot 1.12?

Discussion in 'Spigot Plugin Help' started by aranc47, Jul 24, 2018.

  1. i cant get MCMMO working for spigot 1.12?

    ive tried downloading the lastest build and a few of the previous versions aswell but none work it sees the plugin but then it comes up with this in the command prompt

    upload_2018-7-24_17-37-53.png

    if you know how to fix this problem please let me know as i really wanna play with mcmmo on the server

    thanks
     
  2. Heyo,
    So, what's going on is that in 1.12, all dye's were moved to individual Material fields. In this version of the plugin, it's attempting to find Material.INK_SAC, which no longer exists. This is an issue that must be fixed in code, preferably by the author of the plugin.
     
  3. Seems like there is something wrong in the Configuration there is no Material called INK_SAC in 1.12. It is called INK_SACK.

    No. That happened in 1.13 not 1.12
     
  4. Hmm... I was checking the javadocs for 1.12.2, and it was there. Perhaps they were the 1.13 docs incorrectly labeled.
    But yea, haven't used McMMO much, so I guess I wasn't really qualified to answer this question xD. Took my best guess though.
     
  5. so what do i need to do to get it to work? ive been trying to get it working for 3hours now i tried playing on 1.11.2 and that didnt work either
     
  6. In your treasures configuration file, find where it says INK_SAC and change it to INK_SACK, that should fix your problems.
     
  7. everything in my treasures config says INK_SACK with a different colour at the end
    https://gyazo.com/d1fcd00b5a9d02695b291261eae5f440
     
  8. Okay so what is happening is you used one of the NEW builds, im assuming being made for 1.13
    So you need to revert back to an older McMMO-1.5.10 build, Which also means, you will have to delete the McMMo folder, because the newer plugin created the wrong files for you
    Use this build, I tested it, and it works
    https://popicraft.net/jenkins/job/mcMMO/15/