Can't import some package

Discussion in 'Spigot Plugin Development' started by owningz2, Aug 5, 2019.

  1. So basically i wanted to try to update a abandoned plugin from 1.13 to 1.14

    -I update the dependency already from 1.13.2-R0.1-SNAPSHOT to 1.14.4-R0.1-SNAPSHOT

    I'm Having trouble with this Error rhighlighted code:

    import com.mojang.authlib.GameProfile;

    import net.minecraft.server.v1_14_R2.EntityHuman;
    import net.minecraft.server.v1_14_R2.World;

    public class EntityHumanNonAbstract1142 extends EntityHuman {

    public EntityHumanNonAbstract1142(World world, GameProfile gameProfile) {
    super(world, gameProfile);

    getDataWatcher().set(bx, (byte)0x7f);
    }

    public boolean isSpectator() { return false; }

    public boolean u() { return false; }

    }

    It's very hard for me.

    Thanks for the help!
     
  2. You are importing from R2 but your Revesion is R1. Try to fix your dependencies and imports and make them match either R1 or R2 :)
     
  3. The maven spigot repository has only the api, not the server with nms and mojang packages
     
  4. He can add a local dependency. Easy as that (most likely the correct spigot version)
     
  5. Yeah but if he imported spigot from its local repository, he will have NMS imports

    No.
    If the problem was the release version, net.minecraft.server should be recognized
     
  6. I could be wrong, but there is no R2 for 1.14 ... its been 1_14_R1 for all versions 1.14 -> 1.14.4

    See NMS wiki
     
    • Like Like x 1