1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Can't make server jar 1.8.x latest buildtools

Discussion in 'Bugs & Feature Requests' started by spyler, May 3, 2015.

  1. Hi,

    I get this error trying to make the server jar files as is using the 'java -jar buildtools.jar' command.
    This is how the error looks like: http://pastebin.com/T8U6We4X
    As far as I know it is the only error, resulting in no server jar files.

    I tried making other server versions using the --rev command going down from 1.8.3 to 1.8.0 using 1.8.0 worked and didn't give any errors.
    So: 1.8.3 = error 1.8.2 = error 1.8.1 = error 1.8.0 = no error

    Any idea's what goes wrong?

    My skill does no go beyond what I can find with google.

    (Previous builds worked but those gave unstable server .jar files and don't contain the security fixes.)
     
    #1 spyler, May 3, 2015
    Last edited: May 4, 2015
  2. 1.8.4 spigot jar is not out.
    as far as i know, the bug that was patched in 1.8.4 was fixed in 1.8.3 spigot.

    Try deleting your buildtools folder except the buildtools.jar and run it!
    Also make sure its exact capitals!

    Running buildtools now, will reply if there is 1.8.4 spigot out (i dont think so!)

    EDIT: 1.8.4 Spigot is not out, as i presumed.
     
    #2 Latouth, May 3, 2015
    Last edited: May 3, 2015
  3. There is no 1.8.4 version. It stated so in the security popup thing on the forums. There is only a fix for the exploit on the latest version of Spigot(1.8.3)
     
  4. I thought so.
     
  5. Thanks for the reply all, but that's not the issue. I knew that.
    I just tried and stated it to be sure and complete. I have tried empty folders and even empty drives. Over 20 times the same error. I changed my post to avoid further confusion, but the problem remains.

    I can't make the 1.8.3, if I run the 'java -jar BuildTools.jar' like this it gives the error. But it's just one error, almost at the end of all the checks that happen. The log I posted is the one that gives information about that error.

    If I run 'java -jar BuildTools.jar --rev 1.8' I don't get the error. I figured I should be able to make a 1.8.3, which doesn't work, with the latest build tools being the one that contains the security fixes. Running the command without --rev should give me 1.8.3 anyway, but it give the same error.
     
    #5 spyler, May 4, 2015
    Last edited: May 4, 2015
  6. Here are the 2 pages on buildtools
    http://www.spigotmc.org/threads/buildtools-updates-information.42865/
    http://www.spigotmc.org/threads/bukkit-craftbukkit-spigot-1-8-3.53745/
    Note the line that says
    "To clarify, running BuildTools with no arguments will give you 1.8.3, whilst using --rev 1.8 will give you 1.8.0!"

    BUT make sure you delete buildtools and get the lastest one before trying to build a 1.8.3 jar! https://hub.spigotmc.org/jenkins/job/BuildTools/
    then it should be as easy as running java -jar BuildTools.jar
     
  7. Are you right clicking BuildTools and hitting 'Git Bash' then typing 'java -jar BuildTools.jar --rev 1.8'
     
  8. To get something I did also ran that one and that one worked. But the ERROR is while hitting Git Bash then typing 'java -jar BuildTools.jar' nothing more.

    So I got a 1.8 using the #36 buildtools but not a 1.8.3.

    So running this: 'java -jar BuildTools.jar --rev 1.8.0' = NO ERROR using buildtools #36 (I get a server .jar version 1.8)
    Running this: 'java -jar BuildTools.jar' = ERROR using buildtools #36 (I get no server .jar files)
     
  9. That is what I used. That is when the error happens.
     
  10. Okay then youll need someone who understands java and look at that error closer.
     
  11. Weird build tools #36 works fine for me. What OS are you running? I'm running windows 8.1 pro :p