Solved Can't use a run.bat

Discussion in 'Spigot Help' started by Kapyyy, Sep 4, 2016.

  1. Without Running as Admin:
    With Running as Admin:

    For the first issue what is the desired java version? Also for the second issue I copied the exact name from the file. I am unsure of what to do. Any help would be great.
  2. latiku


    wtf is "java -server"
  3. Idk I copied someone's bat file and they had that. I removed it without any change.
  4. Right click your bat file and click "run as administrator".
  5. Ok then what?
  6. Then it should launch the jar file? Are there any errors?
  7. [​IMG]
  8. Yes that is one option, but so that you know how it works:
    Command prompt, as with all applications runs in a working directory. When you go to your start menu and run as administrator (the way you did in your second picture), it launches command prompt in the system32 folder. You can change this with the cd (changedirectory) command.
    To change it to the folder you want, you'll need to back up a few folders. you can do that with '../'.
    Run cd ../../Users/cgrot/Desktop/Server
    Then you can run java -Xms=1G -Xmx=2G -d64 -jar paperspigot-1.8.8.jar -o true

    Hope I helped.
  9. [​IMG]

    Not sure if I did it right but still gives me an error.
  10. If you installed it properly, it should have changed the PATH. Maybe it didn't. Go find the folder you installed it to and try
    "C:\\<Where's your java>\\bin\\java.exe" -Xms=1G -Xmx=2G -d64 -jar paperspigot-1.8.8.jar -o true
  11. [​IMG]

    Still not working.
  12. That's because you're running the 32 bit java. Hence, Program Files (x86). This time, make sure you've installed the 64 bit java and run that one. It will be in Program Files, not x86.
    • Winner Winner x 1
  13. Thanks its working now but do I have to run it like this every time?
  14. You can just copy the command into your .bat file. Btw the '-o true' part of your command means your server runs in online-mode=true.
    • Useful Useful x 1