can't use IP connecting server.

Discussion in 'Systems Administration' started by smailchen, Dec 6, 2017.

  1. Why I had port forward my server but I can't connect it with my mychicken IP..
     
    #1 smailchen, Dec 6, 2017
    Last edited: Dec 8, 2017
  2. If the server is running and correctly configured to listen publicly then you haven't port forwarded correctly.
     
  3. Even hamachi's ip also can't connect in my server,i've tried..and I had checked the port forwarded it seems no matter with it,thank you
     
  4. PS: my server setting is basic
     
  5. Is there any drive or setting should I setup?plz
     
  6. Could you post your server.properties please.
     
  7. Strahan

    Benefactor

    I've never used Hamachi so I cannot comment on that, but as far as using your public IP not all home routers support NAT reflection. If you want to test if it's visible to the world, use an external MC status check like Dinnerbone's or something.
     
  8. Could not check the status of XXXXXXX
     
  9. #Minecraft server properties
    #Thu Dec 07 13:02:42 CST 2017
    generator-settings=
    op-permission-level=4
    allow-nether=true
    level-name=world
    enable-query=false
    allow-flight=false
    prevent-proxy-connections=false
    server-port=25565
    max-world-size=29999984
    level-type=DEFAULT
    enable-rcon=false
    force-gamemode=false
    level-seed=
    server-ip=
    network-compression-threshold=256
    max-build-height=256
    spawn-npcs=true
    white-list=false
    debug=false
    spawn-animals=true
    hardcore=false
    snooper-enabled=true
    resource-pack-sha1=
    online-mode=true
    resource-pack=
    pvp=true
    difficulty=1
    enable-command-block=false
    gamemode=0
    player-idle-timeout=0
    max-players=20
    spawn-monsters=true
    generate-structures=true
    view-distance=10
    motd=A Minecraft Server
     
  10. Although I'm almost sure that have the server IP line empty will allow the server to bind to all available IPs, try putting the internet-facing IP address you want the server to listen on at the server-ip= line.
     
  11. I have done it before but still not ok..If even hamachi's ip can't connect it,it is about the internet setting..
     
  12. I can use hamachi now..
     
  13. So if you put in the Hamachi IP, it works?
     
  14. nah,my "server-ip=" is empty,when I import hamachi in my INTERNET CARD,It works.
     
  15. Strahan

    Benefactor

    The odds of a home hosted box having the public IP available on a local adapter is slim to none so this will, the majority of times, just cause the server to not start.
     
  16. Last year and the last last year I can use my public ip easily..
     
  17. can someone here help me... plz
     
  18. Strahan

    Benefactor

    Did you open 25565 on the firewall?

    I don't think you grasp what I'm referring to.
     

Share This Page