Can't use plotsquared!!

Discussion in 'Spigot Plugin Help' started by MrDazzling, May 20, 2016.

  1. so im trying to use plotsquared and if im trying to make a map "/mc create Plot normal -g PlotSquared" it says FAILED and if u try to use any command it dont say anything in game but the consol it says
    [14:09:17 ERROR]: Could not pass event PlayerCommandPreprocessEvent to PlotSquared v3.3.3
    org.bukkit.event.EventException
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.PlayerConnection.handleCommand(PlayerConnection.java:1342) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.PlayerConnection.a(PlayerConnection.java:1185) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_91]
    at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_91]
    at net.minecraft.server.v1_9_R1.SystemUtils.a(SourceFile:45) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.MinecraftServer.D(MinecraftServer.java:721) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.DedicatedServer.D(DedicatedServer.java:400) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.MinecraftServer.C(MinecraftServer.java:660) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:559) [spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_91]
    Caused by: java.lang.NullPointerException
    at com.intellectualcrafters.plot.util.UUIDHandler.getPlayer(UUIDHandler.java:107) ~[?:?]
    at com.plotsquared.bukkit.util.BukkitUtil.getPlayer(BukkitUtil.java:64) ~[?:?]
    at com.plotsquared.bukkit.listeners.worldedit.WEListener.onPlayerCommand(WEListener.java:167) ~[?:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_91]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_91]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_91]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_91]
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.9.jar:git-Spigot-d20369f-7fc5cd8]
    ... 16 more
     
  2. /mc?
     
    • Agree Agree x 1
  3. You mean /mv create plot normal -g Plotsquared? There is a easier way to do this rather than using multiverse to setup a new plotquared world. Have a good look at the resource page of the PlotSquared plugin here Link: https://www.spigotmc.org/resources/plotsquared.1177/. If you need help with the commands make sure to check out this page Link: https://github.com/IntellectualSites/PlotSquared/wiki/Commands. So now if you don't feel like looking at these links and figuring it out yourself then you can type /plot setup and the system should show you through the process of creating a new plotworld. Still stuck? search on google or youtube on how to create a new plotworld with plotsSquared. Hope I helped

    Thx Pixl
     
  4. /mc create Plot normal -g PlotSquared is not a command, is /mv create Plot normal -g PlotSquared, make sure you have the latest version of PlotSquared.