Spigot Carbon 1.8

Adds future Minecraft content to older Spigot versions. (Spigot 1.7 ~> Spigot 1.8)

  1. Can I do that minecraft 1.8 blocks are alone in the world survival so users can enter the overworld with minecraft 1.7?
    Sorry for my bad English..
     
  2. I'm just going to assume that you mean if 1.8 blocks can be used in the world with 1.7 clients, and the answer is yes, all you need is ProtocolLib and to remove the 1.7 client entries in protocolblocker.yml.

    Bear in mind, flawless stability is not guaranteed, so obviously I'm going to say to use Spigot 1.8 instead for 1.8 support. Carbon will soon be updated for 1.9 snapshot and beta releases, so the 1.8 version will be permanently unsupported beyond that.
     
  3. I like how this is still a top-downloaded resource 2 months after spigot 1.8's release lol
     
  4. WFloydBoy

    Supporter

    If I were to generate a world with multiverse, would I have to enter a custom generator or will it automatically generate a 1.8 terrain?
     
  5. It will generate 1.8 terrain if the world is listed in Carbon's config in the worlds: [] option, it doesn't matter what plugin is used to run that world.
     
    • Informative Informative x 1
  6. Thanks for all your hard work!
     
  7. Je ne en peux pas patcher l'ergot .BPS fichier est manquant: '(
     
  8. I really want to understand why Carbon does not work with Spigot because I have the Spigot 1649 build that allows 1.7 and 1.8 versions on my Minecraft server and I want 1.8 players on my server to be able to use 1.8 blocks. Every time I try installing Carbon 1.8 or 1.5 it won't generate a folder and work with Spigot
     
  9. WFloydBoy

    Supporter

    I'm not sure if you're open to fixing issues anymore but I found quite a large one and a simple fix would be to be disable depth strider so if that's possible let me know.
    When players are on 1.7.10 and enchant, they can still get the 1.8 enchants on the items. Now when a 1.7 player places these items in anvils, their game i guess reads it and crashes the client instantly.
     
  10. I am using a patched Spigot #1649 with spigot-20141001a.bps and am using ProtocolLib-Spigot-3.6.0-20140905.001027-2.jar along with the Carbon 1.8. I started my server and everything runs fine. No warns or errors, and I can connect with 1.8, but if I try to use 1.7.10 it's blocked - it just says Spigot 1.7.10X in red on the Play Multiplayer list. Can anyone give me a hand please? I'm a quick learner, I'm probably just missing something simple. Thank you very much!
     
  11. WFloydBoy

    Supporter

    Delete the text in protocolblocker.yml
     
    • Like Like x 1
  12. You're awesome, man. Of course it was something simple I overlooked. After hours of learning the complicated stuff it never occurred to me this was a simple issue. haha! Thank you!
     
    • Friendly Friendly x 1
  13. Great. It still works
     
  14. Thanks for this plugins.
     
  15. does carbon support other 1.8 plugins? or does it just work with 1.7 plugins? (pretty sure someone else has asked the same, but over 1k comments, i find it easier to ask again :p )
     
  16. Carbon only works on 1.7.10 or lower. That's what it was meant for. You need to use plugins meant for the 1.8 PROTOCOL HACK only if you use Carbon and an old version of Spigot.
     
  17. I wouldn't think so, as this wouldn't use the new named convention because it still uses ID's and some assets that were added in 1.8.

    there may be a few that could work? but i wouldn't hold much
     
  18. If my creative server used this plugin, go to 1.8. Can i rollback to 1.7 with this plugin again ?
     
  19. No.