1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Solved Changing spawner type results in invisible spawner.

Discussion in 'Bugs & Feature Requests' started by Jigsaw, Jan 22, 2013.

  1. Jigsaw

    Supporter

    Using:
    Code (Text):
    [INFO] This server is running CraftBukkit version git-Spigot-430 (MC: 1.4.7) (Implementing API version 1.4.7-R0.2-SNAPSHOT)
     
    When I place a normal pig spawner and then use a plugin that changes the spawner type it results in the spawner changing to the specidied type, but it still spawns pigs. The pigs will not stop spawning even after removing the spawner. They will keep spawning out of thin air where the spawner used to be. This worked just fine on Spigot #397

    Edit: Just tested with no plugins on build #430. Started a brand new map with no plugins and placed a pig spawner. Then destroyed the pig spawner and pigs will keep spawning. This bug is present with 0 plugins.
     
    #1 Jigsaw, Jan 22, 2013
    Last edited: Jan 22, 2013
  2. Confirmed.

    Using build 438.

    Even after destroying the spawner it still spawns pigs.

    When i first set using //set spawner|zombie, it spawned 1 zombie but then pigs again.
     
  3. Jigsaw

    Supporter

    Yeah, this is quite a big problem for my server. Players are allowed to purchase spawners and until this is fixed I am unable to provide them spawners or they will get random pigs all over. Hopefully it is a simple fix. :)
     
  4. Jigsaw

    Supporter

    #4 Jigsaw, Jan 24, 2013
    Last edited: Jan 24, 2013
  5. Oh man i was posting in the wrong thread :(.

    Anyways i can confirm this on build 452. Seems something happened after build 417 which is causing this as i run 417 on my live servers. Pig Apocalypse anyone?

    Not sure on the server crash issue as i was unable to reproduce that, i place spawner, pigs spawn, change spawner using essentials /spawner zombie, zombies and pigs spawn, break spawner, pigs continue to spawn but no zombies or server crash. Tested on spigot 452
     
  6. Jigsaw

    Supporter

    FuRiouSOne the crash only happens if you are in creative mode. It happens on all of the latest Spigot and CraftBukkit builds. I wouldn't recommend testing it on your actual server. I have already submitted a ticket for the infinite pig issue at Bukkit. Feel free to vote it up to hopefully get it addressed soon. https://bukkit.atlassian.net/browse/BUKKIT-3501
     
  7. I was in creative when i was testing and didnt see a crash. As admin i am always in creative unless i need to change to survival.
     
  8. Jigsaw

    Supporter

    I saw that. :)