ChatEX Prefixes?

Discussion in 'Spigot Plugin Help' started by Leafdroid, Jun 26, 2016.

  1. So basically im trying to make the prefix use the PEX groups prefix instead of groups name, is there a way to do this? I want it to display "&5Immmortal" wich is the prefix for the Immortal group, but when I use %group it uses the groups name and not prefix.
     
  2. First can you say me your chat plugin?
    Second: you can do in pex: prefix: '[Prefix]'
    Third maybe %prefix?
     
  3. My chat plugin is ChatEX, and when I use the %prefix variable it doesnt display anything.
     
  4. In PEX you simply can do:
    Code (Text):
    Immortal:
      options:
        prefix: '&5Immortal'
     
  5. This is exactly how it looks in the Permissions.yml
    Code (Text):
     
      Immmortal:
        default: false
        prefix: '&f[&5Immmortal&f] '
        inheritance:
        - Survivor
        - Scavenger
        - Slayer
        - Master
        - Warlord
        build: false
     
     
  6. It should be:
    Code (Text):
      Immmortal:
        default: false
        options:
          prefix: '&f[&5Immmortal&f] '
        inheritance:
        - Survivor
        - Scavenger
        - Slayer
        - Master
        - Warlord
        build: false
     
  7. Yay it fixed it, now it all works. Thank you :D
     
  8. No problem :)