Spigot ChatRooms 2.3.0

Better private group chat

  1. Hmm... compression may be breaking it? Don't know if that happens. I'd recommend just downloading a new copy.
     
  2. Okay. Will do. I will try asap.
     
  3. Still same error =/
     
  4. Can you paste the entire exception stack trace? In the pastebin you provided earlier it appears to have been cut off from the top.
     
  5. im sorry but i run it on a screen on my dedi i cant paste all of it. im trying.. i think its just filezilla that fucks things up. ill try zipping it in a folder with the jar.
     
  6. What exactly are you zipping? like just the plugin jar? or the plugin jar and its data folders?
     
  7. just the jar.
     
  8. ill try zipping the jar with the folder in a folder xP
     
  9. If you can't paste the whole stacktrace directly from your console, i would recommend going to <your server directory>/logs/latest.log. You can find the whole stacktrace there.
     
  10. will do asap.
     
  11. Ohhhh.... I think I know what the problem is.. What version of Java are you using?
    The plugin was written and compiled under Java 1.8.0_45. If you have a lower version such as 1.7 the plugin may not work.
     
    #32 pleasedeletethis, Jul 16, 2015
    Last edited: Jul 16, 2015
  12. Java 8
     
  13. Can you paste the output of
    Code (Text):
    java -version
    here?
     
  14. java version "1.7.0_79"

    OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu1)

    OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

    0_0 oops... its 1.7...
     
  15. Ah yes. you're using java 1.7. The plugin was compiled under 1.8
     
  16. darn... most of plugins worked with 1.7 -_- can u get it to work with 1.7? or how do i update my java without turning off my servers and in linux?
     
  17. I will try to see if i can compile it with 1.7.
    Unfortunately, you will have to stop your server to update your java if you are going to do that. What specific flavor of Linux are you using?
     
  18. I already updated to 1.8 =D its owrking
     
  19. Yeah, I don't think I can get a Java 7 JDK, as Oracle has actually discontinued free downloads due to Java 8 being the latest version.
    I believe I saw earlier that you were using Ubuntu, so you can get the Oracle Java 8 by using these commands (stop your server first):
    Code (Text):
    sudo add-apt-repository ppa:webupd8team/java
    sudo apt-get update
    sudo apt-get install oracle-java8-installer
    After this, make sure you got the latest version by doing
    Code (Text):
    java -version
    again.